ZWO camera direct control?


#1

I’ve used ASI ASCOM to control the 1600MMC. I know many requested direct control and I see it was added? I installed a ZWO driver and…

  1. why is the wrench BLACK when selecting the ZWO camera?

  2. After working for a bit - I get this error. (pop up) Connection error, "Erro connecting to ZWO camera! Index was outside of the bounds for the array?

I actually can’t connect either way right now.


#2

Hi Ron,

I just was checking the forum about that issue. Currently I am struggling too with that problem. I tried everything imaginable, nothing works. The cameras simply show black screens after some exposures. There is one strange thing, the ZWO´s work in all other Applications that I owned already previously.
For SGP I do run the V3, can´t say if it worked under 2.x.
None of the control plugins for the 1600mmc works, be it native or ASCOM.

Very best and CS from Luxemburg!

Lex


#3

Afterburner,

your mentioned connection error also happens quite often on my I5 4c, 8gb DDR3, SSD and USB3.0.Solving it by unplugging/plugging the cam…

CS,

Lex


#4

Because there are currently no settings on the native implementation. For the most part I’d recommend using the ASCOM driver unless you just want to play with the native driver.

Thanks,
Jared


#5

It is not just a matter of playing with the native driver. Jeez, this is supposed to be a major upgrade. I have a ASI 094 which was working with version 3. Then the ASCOM driver stopped working and did the endless download looping. Switched to the native driver and it worked. Then it didn’t. Now nothing works.

Given that ZWO’s ASI cameras must be a major part of the camera market and a huge help in selling SGP, it would be nice if this stuff worked.

Really tired of unplugging things, rebooting, reinstalling drivers, on and on.

I’d surely pay a lot more money to get this thing to work.

Ugh.


#6

Yet there’s continual pressure to reduce the cost of software, even of SGP that’s already pretty cheap.


#7

I tried to use the native driver in PHD and ASI(1) driver in SGP at the same time and that didn’t work. It doesn’t work in reverse either. I can only use the ASI(1) and ASI(2) drivers for both cameras to work at the same time. I suspect the native driver and ASCOM drivers were never intended to be used at the same time!

Ciao,
Mel


#8

I could be wrong as I don’t follow here that closely. But If I recall right. I remember seeing the ASIcam direct driver being touted as part of 3.x. And the reason for the native driver was to allow us to change driver settings in a sequence. (changing gain during a sequence?)? I now have two ASI cameras. I hope to image with the cameras side by side. Hoping that won’t be a issue.


#9

ASCOM drivers tend to be fairly simple, all they do is convert commands using the ASCOM specification to commands to a device specific driver. This is known as a façade. This is particularly the case with cameras where all that’s needed is to communicate with a camera specific driver.

Direct control from SGP does the same thing, the SGP direct control driver connects to the same camera device driver and sends the same commands. Most of the complexity should be in the camera driver or SGP.

What this means if that direct control may make very little difference. For the most part the same software is used so if there are problems they will still be there.

Using two cameras at the same time is another can of worms. The camera control software has to be written to allow for this at all levels, from the camera drivers, through the ASCOM (or direct) interface. I’ve done ASCOM drivers for a couple of cameras and it’s not at all easy.


#10

Hi guys,

I have really been confronted to this issue several nights, really wasting precious imaging time.
As my choice is SGP I really want this to work. As mentioned the native control was also one of my personal decisional points go the way of sticking to SGP by upgrading to V3.
Sadly I do not understand why all “other” software is working flawlessly?

Hopefully this can be solved…

CS

Lex


#11

SGP gives me an error now when I connect the camera. And yes - all other software using the direct driver works fine. I’ve recently been reduced to using ASIcap for recent acquisitions.

check it out.


#12

Ok;

I ended up restoring Windows; changing the cables; updating the drivers… Nothing!

So I thought the problem may be the hub of the 1600! As I bought a quiet expensive USB 3.0 I connected it to the cam. Disconnected my EFW; put it on its own cable and boom it worked! So the hub has got to be wrong.

Now the driver reports the usage oh USB 3.0, finally nailed it.

Now it also works with SGP with USB limit set to 90.

However I wonder why it worked with ASICap before and not with SGP. I often read that the ASI’s are really picky about propper USB signals.

In the end I can fully use my favorite tool SGP!

Very best!

Lex.


#13

what hub did yuo get? I have one that wasn’t expensive. (it works for most things) but I’d not mind a better performing one. I’d also like one that can power at least one output at 2A. My quark needs at least 1.5A and I have running another cable from a AC outlet. (when I could run a short cord from a USB hub on the scope.


#14

I am using no hub anymore! I run the cam directly over a good quality usb 3 cable. I was talking about the onboard hub of the asi 1600.
I do not use this one anymore; as everything went ok after connecting the guider and the filter wheel directly via cable to my pc.

Best,

Lex.


#15

I tried a non powered hub and had the same problems. I replaced it with a
powered 3.0 hub and have no problems. I don’t like long cords from the
device to the computer. So I use short clean cables to the hub on the scope
and then one cable from the hub to the PC. (no issues). I have filter wheel
on short cable to 1600MMC hub (2.0) then the camera 3.0 to the hub. Works
fine, no issues. My guide camera (lodestar) also short cable to hub, dual
focuser to hub. Quality 3.0 hub is powered by powerpole 12v unit. I’m
glad you solved your issue, but a hub can be used if powered and a decent
quality unit.


#16

Lex - direct lines are great, but get messy. My dome is super clean with one line from mount to PC. A hub is essential for me. = (


www.mainsequencesoftware.com