ZWO Filter Wheel is moving my Moonlite Focuser

Something new started happening this evening that never happened before. I added no new equipment or did any updates since the last time I used SGP - it just started for no apparent reason.
I have a Moonlite Focuser and am using the Moonlite DRO driver in SGP and it works fine. I have a ZWO EFW and am using the most current ZWO ASCOM and EFW drivers/software. Before this evening, all played well.
Tonight, when I instructed my EFW to move to a different filter, the filter wheel control windows shows a “changing” message (it normally says “moving”) and the focuser starts traveling. I can’t make it stop at that point without disconnecting SGP from both and restarting.
I went through several iterations of unplugging USB cords, restarting the computer, etc. but nothing has worked. Both pieces of equipment work normally in SGP when only one is connected. With both connected, the focuser works fine as well, but when I attempt to change filters I get the problem.

Any ideas/help???

JT

Logs, must have logs.

I’ll find them. This is my first time trying to deal with logs. Do you want SGP logs, ASCOM logs?
I did look at the ASCOM profiler and it shows the filter wheel on com5_1 and I know the focuser is using com5.
I also noticed that in SGP, when a filter change is directed, the message window in the filter control window momentarily shows “changing” when the filter wheel is moving in one direction and then quickly changes to “moving” and moves the filter. When that happens, the focuser makes a little jerk in the out direction but stops. When the filter wheel is moving the other way, the “changing” never goes away and the focuser drives in and never quits unless I stop it.

See if this works for you, Chris. I put files from the last three days/nights. Things “appeared” to work fine on the 23rd. I noticed the quick swap between “changing” and “moving” on the 24th, but there were not issues. the 25th was when things really started acting up.

Google Drive Log folder

Thanks for the driver logs. I really need the SGP logs and the driver logs for the same time.

This is what I can see
The only Moonlite logs are on the 25th and I see a series of short connections followed by disconnects and often almost instant reconnects. Some seem to be coming from SGP and some from the diagnostic.
Some start moves but are disconnected before the move completes.
This is a summary of the multitude of log files:
184420 Connect
184420 Position 3485
184438 move to 17976
184451 Position 6487, ismoving true, Disconnect


185617 Connect started
185618 disconnect


185627 Conect using Com 1, then Com 2, no response
185628 Connect on Com5 successful
185629 Disconnect
185630 Connect on COM6 no response
this is probably the diagnostic connection


185640 Connect on COM 5 successful
185640 Position 0
185651 move to 17930
185658 ismoving true Position1650 Disconnect


190613 Connect attempt COM1 no response
190614 Connect attempt COM2, no response


191022 Connect attempt on Com5, no response


191028 Connect attempt on Com1 and Com2 both no response
191030 Connect attempt Com5 OK
191031 Connect attempt Com6 no response


191222 Connect COM5 OK
191222 positon 0
191230 Move 17930
191307 ismoving true, position 8600, Disconnect


191919 Connect COM5 OK
191919 position 8652
191919 Disconnect


191926 Connect COM5 OK
191926 Position 8652
191933 Move 0
192011 position 0 reached, IsMoving False
192025 move 17930
192053 IsMoving true, Halt, position 6536, IsMoving False
192053 Move 0
192956 IsMoving true, Position 6025, Disconnect


192058 Connect COM5 OK
192058 Position 6021
192102 Move 0
192130 Position 0, IsMoving False
192135 Disconnect


192203 Connect COM5 OK
192204 Position 0
192229 Disconnect
192230 Connect OK Position 0
192453 Disconnect


192702 Connect OK
192705 Position 0
192713 Move 17692
192718 Position 1162, Disconnect


192756 Connect OK
192756 Position 1167
192801 Move 0
192807 Position 0, IsMoving False
192809 Disconnect


200426 Connect COM5 no response


This is for the most part fine, connections t the correct COM port are fine and all the commands work correctly.
Obviously those initiated by the diagnostics to diferent com ports fail.

There are two connect failures at 191022 and 200426. i don’t have the context so don’t know why. Maybe the focuser hadn’t been switched on or hadn’t had time to finsh it’s internal initialising when the connect was attempted.

The constant connecting and disconnecting is a concern, it won’t help give a reliable connection and it’ worth pointing out that the disconnect process halts any move that’s in progress as a safety measure.

There is no log evidence of a filter wheel.
The only moves are those commanded by the controlling application.

Not sure how much this helps but there’s no real evidence of a problem.

Thanks, but I’m clueless about log files and debugging this stuff. I put every SGP log file I have from the 23rd to this morning into a folder on that same Google Drive. Let me know if those are what you’re looking for.

I suspect there are a LOT of disconnects and reconnects. When this started happening, I went through a bunch of that. I had to disconnect things to get the focuser to stop travelling. I went through several variations to see what worked and what didn’t. I shut SGP down, did several computer restarts trying various USB connect sequences and connecting things in SGP to see if I could go around the issue. I tried re-installing drivers for the filter wheel and focuser. On and on. I have no idea how to toy with any com port assignments, etc. All I know for sure is that the filter wheel and focuser are both trying to use Com5 and I can’t make the Moonlite go to a different com port and I have no idea what to do from there. The other laptop that I connected is brand new with a brand new install of all the software and drivers and had never been connected to the equipment; so I figured I’d try that one and maybe it would work…nope; exact same problem!

I have the newest Windows 10 update/version on both laptops but, as I said, things were fine on Tuesday and wednesday and went sideways last night.

I have a work around, but it’s not satisfactory as a long-term solution.

There should be no need to disconnect the focuser to stop it moving, the stop button in SGP should do that.

I don’t have any context for the multitude of log files so really can’t provide more help. Trying to match the SGP logs and the Moonlite logs would take many hours. Some clues about the date and time that something happened would help.

What I can say is that the moonlite focuser is working properly. There is no evidence that it isn’t.

I can’t say anything about the ZWO filter wheel. There is no log data at all about that. You will need to contact the ZWO people to get help with debugging what it is doing.

AllI can say is that if the filter wheel is trying to use the same COM port then bad things will happen. You can expect to see the sort of access denied errors that you get when you try to connect. The focuser driver is definitely using COM5 successfully. I don’t know if the ZWO wheel can be set to use a different port, there’s no indication of what port it is using in the diagnostics log. That’s something you need to discuss with the ZWO people.

Thanks Chris. Yes, the Moonlite works perfectly. Even with both pieces hooked up, it works perfectly. It’s only when the filter wheel moves that bad things happen and in the case I can’t make it stop without disconnecting it. I know it’s a com issue since both things are trying to use com5. I guess I’ll have to learn how to force the filter wheel to use a s pacific com port. I know it’s possible but it’s a computer thing.

Thanks
JT

Maybe this is setup in a way that causes massive movement?

http://www.mainsequencesoftware.com/Content/SGPHelp/AutoAdjustFocusPerFilter.html

1 Like

Good point. I’ll try turning that off and see what happens.

Chris: I think I solved the issue; it was basically com port conflicts as far as I can tell. I had to go into device manager, remove a bunch of port assignments and reconnect things to let windows work it out.

In the process of trying to work things out, I went through a cycle of trying to uninstall the moonlite software/drivers and re-install it. What I ran into was that the software didn’t really “uninstall” and when I tried to re-install it all I ended up doing was adding a second moonlite focuser somehow. So now, in SGP, I see two focusers. No biggie, really, but I have to ask…do you know how to go about actually, completely removing the moonlite focuser software? Is there a trick of some kind?

Ken. Yes, I had smart focus turned on and SGP was set to adjust the focus per filter. I can’t say for sure that it was the problem. I forced windows to reassign com ports to everything and now it appears to be OK…for now. You may have been right, but I didn’t get a chance to test it for sure due to my wiping the ports before giving it a try.

Chris. Ken was right in his guess. If I turn on the “auto adjust focus per filter” feature in the focus panel, it starts the focuser moving to the correct focus position for the filter chosen and, for some reason, I failed to realize that the focuser was racked in pretty far and had a long way to travel to get to the correct focus position.

The system is actually working as advertised and I’m an idiot.
James

www.mainsequencesoftware.com