Camera timeout prevented abort from running


After last night’s session my scope was not parked, and this error message was showing: “Camera timeout, could not download image! Aborting sequence.” But the abort didn’t actually run until I cleared the error message in the morning. I think I had a similar error earlier in the night (just before going to sleep and leaving the rig running), which I thought I had cleared by disconnecting and reconnecting the imaging cam from SGP. The log is here:

You’ll see that the system starts an exposure about 1:24:24, lets it run 20 mins as expected, but then reports an error saving it. Then nothing happens until I cleared the error message at 7:24:37

A second issue, perhaps related: I took flats in the morning, mostly with no problems, but at one point I stopped frame and focus, and the camera got stuck in downloading. I had to shut down SGP and restart it to finish grabbing my flats. I remember this came up before, but I thought it had been solved. Can anyone remember? Camera is an SXVR-H694, running via the ASCOM driver. Thanks for the help.

Kevin hangs during image download - SXVR-H694

The first thing to check with communication errors like this is your usb
cables and especially usb hub if you use one. This can be maddeningly
difficult to narrow down, but make sure to test and replace cables if


Make sure you are not using the latest SX driver. It has stability issues and sometimes disconnects camera. I know you are using ASCOM driver but it still uses low level SX drivers. See SX warning from their web site:

I also use older SX driver because I had Lodestar/Superstar disconnects with latest SX driver.



Wow Peter, I don’t remember seeing that. How do I tell what version of SX
drivers are installed? Doesn’t show up in the list of installed programs.


Hi Joel,

I am at work right now so I am not sure. Check in Device Manager and it may show version number. If you are not sure, you might as well download and install the previous version driver to be safe.



I’m not so much worried about the com error/camera timeout as the fact that it prevented SGP from aborting the sequence and putting the scope in a safe position. Nothing happened in SGP until I cleared the error message in the morning. I’ll check on the SX driver issue and the cables, though. Thanks for the advice.



I’m at work too; I’ll have to check device manager when I get home. I’m
curious about this because on my OBS computer I’ve had no problems with
this, but on my travel miniPC I’ve noticed this from time to time. The
miniPC was set up just a few months ago with all the latest drivers so I’ll
have to double check that one for sure.


Hmmm. Here’s what device manager shows on mine:

Driver Date: 3/2/2013
Driver Version:
Driver Provider: Starlight Xpress Ltd

I’m using the latest ( ASCOM driver from Bret.



I went home for lunch and it appears that the date for latest SX driver is 2015 and for previous version is 2013. So look for the driver’s date.



Note that the “previous” version SX driver has been recently updated specifically for their newest “Ultrastar” autoguider so you will see a new date of 2015 for the “previous” version which makes it more complicated to decide which version driver installed on your computer is the latest.



I thought we eradicated all of these blocking scenarios from the sequencer (ones that stop end of sequence actions without user interaction). This has been corrected. I am not sure why your camera times out, but, in the future, at least your equipment will be provided the opportunity to take care of itself.


Excellent! Thanks, Ken. Peter, thanks for the update on the driver. I’m sitll not quite sure if I should update. I asked Terry, and I’ll let you know what he says.



Aha - just got a reply. Terry says it looks like I have installed, so there should be no need to update. I’ll let you guys know if I run into this error again.