[Smart] Auto focus help


#1

I need some guidance understanding the auto focus routine.

I’m running autofocus with “Smart AF” off, SGP does it’s thing and says that the best focus point is 23200 but we can clearly see on the graph that the best “estimated” focus point is bellow that, it should be where the two lines intercept. No matter how many times I hit “Run Again” the result is always 23200 (in this example), so I assume i have no slippage nor issues with the AF routine.

Now if I go into settings and enable “Smart AF” SGP behaves as it should, moves the final focus point to the interception of the two lines around 23093.

If I ran it again the best focus point stays within the expected range and dead on with the line interception point.

The problem is, if for some reason a cloud appears and “Smart AF” is on, the focuser goes bananas and gets out of it’s focus range by automatically extending it’s range… meaning SGP will no longer be able to find the correct focus point.

So would it be possible, or how can I setup SGP in a way that I have the good of the two worlds:

  • SGP moves the focus point to the line interception point
  • If focus fails or no line interception is found then SGP would not extend the range of the focuser and instead fail the sequence.

#2

If you don’t want to use Smart Auto Focus then use 9 points rather than 7. With 7 you only have marginally enough data for the interception method to work. If one point is rejected then it fails and defaults back to weighted average. 9 points will give you a little bit of wiggle room and if you still have issues jump that to 11 (best to keep odd numbers)

Thanks,
Jared


#3

If i got half of your results i would be in paradise. After weeks and dozens of hours wasting clear nights im not even close to getting any kind of V … i get lots of zig zags and bunnny slopes but nothing to write home about. and every run is totally different from the other. im ready to give up and just use the Mask after spending 500 $ CAD.
If i sent you my screen grab can you at least look at it and give me a starting point ?
my Focuser is From Pegasus…
I just paid for a full license today…wish i could focus better , all im getting is 3.50 to 5.39 HFR or FWHM,on a 115 MM F5.5 EDT triplet. i hear guys are getting 1.44 FWHM, on a good night. :frowning:
Mitch


#4

Hey guys,

When I first got my nitecrawler at the end of 2016 i ran with 1000 step size and 7 samples (points). My results were v curve, but prone to error.

This year, i reduced my step size to 900 and upped my samples to 8. This gives me a lop sided v curve but its has vastly improved my confidence that the HFD focus algorithm will be on point. I haven’t thrown single sub out this year due to poor focus.

0

0

I have an RC 8 and I DO use smart focus reliably with thiis simple change. My focus moves inward with cooling, So my focus will usually have more samples on the right side of the graph. Smart focus gives me the additional sample when necessary (ie 2 samples are in the CFZ). So far no smart focus obstruction caused run away. (probably just jinxed myself).

0

I know my parameters are different than yours, but you could scale it to your step size to try it out.

@jbrazio My end focus point is as yours when you have Smart AF enabled. I can’t say what disabling it does.
Homer


#5

I guess my settings are OK.

I’ve upped the number of points to 11 as suggested and it is has now more data to do the interception rule, I still require to have Smart Focus enabled in order to the interception point to be the final focus point, otherwise the system will always go to the point where it found the least HFD from all the 11 points measured.

Nevertheless I still believe we could benefit from having an additional checkbox for Smart Focus were the algorithm would use the interception rule but would fail if it thinks the AF range needs to be extended.

@Jared would this be something to be easily implemented ?


#6

Hi jbrazio,

I guess you found a quirk in Auto Focus’s behavior that is not intended by the developers.

During my free 45 day trial I tested Auto Focus extensively. I put some related questions to the developers ( Old and New Auto Focus Method and Unanswered questions: AF methods “weighted average” / “best fit” ) but did not get an answer from them. At that time Auto Focus would always use the “old method” and I did not understand why. Later on - I did not mean to have changed anything - suddenly the new method was used virtually each time. Reading your post, I suppose I switched the setting of ‘Smart Focus’. Anyway, I have now for a long time ‘Smart Focus’ NOT disabled, and the new method (best fit) is used all the time.

According to SGP’s PDF Manual, ‘Smart Focus’ is intended for the automatical extension of the number of data points in order to find proper focus. However, it seems that there is a side effect on the usage of Auto Focus methods. This is strange.

Bernd

P.S.: After posting this I found a thread that covers the topic: AF HFR out of tolerance warning: real issue or false alarm? , especially replies /6 and /8 are interesting.

It would be fine if this description was incorporated into the manual, section Auto Focus!


www.mainsequencesoftware.com