Another plate solving problem


#1

Hi All:

As I get closer and closer to full automation, I seem to be taking two steps forward and one step back. After some previous feedback, I’d set up to use PlateSolve2 and was generally successful. I ran into some problems when I started a new target due to not having the settings in the profile, but otherwise was able to recover and get things working. I also recently attempted turning up the gain on my camera to improve my DSO imaging and while that added some headaches due to hot pixels I was able to tweak the settings and resolve that. So long story short, last week I targeted and plate solved on BlackEye just fine. However, a few days later (over the weekend) no go, regardless of how often I tried. Looking at the image in PlateSolve2, it was highlighting the correct stars, and if I captured a screen shot and uploaded to Astrometry.net, it solved fine with the Blackeye just outside the FOV on the lower left. I went back and enabled astrometry.net as the failover solution and it still didn’t work. Any thoughts/suggestions?

Thanks,

Beo


#2

Logs and some fits that were being problematic would be helpful.

Thanks,
Jared


#3

Well, the temporary plate solve FITS isn’t kept, so I don’t have anything to show, but the pertinent portion of the log is below (and doesn’t tell much).

[05/12/18 22:25:56.950][DEBUG] [Sequence Thread] DoEventGroupChange: Centering on target
[05/12/18 22:25:57.330][DEBUG] [Telescope Thread] Center telescope message received...
[05/12/18 22:25:57.330][DEBUG] [Telescope Thread] Solving with Plate Solver PlateSolve2...
[05/12/18 22:25:57.399][DEBUG] [Telescope Thread] Performing auto center step 1...
[05/12/18 22:25:57.400][DEBUG] [Telescope Thread] Skipping step 1...
[05/12/18 22:25:57.400][DEBUG] [Telescope Thread] Auto center reference frame solved successfully...
[05/12/18 22:25:57.400][DEBUG] [Telescope Thread] Performing auto center step 3 (scope)...
[05/12/18 22:25:57.400][DEBUG] [Telescope Thread] Auto center slewing scope to match reference...
[05/12/18 22:25:57.402][DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 12.9455 (12h56m43.80s) Dec: 21.6833333333333 (21°41'00.00")
[05/12/18 22:25:57.402][DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting...
[05/12/18 22:25:57.405][DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 12.9605362464704 Dec: 21.5862576888484
[05/12/18 22:26:06.573][DEBUG] [Telescope Thread] Scope reports it is done with synchronous slew, verifying...
[05/12/18 22:26:06.574][DEBUG] [Telescope Thread] Telescope: Slewing has completed
[05/12/18 22:26:06.574][DEBUG] [Telescope Thread] Auto center slew complete...
[05/12/18 22:26:06.574][DEBUG] [Telescope Thread] Performing auto center step 4...
[05/12/18 22:26:06.575][DEBUG] [Telescope Thread] Created full file name (file does not exist): C:\Users\foegelle\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[05/12/18 22:26:06.581][DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE message received...
[05/12/18 22:26:06.582][DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame...
[05/12/18 22:26:06.584][DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame...
[05/12/18 22:26:06.741][DEBUG] [Camera Thread] SetAscomHighSpeed... 
[05/12/18 22:26:06.741][DEBUG] [Camera Thread] Cannot set readout speed, not supported by camera...
[05/12/18 22:26:20.541][DEBUG] [Camera Thread] Created full file name (file does not exist): C:\Users\foegelle\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[05/12/18 22:26:20.542][DEBUG] [Camera Thread] SaveFileAscom: Start...
[05/12/18 22:26:20.542][DEBUG] [Camera Thread] SaveFileAscom: Checking image data...
[05/12/18 22:26:20.542][DEBUG] [Camera Thread] SaveFileAscom: Create normal preview bitmap...
[05/12/18 22:26:20.547][DEBUG] [Camera Thread] SaveFileAscom: Locking preview bits...
[05/12/18 22:26:20.547][DEBUG] [Camera Thread] SaveFileAscom: Validating file name...
[05/12/18 22:26:20.547][DEBUG] [Camera Thread] SaveFileAscom: Starting byte traversal...
[05/12/18 22:26:20.641][DEBUG] [Camera Thread] SaveFileAscom: Unlocking preview bits...
[05/12/18 22:26:20.641][DEBUG] [Camera Thread] SaveFileAscom: Saving preview bitmap to disk...
[05/12/18 22:26:20.642][DEBUG] [Camera Thread] SaveFileBmp16: Locking bitmap for disk write...
[05/12/18 22:26:20.642][DEBUG] [Camera Thread] SaveFileBmp16: Opening file stream...
[05/12/18 22:26:20.643][DEBUG] [Camera Thread] SaveFileBmp16: Writing FITS headers...
[05/12/18 22:26:20.648][DEBUG] [Camera Thread] SaveFileBmp16: Traversing and persisting bitmap data...
[05/12/18 22:26:20.782][DEBUG] [Camera Thread] SaveFileBmp16: FITS block fill...
[05/12/18 22:26:20.782][DEBUG] [Camera Thread] SaveFileBmp16: Unlocking bitmap...
[05/12/18 22:26:20.782][DEBUG] [Camera Thread] SaveFileBmp16: Closing file stream
[05/12/18 22:26:20.784][DEBUG] [Camera Thread] Internal Interface: Set Preview...
[05/12/18 22:26:20.785][DEBUG] [Camera Thread] Display image preview using asynch task...
[05/12/18 22:26:20.842][DEBUG] [Unknown] MDI Open Image requires UI thread delegate to open image...
[05/12/18 22:26:20.842][DEBUG] [Unknown] Delegate created, invoking...
[05/12/18 22:26:20.842][DEBUG] [Unknown] Delegate created, invoked, blocking until render is complete...
[05/12/18 22:26:21.093][DEBUG] [Unknown] Calling EndInvoke...
[05/12/18 22:26:21.515][DEBUG] [Camera Thread] SaveFileAscom: Done
[05/12/18 22:26:21.515][DEBUG] [Camera Thread] =========== Save file took 975 ms
[05/12/18 22:26:21.515][DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE complete...
[05/12/18 22:26:21.679][DEBUG] [Telescope Thread] Auto center verification frame complete.  Plate solving image C:\Users\foegelle\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] ************* SOLVE HINTS ****************
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] SOLVER:      PlateSolve2
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] BLIND:       False
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] METHOD:      Max Regions
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] RA:          12.9449396882496
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] DEC:         21.6856215913595
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] SCALE:       0.57538
[05/12/18 22:26:22.159][DEBUG] [Telescope Thread] ******************************************
[05/12/18 22:26:22.628][DEBUG] [Telescope Thread] FitsFileHeaderData: Angle - 0
[05/12/18 22:26:22.628][DEBUG] [Telescope Thread] FitsFileHeaderData: Scale - 0
[05/12/18 22:26:22.628][DEBUG] [Telescope Thread] FitsFileHeaderData: RA - 12.9449311044425
[05/12/18 22:26:22.629][DEBUG] [Telescope Thread] FitsFileHeaderData: DEC - 21.6857718505511
[05/12/18 22:26:22.635][DEBUG] [Telescope Thread] PlateSove2 Param: RA (RAD)  - 3.38897728548066
[05/12/18 22:26:22.635][DEBUG] [Telescope Thread] PlateSove2 Param: DEC (RAD) - 0.378485497110796
[05/12/18 22:26:22.635][DEBUG] [Telescope Thread] PlateSove2 Param: Width     - 3012
[05/12/18 22:26:22.636][DEBUG] [Telescope Thread] PlateSove2 Param: Height    - 2012
[05/12/18 22:26:22.636][DEBUG] [Telescope Thread] PlateSolve2 Command Line:
[05/12/18 22:26:22.636][DEBUG] [Telescope Thread] C:\Users\foegelle\AppData\Local\SequenceGenerator\\PlateSolve2.exe 3.38897728548066,0.37848549711080,0.00840203712660,0.00561251616824,3000,C:\Users\foegelle\AppData\Local\SequenceGenerator\\Temp\psXSolve_0.fit
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] *********** SUCCESSFUL SOLVE *************
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] SOLVER:      False
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] SUCCESS:     False
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] CONF:        0
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] BLIND:       False
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] RA:          0
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] DEC:         0
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] SCALE:       0
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] FLIPPED:     False
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] ANGLE (EON): -500
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] MSG:         Solve failed!  Maximum search limit exceeded.
[05/12/18 22:26:53.091][DEBUG] [Telescope Thread] ******************************************

I’ll have to test again next time I get some good weather.

Thanks,

Beo


#4

Don’t know if it is relevant but I usually bin my plate solve frames for speed but noted the other night that sometimes binned fails to solve when 1x1 works fine.


#5

So, some additional feedback from my subsequent attempts to plate solve. First off, it would be nice if there was an option to seek, focus, THEN plate solve, rather than seek, plate solve, then focus. That would likely help. At any rate, starting from park, the attempt to center failed to plate solve, although it identified stars ok.

Uploading a screen shot of the image to astrometry.net, it solved fine, so I’m not sure why the fallover didn’t work.

http://nova.astrometry.net/user_images/2131838#extraction

After focusing and going back to solve, it did actually solve and center correctly this time, but when the dialog closed SGP pops up another dialog saying it failed to solve with a timer before running the end of sequence steps.

Not sure what’s going on there, but this is getting annoying.

Things also went nuts attempting to control PHD2, but that’s another story.

Beo


www.mainsequencesoftware.com