Auto Center After Guide Star Lost


#1

Hello,

Last night I was imaging and clouds must have rolled in because I lost the guide start. PHD2 tried to center the lost guide star and when it finally started running again my target was completely off the screen.

So I was wondering if the guide star gets lost can it trigger SGP to run a SLEW To and then an AUTO Center to make sure the target is still in the correct FOV? I lost about 4hrs of imaging time due to this, and with my weather that 4hrs means a lot.

Thanks for the great product.

Wem


#2

There’s nothing at the moment that can do this - But in the feature requests poll there’s a feature that you can vote on to be considered in future releases that will enable a plate solve every x subs… This would solve this problem.


#3

If the guide star was truly lost (meaning PHD2 actually issued a star lost message) and recovery was on, it is already part of the process to recenter on the target and then restart guiding. You didn’t attach any logs so I am not sure exactly the sequence of events.


#4

Hello Ken. Here are the SGP and PHD2 log files, around 12am on 9/6 the fun started. The last image of the HA sequence was fine, the first OIII image was streaked terrible then the second OIII image was good but off center.https://www.dropbox.com/sh/78l9vp3jvna1txb/AAAeO-qG5odvON2Hlr_7ZnUYa?dl=0

Thanks,
Wem


#5

Turn on recovery mode. It already covers this situation.


#6

I am not sure I had recovery on. I had to revert back to .14 after .17 would not start as noted in a different thread and I reinstalled .17 lastnight before I seen your message, when I checked .17 it started up with recovery on as default. I will make sure it is started next time.


#7

Recovery mode is pretty awesome :).


#8

I do usually have it initialized.


#9

Here is some data from the log, it said it recovered @2:25:13

[9/6/2016 2:25:12 AM] [DEBUG] [Recovery Sequence Thread] Auto guider has settled…
[9/6/2016 2:25:12 AM] [DEBUG] [Recovery Sequence Thread] Recovery: Settling is successful…
[9/6/2016 2:25:12 AM] [DEBUG] [Recovery Sequence Thread] Sequence recovery was successful!
[9/6/2016 2:25:12 AM] [DEBUG] [Recovery Sequence Thread] Closing recovery dialog…
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] Sequence recovery was successful (CenteringAndGuiding)!
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] ------------- Starting capture frame for event[1] -------------
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] Sending commands…
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] SetFlatBox: Frame Type is Light
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] TEMP - Current Event2: 1
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] Meridian flip not needed, telescope on East side
[9/6/2016 2:25:13 AM] [DEBUG] [Sequence Thread] TEMP - Current Event3: 1


#10

Looking at the PHD log, it looks like PHD lost the actual star, thought it found a different one but didn’t and kept sending max guide pulses until it found an actual star then continued guiding from there.

00:32:54.630 00.000 6356 ScheduleExposure(3000,3,1) exposurePending=0
00:32:54.631 00.001 6356 Enqueuing Expose request
00:32:54.632 00.001 6356 Alert: Your Max RA Duration setting is preventing PHD from making adequate corrections to keep the guide star locked. Increase the Max RA Duration setting to allow PHD2 to make the needed corrections.
00:32:54.987 00.355 6356 Resizing image to 485,363
00:32:55.379 00.392 2400 IsGuiding returns 19637768
00:32:55.379 00.000 2400 scope still moving after pulse duration time elapsed
00:32:55.530 00.151 2400 IsSlewing returns 945
00:32:55.546 00.016 2400 IsGuiding returns 1293618858
00:32:55.546 00.000 2400 scope move finished after 1995765714 + 1996657808 ms
00:32:55.546 00.000 2400 Move returns status 0, amount 1000

One night PHD2 lost the guide star while I was at the scope but it was not cloudy or anything. It looked as if the cameras exposure setting got change as the picture was very dim with few guide stars and gave me the same max duration warning, after a few minutes of this it started working properly again. Maybe the same thing happened here, I am using a ZWO 120mm guide camera.

Wem


#11

OK after more digging it looks like maybe I had my star mass tolerance too high, so when it did lose the star it thought it still had on and just tried to keep locking on to noise and just kept driving the scope away. Thus it might have never triggered sgp.

So most likely operator error as the cause.


www.mainsequencesoftware.com