Autofocus worked with earlier versions of SGPro


#1

First decent wx since last year so I used a moonlit night to check things out. I just installed ver .169 and I’m not sure if its the cause of my problem or something else has messed things up over the winter. I had always had decent V curves - a little bump at the first exposure but otherwise it would do a decent job of focusing. I start off using a Bahtinov mask and grabber to get in focus and the HFD numbers reported by SGPro are what I expect for my OTA, camera and environmental conditions (.8-1.2 or so, binned 2x2, QSI683). I was verifying AF and thought I’d try backlash comp, 50 seems about right and it indeed does eliminate the first bump in the curve. But the V curve is now mostly gone, AF fails.

Going back to my setup from last year, I eliminated backlash comp and it still doesn’t won’t give me a decent focus. I’m tempted to re-install vers .151 which was the previous version I had successfully used but before I do that, any thoughts on what’s happening? I don’t have the greatest focuser/controller on my Explore Scientific ED127-FCD100 (stock focuser, impossible to replace, Rigel controller) so they may be the problem but they worked quite well 4 months ago.

John


#2

There haven’t been any changes to the auto focus routine in quite some time. If you can post some screen grabs of the V curve we can probably help.

Thanks,
Jared


#3

Thanks, Jared.

I think I have a few other problems to resolve. I discovered my focuser driver would drop out but SGP would keep running as if the focuser were actually moving - apparently the driver didn’t return any error to SGP since it thought the focuser was still connected - that accounts for the flat line I saw. I ran more tests last night (keeping an eye on the focuser driver) and found if I increased the autofocus step size, I was able to get good autofocus with or without backlash correction.

Now all I have to do is figure out why Polemaster and my finder cameras sometimes won’t connect until I reboot the PC - I have a 7port USB extender riding on the mount and it connects to a USB-Ethernet extender - of course it’s all flaky! But that’s for another clear night - next month probably.

BTW, great job on SGPro - worth every penny!

John


www.mainsequencesoftware.com