Autoguider (not) Settling with wrong parameters


#1

Hello,
I ran a session last night with my settling option for auto guider at 0.5 pixel for 2sec as below.

But my session failed with “Autoguider did not settled” and when looking at the log, I noticed:
[10/26/2016 11:13:24 PM] [DEBUG] [Sequence Thread] Waiting for Auto Guider distance to fall below 0.1
[10/26/2016 11:21:31 PM] [DEBUG] [Sequence Thread] Distance is below 0.1, starting timer…
[10/26/2016 11:21:34 PM] [DEBUG] [Sequence Thread] Distance stayed below 0.1 for 3 seconds, done settling…
Which short of a miracle given my setup…
But it worked only for one image, and the next time failed miserably:
[10/26/2016 11:41:47 PM] [DEBUG] [Sequence Thread] Auto guider failed to settle in the specified time limit, resuming the auto guider has failed…

Is there something I need to change/update so my settings (.5px for 2s) are properly taken into account?
Thanks,
Olivier

SGP log: sg_logfile_20161026230154.zip (53.4 KB)
PHD2 log: PHD2_GuideLog_2016-10-26_212055.zip (102.1 KB)


#2

We’ve had similar reports. Was this with an old sequence or profile by chance? Can you attach the sequence or profile as well?

Thanks
Jared


#3

That was a sequence I just created earlier in the day.
I have had my profile for a long time and updated it regularly.
Here they are!
Olivier

(lol I can not upload .sgu, .sgp or .sgf, I had to zip it ;-))

The .sgu and .sgp files
AppData.zip (7.5 KB)
The .sgf file
M74.zip (8.7 KB)


#4

@Jared,

This morning, I updated the thread that I started about this. I have since modified my sequence so I can’t share it with you. However, I can tell you that I wondered about this, so while flailing about, I actually created a new sequence with the same settings as the old one. It had the same behavior on both the new and old sequence. I update my profiles almost everytime I make a settings change, so I am not sure that is helpful, but I can share if it is.

Also, in the log I posted is the same line (which I excerpted from the log), about waiting to fall under 0.1 pixels when that wasn’t my setting.

One thing we share is that the threshold I had set was also 0.5 pixels.

For what its worth, Olivier, in my thread (sorry I don’t know how to link to it, but it should be near the top) I included some setting changes that worked for me to run a sequence. I am not sure whether they were all necessary, but together they all seemed to work reliably over two nights.

Thanks,
Craig


#5

Here what I’ve noticed with PHD2 not reporting settling to SGPro and not sure if this is what you’re experiencing. I typically have my focus complete and PHD2 guiding before I start my sequence. Once I start my sequence SGPro will direct PHD2 to stop guiding and do the Slew To/Center Now routine. Once that is complete SGPro restarts PHD2 back up and PHD2 selects a guide star. then SGPro waits for PHD2 to report settling is done. However, I found that I need to go into SGPro auto guilder tab and change the settling number say if it is set for .5 to some other number say .6. As soon as I change the number PHD2 immediately reports to SGPro settling is complete and SGPro move on. I than change the settling number back to what I want and everything runs perfect to the remainder of the sequence. Simply by changing the settling time number in SGPro at the beginning of the sequence does the trick. If I do nothing I’ll get a settling timeout and the sequence stops. It doesn’t matter what number I change the settling to just as long as the settling number is changed in SGPro during that first settling.

Regards,
mahaffm


#6

That is interesting. I will try that. I wonder if changing the value is perhaps forcing it to be re-read and possibly correcting the odd value that is reporting in the logs?

Obviously, this is purely amateur speculation on my part.

Best regards (and thanks),
Craig


#7

I have a related question. I used 2.5.2.4 and dithered every two frames with metaguide as the guider - and it invoked the settle delay even on frames that did not dither. Is that how it is intended to work? I thought the settle check was only meant as a check after dithering. Because otherwise there should be nothing to settle.

Frank


#8

Hi Frank, you are right and it has been discussed here: Settle time for non-dithered frames
Not sure if something has been done about it.


#9

Thanks -

Actually right now I am using the Direct Mount Guider and doing unguided imaging with dithering, which is working very well, but the same thing applies and it doesn’t need to settle when it doesn’t dither.

Fortunately in this case I can use a small delay for settling - but if the limiting factor in dithering is the delay you need to use for settling - then there is less benefit in dithering less often than every frame.

Frank


#10

There are other user options to pause guiding… during image download and during auto-focus, for example.

Perhaps the capability to differentiate those circumstances from capture initiations which require no settling time has not yet been developed.

Just a guess.

Best regards,
Craig


www.mainsequencesoftware.com