Avalon Linear and StarGO - Meridian flip


#1

Last night I set up a sequence with SGP and my Avalon Linear mount (GEM) - This is the first time I have used the new StarGO software as I have just upgraded the motherboard. I have had many months of SGP success using the SynScan on the Avalon.

When I pressed start I got the following message

I pressed OK and thought I would see if the flip would happen - It didn’t. I have attached the SGP log to see if anyone can throw some light on it.

How can i get the Avalon Linear to flip? In the StarGO it is showing as set to the Linear.


#2

I would suspect this is an issue/deficiency with the StarGO ASCOM driver rather than SGPro. Let’s see what Ken/Jared have to say.

Regards
John


#3

So is it a case that Meridian flips are not supported by the StarGO software? I can’t be the only personal with an Avalon Linear mount that has tried to do a meridian flip with SGP!

I ask as I have just looked in the SGP profile and 'auto meridian flip; has become unticked… and I didn’t touch it at all from last time.


#4

You might like to run the ASCOM conformance checker against the StarGO ASCOM driver:

http://ascom-standards.org/Downloads/DevTools.htm

Maybe a SideOfPier issue?

Regards
John


#5

Thanks John - I will forward this suggestion to the Avalon team - What I know about such things is less than zero!


#6

SGP issues the command but ASCOM and your mount have to be in parameters to do it. On my Gemini 2 MI250, you have a small window for meridian flips… If it’s not in that window, it won’t flip.

Turn on logging in your ASCOM driver and post those with your SGP logs. It’ll help you track down what is causing the issue.


#7

Can you shed any light on where the ASCOM logging may be? Sorry for being a klutz!


#8

It’s usually an option I the setup. If not, go to the ASCOM diagnostics tool?


#9

I think that your mount and ASCOM questions about this mount will need to go to the mount support people. They don’t publish their driver, at least not openly.

It’s possible that they don’t have logging in their driver, it isn’t mentioned in the StarGo manual.

The ASCOM Conform App is fairly easy to run. Download the installer that was linked to and install it just like any other software.
Run it, select your telescope - Menu - Options - Select telescope and Select Driver.
Click on Check Conformance and wait for it to finish - about 10 minutes.
The log files are where all ASCOM logs are, in the My Documents/ASCOM/ folder.
There are more options but start with the defaults.

Chris


#10

Avalon ASCOM developers are looking into this for me - Hopefully it will be sorted soon. Thanks for all of your help folks.


#11

@swag72 I can’t be sure. You seem to have removed the parts of the log we need to look at.


#12

Sorry Ken - I removed the stuff at the beginning and end that I assumed was useless. I’ll see if I’ve still got the complete log.


#13

Avalon emailed me the newly developed driver with the SideOfPier parameters last evening. I hope to try it as soon as it clears - I’ll let you know how it works just for finishing of the thread nicely.


#14

Hi Sara

I was wondering how you’re getting on with the StarGo: did the updated driver from Avalon resolve the auto-meridian flip failure?
Does the StarGo enable you to set a custom park (recalling a previous thread)?
Apart from reduced mount noise, have you observed any other advantages over the ‘standard’ fitted NEQ6 board and over Eqmod?

Barry


#15

Hi Barry,

The updated driver didn’t resolve the flip problem. The developers are currently working on a new ASCOM driver, so will incorporate that in a couple of weeks I hope.

Yes to custom park - and at the end of an imaging run with SGP the mount now parks to it’s custom park so I can easily shut the roof.

Not sure about if there’s any other advantages at the moment - There’s a few thing I’m waiting to explore when I get cables etc, so I’ll keep you posted.


#16

Thanks Sara.


www.mainsequencesoftware.com