Bug?: Solve and Sync button won't to EQMOD but "Center on Target" works


#1

After playing around with this a lot over the last few months I think I’ve finally managed to figure out the symptoms, but I have no idea the cause…

Here’s the situation, I have an Orion Atlas and I’m using a shoestring astro cable to control it via EQMOD.

If i use the Docking Module “Scope Centering” button of “Solve & Sync” it will solve the image but the Sync is not passed to EQMOD. If I use the blind solver the sync is passed to EQMOD, and if I go to the Sequencer window, right click a target and click “Center on Target” then the Sync is sent to EQMOD. For me the only time the sync is not sent to EQMOD is if I hit that button on the docking module.

Any ideas?


#2

I have a very similar setup. However, mine does not sync to EQMOD no matter what I try. I have the Skywatcher EQ6R Pro. I also use the shoestring USB2EQ5 cable. I can still image as long as I turn on the mount with the exact home position. If it’s off even a tiny bit, no Sequence will work because plate solving fails. Sync in SGP can never update the position in EQMOD.


#3

Some supplementary data might be necessary:

  • EQMOD Version?
  • SGP Version?
  • Do you have a pointing model in EQMOD?
  • What is your setting for “Alignment/Sync” --> “User Interface” in EQMOD?

grafik

  • How do you test if the Sync is/is_not passed to EQMOD?

Regards,
Horia


#4

EQMOD = 2.00q
SGP = 3.1.0.153
pointing model? - Yes I believe so, at least I think this is the default behavior with EQMOD is to build one as it starts to receive sync data from plate solve applications.
Settings - User Interface is Append on Sync and Alignment behavior is 3-point
How to test - You can see your pointing model being built by looking at a couple places. First look at the Point Count counter, every time EQMOD gets sync data successfully from a plate solver, this should increment. You can also visualize this by clicking the button that looks like a note pad (Point List).

My rig tripod is mounted to a rolling platform, and I store it setup in the garage and wheel it down to the end of my driveway when I want to image. Since I’m not in exactly the same spot all the time I have been clicking the button that looks like a notepad with a red X on it, this is the “Clear Align Data” button, and it will clear out your pointing model and reset the count to zero (again can visualize that the model is wiped with the notepad button).

My typical setup routine: Physically wheel out my rig and plugin the power. Polar align with my polemaster. Connect EQMOD to the mount. Clear the pointing model (click that button), then unpark the mount. Fire up SGP and connect all hardware. From there I usually add 4 to 5 bright stars prior to my actual imaging target for the night to my sequence but I do not check any Events for those targets. I right click them, and use the “Center on Target” command to have SGP slew the mount, then it starts the platesolving routine. Normally this procedure will get me within at least about 100 regions for PlateSolve2. Once it solves the first one it get’s better and better. By the time I slew to the 4th or 5th target it’s usually only a few dozen pixels off target from the slew.

Every time PlateSolve2 solves one of these my Point Counter in EQMOD goes up by one.

Now in contrast, if I use the Frame and Focus module to snap a pic, then I click on “Solve and Sync” in the Scope Centering module, then SGP will launch PlateSolve2, and it will solve, but the sync is never passed to EQMOD, and I can tell that by looking at the point counter in EQMOD.


#5

cthomp97 - I’m not familiar with your mount but sounds like the first thing to do is to get PlateSolving working. Here is my understanding from all the troubleshooting I’ve had to do, I hope this helps you out…

When PlateSolve2 fires up its supposed to get the mount position (this is where the mount thinks it’s pointing). You can see that on EQMODs main window under Mount position. Pick a target like a bright star that you might use if your were visually 3 point aligning the mount and take a look at the RA and DEC coordinates of the target. After the mount slews look at EQMOD and verify that RA and DEC have numbers that are somewhat reasonably close to your expected coordinates. You should also be able to physically look at where the scope is pointing to see if it seems reasonably close to your target (and when I say reasonably, I mean within maybe a 30 degree arc from the target it doesn’t have to be very close, just close enough). The closer the mount slews to the target the faster the platesolve will run because it has to search less.

I’m not sure if you have blind failover setup, but that’s like your backup last resort. If at all possible to be on the internet while doing this procedure then set blind failover to the online version, let PlateSolve2 fail and let Astrometry.net solve it (in the settings box it will say “Remote” that means it will send your solve image to the Astrometry server for it to solve it and pass back the coordinates). If you can’t be on the internet then you’ll need to download and setup Astrometry local (there is a tutorial in the SGP manual on how to do this).

All in all you need a few things in order to solve. The camera needs to be reasonably in focus, the solvers need to be able to detect stars and the more the better. The mount should be reasonably close to the target after slewing, if it’s not then the blind solver will help get things back to synced up.

If you’ve already tried all this, have you submitted some test shots to Nova.astrometry.net ?


#6

OK, so you have a pointing model. Append on Sync will allways insert a new point into the pointing model, but if another point is closer than the “Proximity range” setting, that “other” point will be removed from the list. To check if SGP actually sends the Sync command to the mount you have to look at the SGP log file.

That being said, I would suggest to either build a huge and permanent pointing model and do not use Syncs after that or - and this is the easy way if you are not permanently mounted - completely drop the pointing model approach. Delete all the points in EQMOD and set the User interface to “Dialog based” to stop creating a new model. In SGP, Profile Manager --> Telescope make sure the option for “Sync behaviour” is set to Sync.

Kind regards,
Horia


#7

Not a great solution I don’t think. If you don’t use a pointing model at all then every target your going to spend anywhere from 2-20 minutes waiting for platesolving to finish. With the way I’m using it, I can build up a point model by selecting targets a little farther away from Polaris each time, meaning I’m not waiting very long for the solves to finish. After 4-6 of these I can slew pretty much dead on to any target after that.

I’ll have to dig up the SGP logs on my imaging laptop later to see if it thinks it’s sending the sync or not. But as I described in the behavior I’m seeing it’s sending the sync when I I’m right clicking targets but not when using the docking module button. That tends to lend itself to something being different in what’s being executed between those two methods inside SGP.


#8

Finally figured it out. My mount was not set to tracking mode on the first solve, if I set the mount into sidereal tracking it will then allow the sync. I found this in the SGP logs. Where I am a little disappointed is that instead of SGP displaying any kind of error message or warning etc, it just continues to say “plate solving”. Shouldn’t it trap for and handle errors when the show up in the logs like that??


www.mainsequencesoftware.com