Cant Connect to PHD2 - port 4400 Access Denied....GRRrrrrrrr


#1

Hello all,
Finally got out to try out my kit and SGP under the stars last night and I had a failure to connect
to PHD2 due to connection to port 4400 being denied.

I’m Using the following:
Win 7 64bit
ASCOM 6.1sp1
SGP v2.4.3.11
PHD2 v2.5.0dev4

PHD2 has ‘Enable Server’ ticked and also a saved profile for my guide camera and mount ready to roll. SGP has
the path and the PHD2 profile selected. As soon as SGP tries to stop guiding or reinstate guiding it just freezes
and twice I had to do a forced stop of SGP last night, managed to pause the sequence once, get PHD2 running,
calibrated and guiding and on resume everything moved on ok with the SGP’s PHD graph populating the RA and DEC
lines in the module.

So what would cause SGP to be denied access to port 4400, and what on earth is port 4400 anyway, Google search
on port 4400 access denied doesn’t really produce any answers. Is it a software thing ? Operating system thing ? maybe
my port 4400 is allocated to something else on my system and as a result will deny access to any other software asking
for connection.

Is there any way I can view port 4400 on Windows 7 so I can see if anything is locked to it because I cant find anything in device manager and a search in the windows help file gives nothing found ?

HELP !

Many thanks
Paul

ow yeah, heres one of my LOG’s from last night:

sg_logfile_20151024234749.txt (30.1 KB)


#2

Does it always do this? Have you connected to PHD2 with this machine before? That error message means that you either have a firewall issue or something happened to the state of the PHD2 server. When you start PHD2 for the first time, it asks you if you want to allow it access to port 4400, did you say yes?


#3

Right, I think you should check your firewall settings: Windows Control Panel => Windows Firewall => “Allow a program or feature through Windows Firewall”. Scroll down to find phd2. If it is not there, add it by clicking the “Add another program…” button.

If that still does not work, try temporarily turning off Windows firewall. Checking with firewall disabled will tell us if it is a firewall issue or something else. (Make sure to turn firewall back on after you check.)

If phd2 is already there in the allowed programs list, please post a link to your PHD2 log file so we can check to see that phd2 server was operating as expected.

Andy


#4

Andy,
Many thanks, problem solved

As you’ll see from the screenshot above it appears I had 2 entries for phd2 one allowing access through the firewall for Home network only and the other for Public network, my system is set up as a Home network so from what I can see maybe my system was trying to use the second one which only allowed access on a public network.

I deleted both phd2 entries (inc the 2 ‘PHD’ ones as PHD1 isn’t even installed anymore), added a new entry for phd2 which now looks like ‘PHD guiding 2’ for some reason, with the Home/Work option selected…

What do ya know…Im now fully working :grinning:.

Paul

Many thanks for your help Andy and I hope my pic and explanation helps someone else out too


#5

I have seen the same thing with GNS. Multiple entries seemed to screw things up.


#6

I’d like to stick my nose into this just to emphasize something that may not be intuitively obvious to all SGP users…

Multiple firewall entries will make the system behave in ways that may seem odd because firewalls quit processing when they hit a “match”; if the first rule means “deny”, then some later rule that says “allow” is never even going to be looked at. In firewalls, multiple rules for a single program are inevitably confusing, and the results are unlikely to be what you want.

Karl


#7

That is very good to know! Thanks!


www.mainsequencesoftware.com