Error transforming JNOW to J2000! system freeze


#1

Hi,

I’ve been using SGP successfully for some years now with my equipment (Avalon Linear, GP-D2 with OnStep, two Atik Cameras, a Canon). A few weeks ago I connected my Computer to a 10Micron GM2000 using the ASCOM driver and shot some nice pictures for one week at LaPalma.

Back at home, reconnecting to my eqipment, I’ve have an issue which I can’t solve by myself. Slewing to target in the area arounf CTB1 and SH2-170 (around RA 0h00m) sometimes I get the message “Error transforming JNOW to J2000”.

Much more worse: Sometimes SGP freezes and I have to restart SGP. All other processes stil run. I even do not needd to disconnect/reconnect any equipment. But for a (formerly) automatic system this is a no go. Can anybody help me?

I put the logfile here: http://photonenfangen.de/publicdata/sg_logfile_20180930112743.txt

The system stalled at about 02:41. Before this time an increasing numbe of messages of the follwing type occured:
[10.01.18 02:41:23.873][DEBUG] [CP Update Thread] Error in control panel UI updater: Error transforming JNOW to J2000! SetApparent set - ‘24,018592’ is an invalid value. The valid range is: 0 to 23.9999.
[10.01.18 02:41:23.873][DEBUG] [CP Update Thread] Inner Exception: SetApparent set - ‘24,018592’ is an invalid value. The valid range is: 0 to 23.9999.

I’m not sure if confusion with the GM2000 ASCOM driver is the cause. Hence I removed it. The system freeze seems to occur only one time per night. So the test is still running and I will post an update as soon I know more.

Regards,
Kai

BTW: The last frame number is 0286. If you search for 0286 you may come close to the probably interesting lines.


#2

Do you have a log file for the ASCOM driver too? That would be useful.


#3

Hi Buzz,
the standard logs are available. I’m gonna post them, when I’m back home. My work day just has been started, so they’ll come this afternoon…
Regards,
Kai


#4

The issue is getting more dififcult. Which ASCOM log file do you mean? Before the freeze I had following drivers connected to SGP:
Avalon Mount, Avalon Focuser, Atik Camera, ATik Filterwheel, Manual Rotator
I had configured no logging. No a test is running with logging enabled for the camera, but not more. I have the suspect, that ASCOM.Astrometrics is involved. How can I provoke logging for that guy?
Regards,
Kai


#5

I had the original Avalon Linear. Which ASCOM driver are you using? I avoided EQMOD and just used the SkyWatcher one written by Chris Rowland and who frequents this forum.

If you have the more recent Avalon, with StarGo, I am not familiar with that one.


#6

Yes I have the Linear with StarGo. A solid work horse. Does always what I want. The drivers came along with the mount and are updated from time to time at the homepage of Avalon. Since March I use a patched version, because I had an issue with the ASCOM driver for the StarGo focuser. Luciano helped me finding the error and sent me a patched driver which I uses about 5 months without any issues. Now after beeing at LaPalma and installing the GM2000 driver I have the above given issue. Thats the reason why i think the GM2000 driver may be the culprit.


#7

It would only take a few minutes to do but maybe remove the GM driver, repair the ASCOM platform and re-install the StarGo. If the problem persists, then it is back to head scratching time again.


#8

OK. Removing the GM driver is easy. I did that in the meantime. But what did you mean with ASCOM repair and how can I do that?


#9

I’m pretty sure if you try and install it a second time, it comes up with the option to repair.


#10

Good morning buzz,

his morning the freeze was around 05:03. Find a log of the ASCOM driver of the Atik here:
http://photonenfangen.de/publicdata/ASCOM.Atik.1708.312580.txt
My next step will be as you sugested a repair or remove / install of the ASCOM platform.

Call again,
Kai


#11

Kai - the ATIK camera log file is probably irrelevant to this issue. It is the StarGo / SGP ones that probably are more useful.


#12

Buzz,

Here I put the logfile of SGP, corresponding to the freeze at about 05:03 at Oct 2th.
http://photonenfangen.de/publicdata/sg_logfile_20181001170807.txt

Here is the message window, I get if I try to slew directly to the target at 00h01m34,04s / 64°37’15,59":
http://photonenfangen.de/publicdata/Clipboard02.jpg and this is the message text of the notifier:
http://photonenfangen.de/publicdata/ASCOM-log.txt

I hope it helps.

In the meantime I moved from ASCOM 6.3 to ASCOM 6.4SP1, but it didn’t fix the issue.

Regards,
Kai


#13

Can you attach the sequence file with this target in it? Sounds like something isn’t correctly bounding the RA values.

Thanks,
Jared


#14

Hi Jared!

Find the sequence file here: http://photonenfangen.de/publicdata/Test.sgf
The target showing the strange slew behaviour is Te2.

In the meantime I de-installed ASCOM and all third party drivers (it is an option of the ASCOM de-installer) and installed ASCOM and the drivers again. I can’t promise anything, but maybe this fixed the issue. Tomorrow I should see the result.

Regards,
Kai


#16

Buzz and Jared,
It seems that the complete remvove / reinstall solved my problem. The test setup last night showed no issue anymore. This is the first since that issue occurded! Tonight it is expected to clear up, so I hope to get the chance for a real sky test.
Update follows.
Kai


#17

Hi Buzz and Jared,
thanks for your help! Captured almost 95% of the last night including an automatic meridian flip without a freeze. The issue is solved. I do not know what it really was, but the complete remove and re-install of ASCOM platform, releveant driver and SGP fixed it.
Kai


#18

Hi Kai,

Greetings from Lilienthal.

I found the following error message many times repeated in your protocol file:
SetApparent set - ‘24,018592’ is an invalid value. The valid range is: 0 to 23.9999.

This looks to me if it was a typical locale conversion problem, point and comma confusion. I experienced that quite often with other astronomical software. Besides this, 24.018592 should have rather been 0.018592, which is likely the J2000.0 RA.

Cheers
Jürgen


#19

Correction: I meant that 0.018592 is likely the JNOW Right Ascension.

Jürgen


#20

Hi Jürgen,

Nice to hear from you! And so close :wink: Had a short time out due to the Marathon… but now I’m online again.

Yes that was the issue. What I didn’t recognised was the point/comma issue. For heavens sake it is fixed now. But the mechanism caused this is still a question for me. May the installation of the 10Micron driver was the cause, but I won’t need it the next time…

See you,
Kai


#21

Hm, interesting that an uninstall solved it. It seems that this is an issue with the conversion not correctly “bounding” the RA. Glad things are up and running again, but I’m still going to do some research to see if I can duplicate this.

Thanks,
Jared


www.mainsequencesoftware.com