Feather touch motorfocus lags SGP extremely


#1

Hi,

I recently purchased SGP and was successful to connect camera, filterwheel and telescope without problems.
However, I have problems with a Feather Touch motor focus DH-1.
This works well via ASCOM in Maxim but lags SGP extremely.
I am able to connect after 1-2 minutes waiting time.
Focusing is not possible.

Any tricks ?

Best regards

rudolf


#2

Rudolf,
Hard to tell. Please see here so we can take a look:

Thanks,
Jared


#3

Jared,

Thanks a lot for your replay.

I just wanted to post how I solved that problem.

For a test the focuser was not installed directly via the ASCOM driver, but using the POTH system of the ASCOM drivers, in which you can define devices in a “relescope hub” which allows that several programs can simultaneously use the devices. Thanks Hansjörg for the Tip.

This way, SGP now connects fast and there are no lags.

Thanks & best regards

Rudolf


#4

Rudolf,

I seem to be having the same problem as you had last year. I am trying to use SGP to control an old Feathertouch dh-1. SGP can connect after a long delay, but then while I am connected, SGP is extremely laggy, so much so that it is unusable. Once I disconnect, the lag disappears.

I can’t figure out how to use POTH to solve this issue. If I connect POTH to my feathertouch focuser, SGP says that it cannot connect to the focuser. If I disconnect POTH, SGP connects with severe lag, as before.

How exactly did you solve the problem with POTH?


#5

You connect the Focuser to POTH, then in SGP you connect to the POTH Focuser (Not the Feathertouch)

POTH acts as a go-between.

Thanks,
Jared


#6

Fantastic, thanks Jared. Now I can connect via POTH, and everything seems to be working as it should.


www.mainsequencesoftware.com