FLI Camera Error: Error with FLIGetTemperature (Code: -5)


#1

I’ve go my hands on Finger Lake Instruments ML16200 and I’m trying to configure and test this camera along with a CFW2-7 filter wheel

I am using SGP version 2.5.1.17
FLI drivers update 4/14/2010 (latest)

I’ve installed the ASCOM drivers for FLI and SGP is connecting to the camera and filter wheel along with the focuser.

When starting a small test sequence of lights I get a dialog saying "Error attempting to capture image (see log for more information.)

I get the following errors in the log.

[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] Waking from exposure time sleep period…
[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] Checking to see if the CCD has a temp…
[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] Saving the CCD temp…
[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] FLI Camera Error: Error with FLIGetTemperature (Code: -5)
[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] FLI Camera Error: Error with FLIGetCoolerPower (Code: -5)
[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] Entering super dangerous loop to await image completion…
[30/10/2016 9:34:20 PM] [DEBUG] [Sequence Thread] TEMP - Current Event16: 0
[30/10/2016 9:34:24 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetTemperature (Code: -5)
[30/10/2016 9:34:24 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetCoolerPower (Code: -5)
[30/10/2016 9:34:27 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetTemperature (Code: -5)
[30/10/2016 9:34:27 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetCoolerPower (Code: -5)
[30/10/2016 9:34:30 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetTemperature (Code: -5)
[30/10/2016 9:34:30 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetCoolerPower (Code: -5)
[30/10/2016 9:34:33 PM] [DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE complete…
[30/10/2016 9:34:33 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetTemperature (Code: -5)
[30/10/2016 9:34:33 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetCoolerPower (Code: -5)
[30/10/2016 9:34:36 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetTemperature (Code: -5)
[30/10/2016 9:34:36 PM] [DEBUG] [CP Update Thread] FLI Camera Error: Error with FLIGetCoolerPower (Code: -5)


#2

@Nicholas_Jones

I’m not sure. I looked at the FLI documentation to find out what “-5” means:

Return Value:
Zero on success.
Non-zero on failure.

So… not super helpful. The camera logs would be way more specific here if you want to include them. It is called

FLI_DEBUG_LOG.txt

and is located in the same folder as the SGPro logs.


www.mainsequencesoftware.com