Focuser moves in wrong direction -2.5.0.12


#1

I switched my imaging scopes yesterday. I put a Feathertouch focuser on my Newt and was setting it up tonight. I’m trying to autofocus and notice that the focus routine is moving the focuser (Rigel usb n-step) in the wrong direction. When running autofocus, its first motion is inward. If I check the “reverse direction” button in the focus tab it makes no difference. The focuser still moves inward when starting autofocus. I guess I don’t know that it matters for focusing but just wanted to bring it up. Seems that the reverse direction button isn’t functional with my focuser.

I tried checking the reverse direction box in the focuser driver and it just confused SGP because as it was moving in, the numbers were increasing and it wouldn’t stop.

sg_logfile_20160222192805.txt (101.3 KB)

Thanks,
Chris


#2

That’s certainly odd. This is a pretty popular focuser and we have not had others report this issue. We could have a bug in the “reverse direction code”. I’ll check that out.

Quick update… just checked “reverse direction” on the simulator and it appears to be broken for AF, but working for the in / out buttons. Should be easy to fix.


#3

Thanks for the quick reply!

So I guess I have a question, does it matter for the focus routine or the quality of the focus whether the first motion is in or out?

Chris


#4

Actually… I think I have just lost my mind or I am tired or both. AF directs your focuser to move to an absolute position so “reverse direction” has no particular impact on these instructions. There is no reversal of a request to move to specific position.

In terms of quality, I don’t believe direction of the initial movement has much impact, but this is a statement that will almost certainly start some kind of debate. We have had at least one request to allow for reversal of this…

You will need to find out why your focuser does not want to move to a specific position… this has nothing to do with interpretation of “in” or “out”.


#5

You will need to find out why your focuser does not want to move to a specific position… this has nothing to do with interpretation of “in” or “out”

So, what does the “reverse direction” setting in SGP do? I understand that for an absolute focuser, SGP is just telling it to go to a certain step/position. The stepper driver reports where the motor actually is but cannot account for gearing which may reverse direction of the focuser relative to the motor. As long as it’s not a problem with getting a good autofocus I don’t care which direction the focuser moves. Maybe I don’t understand the function of the “reverse direction” checkbox in SGP.

When I tried to use the reverse function in the driver, the motor kept moving in the “in direction” with numbers going down when SGP was expecting it to go out. The numbers were decreasing and so SGP kept it moving and never achieving its desired postition. That’s at least what it seemed like to me. I had to kill the power to get it to stop. I had SGP move the focuser to position 18000 when it was at 17000 or so. When it started moving, the numbers kept going down. Maybe I was just tired or out of my mind too, probably both. :smile:

Thanks for the info,
Chris


#6

There are 2 ways in which to move an absolute focuser.

  • Give it an absolute position and let it go
  • Give it a number of steps in or out to move.

The latter of these two is the only thing that reverse focuser direction actually applies to. The only place the tells the focuser to move in a relative way with steps is the “fine” and “coarse” buttons. If your focuser is at 17000 and when we ask it to go to 18000 and the number decreases, that is a problem entirely outside of SGPro.


#7

Thanks, just the info I needed.

Chris


#8

After playing around with the drivers I could not get it to reverse direction to correspond with what SGP expects. With “reverse direction” checked in the driver, the focuser would just keep going because it was reporting positions somehow wrong. When autofocus was started and SGP wanted to move the focuser out (higher step numbers), the numbers reported by the driver actually went down. So SGP just kept trying, driving the focuser continually as the numbers would never go to the expected position.

In the end I just just turned the motor around. With the Rigel steppers, it’s easy to do that. No it moves in the correct direction.

Chris


#9

I think you are describing known behavior of sgp and it isn’t something new or tied to your focuser.

SGP always takes the autofocus curves from high numbers to low numbers - regardless of what ‘in’ and ‘out’ mean. I have entered a feature request some time ago that this be changed.

With your focuser - or any focuser - if you open the focus dialog and set the dialog to have a fine step size of 100 - if you then press the In button it should move either + or - 100 steps depending on how you set the Reverse value.

Also - if you are at 1000 and you tell it to go either to 900 or 1100 - with an actual ‘GoTo’ command - it should goto that number, up or down, regardless of the Reverse value.

And if you have backlash compensation set - it will invoke backlash on moves that go either up or down - depending on how it is set up. So if you have backlash of 1000 set - it will overshoot in one direction by 1000 and come back.

All that stuff should behave properly in sgp - and if it doesn’t then there is something odd about your focuser.

But if you say the actual autofocus routine ignores in/out/reverse and just goes from high values to low values - that is a known thing and the routine is hard-coded that way. And I agree it should be changed - and it is a feature request.

Frank


www.mainsequencesoftware.com