Framing & Mosaic Wizard not working?


#1

Not used SGPro for while. Fired it up this evening (finally clear skies) but I’m not able to download images in the Framing & Mosaic Wizard?

The error comes up when entering the object name -> Fetch button: Error fetching image. the requested security protocol is not supported. I did a quick search on the forums here but nothing came up apart from a few posts from August last year which I’m not sure are related.

I updated to the latest 2.6.1.114 and the error is the same. This is a Windows 7, SP1 machine.

Any help appreciated and a bit disappointed and sad that this isn’t working tonight.


#2

I updated to the latest 2.6.1.114 and the error is the same. This is a Windows 7, SP1 machine.

Woops! I just noticed that latest SGPro is 3.0.3.169. I downloaded and installed that version but had a minor hiccup regarding communication protocols, which I suspect is an issue specific to Windows 7 and updates to run via TLS 1.2. Symptoms include SGPro not being able to connect to verify my license and inputing my login details into the “Help -> Register this Machine” dialog yield a “the security protocol is not supported” error.

I fixed this as follows:

  1. Download the TLS update here: http://www.catalog.update.microsoft.com/search.aspx?q=kb3140245
  2. Upgrade my .Net Runtime to 4.7.2 here: http://www.catalog.update.microsoft.com/search.aspx?q=kb3140245

The above two (not sure if step 1 is required) resolved my issues. The Mosaic wizard (my favourite) is now able to download images and SGPro is picking up my licensing details \o/.

Hope the above helps anyone with similar issues.

:crossed_fingers:clear sky tonight!


#3

#2 should have also taken care of #1.

Also anyone reading this should be aware that SGP3 is not a free upgrade to SGP2. But these same steps should apply for SGP2 users having the same issue.

Thanks,
Jared


www.mainsequencesoftware.com