Frequent Autofocus failure with FLI Atlas focuser


#1

I have a new FLI Atlas focuser. A number of times, autofocus fails when SGP moves the focuser out the first time. You can see these points in this log file https://drive.google.com/file/d/0B0KcEqw-v71VYlFwVEF0akhDdjA/edit?usp=sharing - look for “ASCOM Focuser: Error in Move(abs) :”

This only happens on the very first move.

When I cancel the autofocus run, the focuser works as normal.

 MarkS

#2

Mark,
I believe this is happening because your focuser is reporting that the move has completed when it actually hasn’t. Do you happen to have, or can you get, a log from the ASCOM driver of your focuser so we can correlate the two?

Thanks,
Jared


#3

I couldn’t figure out how to create debugging output - sent an email to FLI
to ask for help.

In the meantime, I tried to use “ASCOM Chooser” and then select the FLI
focuser there. That didn’t cause any issues last night…

 MarkS

#4

That’s interesting…as there is literally no difference between using the chooser or actually selecting the focuser since they’re both connecting to the same device. Glad it worked though. Debug output from the focuser would be nice if their ASCOM driver can output it.

Thanks,
Jared


www.mainsequencesoftware.com