Local Ansvr Plate Solving Issue


#1

Hello,

I have been having nothing but success with the local Ansvr blind solving and syncing until tonight when I tried my new ASI 1600 camera. I do have the camera parameters setup correctly, but, when I try to plate solve using local ansvr, it fails. After a few attempts I tried to check the “settings” and it could not connect to that IP address that shows various parameters. Fortunately I was trying this at home so I was able to use the remote ansvr and I was able to plate solve.

What could the issue be here?

Thanks


#2

If you couldn’t connect to to ANSVR’s IP address it sounds like ANSVR wasn’t running. Did you try to restart it or see what was going on in the ANSVR log?


#3

No, I didn’t do any of that. I had never had to manual run ANSVR, and I imagine it has always been launched by SGP on demand. I will check it out tonight.

Where is the log file?

Thanks


#4

I found a similar issue this past weekend where the fallover, local Ansvr, failed. I have two cameras that I use, one is a ATIK 383L+ OSC and the other is ASI071. I always used the ASI071 in my observatory and the ATIK383 I use on my field setup. I never had an issue with plate solving using the ASI071 in my observatory nor with the ATIK383L in the field. With my observatory setup when slewing and centering, using SGPro, always solves using PlateSolve2 and never needed to fall over to the local Ansvr.

Additionally when I take my field equipment out using the ATIK383L I never had an issue with plate solving. Typically on the first Slew/centering I am not close enough and it always falls over to the local Ansvr and solves. After the first solve and from there on the PlateSolve2 picks ups and solves the rest since I am now close enough to the requested coordinates.

However, this weekend I decided to take the ASI017 camera with me for some fieldwork. As before the first Slew/centering was not close enough for PlateSove2 and it needed to fall over to the local Ansvr. However the local Ansvr failed and since I had no internet connection I was stuck. I did capture some images of different parts of the sky knowing that I’m going to need them for troubleshooting.
I came home and over the next couple of days I worked with those test images from the ASI071 camera. None of the images would solve with the local Ansvr but when I went on line they all solved using the remote Ansvr. I then used the RA and DEC information I obtained from the remote solver and plug those in to the plate solver and PlateSolve2 solved without any issues. I then did the same using the local Ansvr and it would not solve. I check the indexes and even installed additional indexes and still the local Ansvr would not solve those field images taken with the ASI071 camera. I verified that the local Ansvr was running by watching the log files

Next I took images that were obtained from my observatory using the ASI071 camera and all the images I tested solved with all three solvers; PlateSolve2, Local Ansvr and the remote Ansvr. The images I solved this way were from images scales of 0.35”/px and 1.40”/px. My field equipment uses a SCT-8 with an image scale of 0.45”/px.

At this point I am stumped. My next step is to take those field test images to see if my observatory PC will solve them with the Local Ansvr.

I’ll report back on what I find. I can’t believe this would be a SGPro issue and I wasn’t going to post anything but since @farzad_k found what appears to be the same issue, but with a different ASI camera, I thought I would post.

Sorry for being so long winded,
Mark


#5

Go to Start and then scroll down to Astronomy.net Local Solver. You’ll find options to Start the Server, Stop the Server, Watch Ansvr Log, and others. You can find the actual logs by looking in the “Watch Ansvr log” option.

You probably won’t have to wait until dark. One way to see if Ansvr is running is to go to Task Manager and see if perl is running. If perl is running load one of your images into SGP, right click on it to bring up a window that has plate solve, and pick blind. If everything is good it will solve. If there is a problem you’ll see what happened out in the dark.


#6

I’ll try that after work today. Thanks.


#7

OK, I isolated my issue so I’m not sure if it’s the same issue. For whatever reason, In the ansvr config file if I put any number in the “Depth: ____ number of field objects to look at, or range of number, . . . . …” the local ansvr plate solver fails to solve. Once I set the Depth to “Blank” it solves as it normally does in about 20 seconds. Might be something with my setup and this camera that maybe the stars were not bright enough.

Anyway by setting the “Depth” to blank seems to solve the plate solve issue.

Mark


#8

Steve, it worked - thanks.

Is ANSVR supposed to be launched by windows at startup or it is supposed to
be launched by SGP as needed?


#9

ANSVR is launched on startup on my laptop, always hiding in the background.


#10

The ansvr installer installs a shortcut in the Windows Start menu Startup folder so that ansvr starts when you log in to Windows. You can look in the Startup folder to confirm that the shortcut is still there.

If it got removed, you can copy the “Start ansvr” shortcut from the Astromery.net Local Solver folder into the Startup folder. If you’re not comfortable with that kind of operation, you can re-run the ansvr installer (Your downloaded indexes and your ansvr settings won’t be affected by re-running the installer.)


#11

Thanks, Andy.


#12

It turns out it was in the startup folder already:


#13

In that case we can assume that it is trying to start when you log in, but failed for some reason. We can tell what happened by looking at your ansvr log file: C:\Users\YOUR_USERNAME\AppData\Local\cygwin_ansvr\var\tmp\platesolve\ansvr-DATE_TIME.log


#14

Unfortunately no log file from last night, presumably because it never was
launched?


#15

The time stamp in the file name represents the time that ansvr started.

Let’s try this:

  1. log out of Windows. This will stop ansvr,
  2. log in to Windows. This should start ansvr and create a new log file with a timestamp around the time you logged-in
  3. confirm ansvr is running by opening http://127.0.0.1:8080/api/config
    Let us know if ansvr started or not. If so, then you should be good to go. If not, we’ll need to find out why.

#16

Hi Andy,

Sorry for the delay. First there was the eclipse and then a whole lot of other problems. Last time I platesolved was two nights before the eclipse and I had to launch ANSVR manually.

And I have followed the instructions and without launching ANSVR manually I am not able to get the configuration link to work. The good news is that I can launch ANSVR manually and it will work.

Farzad


#17

along similar lines but slightly different…
I am testing blind solving offline.
ANSVR did not solve initially as above, but after reading this thread I started the server manually (even though task manager showed that Perl was running), and it then solved.
But it took 329 seconds!
Any suggestions on how I can speed that up?
Is it a function of processing power? I’m just using an Intel Stick w Atom processor.

cheers
Malcolm

ps edit: I should add that I am solving just fine when there is an internet connection.


www.mainsequencesoftware.com