Manual rotation/ auto center error


#1

Hi all, I have been using SGP for quite a while but lately I have been getting a error message when starting the sequence.

I select a new sequence with profile,
select my target with the framing and mosaic wizard, Rotate it to fit the CCD ( normally 0 degrees )
connect all my kit & press run.

This has always worked well in the past but lately I have been getting a error message saying
" cannot rotate camera because the rotator has not been synced with the actual sky angel. Run solve and sync and try again.

Any idea why this has started to appear as it has never before, stared in the last few weeks ?
running 3.0.3.151. I don’t know if I have accidently pressed a button or not but it happens on both profiles I have set up.


#2

Anyone able to answer this for me, it’s getting frustrating.

Thanks


#3

Two things come to mind. Have you tried to run “solve and sync” as the error suggests? But more importantly, under target settings do you have “Rotate to:” enabled? Or under the equipment panel of the sequencer window do you have a rotator selected?



#4

Hi,

Yeah I have tried the solve and sync, that does do the job, but I have never had to do this since I set up SGP, (at least 18 months ago ) I also have the manual rotator set up. Target setting also has the box checked…
Rog


#5

Well, if you have the manual rotator set up and the rotator option enabled in the target settings then you must use the solve and sync. That’s the only way SGP will know if the camera is rotated the correct way. What you are asking SGP to do is to confirm what your camera angle is and the only way to do that is to solve an image and check the angle of rotation. If it’s not correct it will tell you.

I’m not exactly sure what you are trying to do. If all you are doing is putting your camera on the scope “close to” 0deg and all you want to do is start the sequence, then you should disable those rotator options and then you won’t be asked to solve and sync.

For myself, I know how to put the camera on the scope such that it is always within 1-2 degrees of 0deg sky angle. I don’t use the manual rotator and have all those rotator options disabled, and yet I know that my angle is always very close to 0deg.


#6

You say I must use the sync and solve, I have never had to use this before the error message started to appear. On maybe over 100 sequences I have already done not once has this appeared. Only in the last few weeks.
This is the way I set up for a sequence
open SGP
New sequence with profile
Select my object in Framing and mosaic wizard in object type in the name (M42) if it fits at 0 degrees I Create sequence,
Sometimes I have to rotate for the object to fit in the frame (m31 has to be @ 90 degrees)
I then select my light frames & filters and duration then press " Run sequence" This is then where I get the error message.
Before this it just used to plate solve it using plate solve 2 & then inform me that I had to rotate the camera to suit, Once done to the desired angle it goes through the rest of the motions & starts taking the light frames.

Roger


#7

There were some recent changes in how the rotation is handled. I’ll double check the behavior with a manual rotator.

Thanks,
Jared


#8

I am in the same situation since I moved to version 3.


#9

Did you find anything Jared ?

Rog


#10

Something new about it? For me it is very important that the rotator manual works


#11

No nothing.

It’s getting on my nerves now

Roger

www cap1obs.co.uk


#12

I am having the same issue. I prefer the old way, when the sequence did not come to a halt for an initial plate solve to assess current rotation. It makes it impossible to program a sequence start time and have it run on attended on a series of nights when the rotation has not changed.

The rotation check should be more of a confirmation during the target centering process, not a prerequisite for starting the sequence.


#13

Is anyone looking into this ???

Roger


#14

I am currently running version 3.0.3, and yes, the manual rotator has been broken since the switch to version 3.

So if you need the feature, you may want to stay in version 2. If however you upgraded, here is a work around:
-untick rotate camera.
-plate solve.
-on the plate solve image click on display fit headers.
-one of the fit header populated by platesolve is the actual rotation angle.
-calculate the difference between your desired angle and the actual angle calculated by plate solved and found in the fit header. Apply modulo 180. The result is the angle you need to apply to your manual rotator.
-So rotate the camera by the angle above and iterate the method until your calculated angle is below tolerance.

Good luck, this should keep you imaging until a fix is issued.

Guillaume


#15

I believe I have this addressed but I’m currently unable to test. Hopefully I’ll be able to get it tested tomorrow evening and can get you all a test build at that time.

Thanks,
Jared


www.mainsequencesoftware.com