Meridian flip; Ascom driver/feature request? G53F mount


#1

Hi,
I have the Gemini G53F mount, and it does have an ascom driver in fact 2. (but one reports wrong time to meridian and does not report in a reliable way end of slew)

The issue I have is that the reliable one that reports in a reliable way end of slew, reports time to meridian correct as long as you don’t check the auto meridian flip feature …
As soon as you check this feature time disappears and also when you start an image run SGP reports the mount does not support flip and deactivates it. The driver indeed does not support side of pier … but apparently this seems no issue as that works in ACP according to the vendor.

So could there be an option to just take the reported time to meridian that seems correct and go with that?
I use the latest official release … but same issue was present with 2.3

Thanks,
Yves


#2

The time to meridian is actually calculated by SGP.

Your best bet is likely to use POTH and have it emulate the Side Of Pier which should take this into account.

Thanks,
Jared


#3

Hi Jared,
thanks for the suggestion.
I tried it and indeed the side of pier simulation of POTH did solve the issue of meridian flip.
Unfortunately POTH and the driver don’t agree well, the driver that works has slow latency and the system becomes unbearable slow, so much it also misses the end of slew so the meridian flip will never end as it mow also waits for the slew to complete forever (but even if that was not an issue it’s to slow and CDC will not even respond) Interestingly the latency is nu issue with the generic hub …

As a side note, it seems that ascom drivers not always report end of slew correctly, is there a way to do a more robust detection in SGP, so that the Meridian flip procedure doesn’t fall into an endless waiting?

If time to meridian is calculated by SGP, how comes that connecting with 2 different drivers, gives the same coordinates (I to double need to check this tonight) but a different time to meridian, namely the 2 hours I’m of UTC?

Thanks,
Yves


#5

Here the screenshots of the 2 Ascom drivers connecting to the mount, OTA is over meridian.

First screenshot, wrong time to meridian
Second correct time
Third, meridian time disappears when you check auto meridian flip option

If SGP calculates the time to meridian I don’t understand why there is a difference at same RA and DEC at minutes apart …

/Yves


www.mainsequencesoftware.com