Meridian flip issues SGP/EQMod


#1

Hi All,

My Telescope setup is EQMod Ascom HEQ5/6 and I’m having difficulty in getting the Meridian flip to run properly. I need to understand some basic concepts and hope for help.

EQAscom has a check box for Auto Meridian Flip. I leave it checked and this runs meridian flip with no issues when running WITHOUT SGP.

I’m doing indoor tests to learn and test the SGP Auto flip. I first plate solve an object close (10-30 minutes) to meridian then set the sequencer to take several image then wait monitor the process to see how does SGP run the flip. I’m disabling Auto guider and uncheck ‘Auto Centre after meridian flip’ (becuase I just want to check how SGP runs the flip and continue with taking images)

In all my attempts the meridian flip has been run but I think not by SGP but by the EQAscom and then when SGP attempts to do the flip it prompts with error below

Here is the link to one of the log files

BTW, do I need to keep the ‘Auto Flip’ checked in EQAscom ? could this be the problem ?, I did try to uncheck but then no flip occured.

I would like to know how is the flip performed, my guess is that SGP is sending a command to EQascom to flip and if EqAscom already flipped the mount then maybe this is the cause of my problem

Any help appreciated

Thanks
Uri


#2

Ok guys, I have done more searches re the above issues and found many suggestions which i will try first, sorry guys

Thanks
Uri


#3

No worries. Let us know if they don’t pan out for you and we’ll see what we can do!

Chris


#4

Thank you for reply, afre reading though the ‘Help on Eqmod users’ thread I have made some changes in the EqMod setup (changed side of pier to ‘Physical’ and unchecked the ‘Auto meridian flip’), I also changed the ‘Time past meridian flip’ to be >0 in SGP . I tested indoors and all works, Yeh !, hope it works fine in real, Thanks again


#5

Side of pier to physical will work almost all the time. However, there is an issue with it, in some circumstances. The current settings most recently recommended for EQMOD and SGP users are:

A) Don’t use any pointing model at all. Let plate solve manage the whole alignment process.
B) Use EQMOD version 1.28m and set the side of pier option to “pointing” (version on EQMOD Yahoo Group)
C) Do not enable meridian flip in the eqmod software. Let sgp manage the process.
D) Set the meridian flip at 2 degrees past meridian. (8 minutes in later SGP releases)
E) Set the mount meridian software limits at greater than 2 degrees.
F) Set the epoch in the mount as J2000
G) Alignment/sync user interface set to “dialog based”.


#6

Hi Tim,

I have some doubts:

A) Don’t use any pointing model at all. Let plate solve manage the whole alignment process.

D) Set the meridian flip at 2 degrees past meridian. (8 minutes in later SGP releases)

E) Set the mount meridian software limits at greater than 2 degrees.

Ponit A)… Where is that option? Eqmod or SGP?
Point D)… That’s inside SGP. OK
Point E)… Where is it that option? Is it in SGP? In Eqmod?

I have a Neq6 Pro 2 mount, and uses it through Eqmod.

Thanks
Fernando


#7

It’s better to use Version 1.28m and use the Pointing mode.

Physical only works half the time, for hour angles in the range -6h to +6h. For the other half of the hour angle range it’s wrong.

I realise that the good hour angle range is the area that people use most of the time but there are traps at each end. If your sequence happens to finish slightly after +6h then the pointing state suddenly changes and SGP fails.
I’m not sure what happens if you start slightly before -6h but the pointing state will be wrong and SGP could easily struggle.

IMO it’s a shame that EQMOD has so many options for pointing state. The only one that complies with the specification is Pointing and AFAIK the only version for which that works over the whole of the Earth is version 1.28m.

Apparently the other modes are to satisfy applications that need different interpretations but that just means that there are two applications that are wrong.

There’s a case for allowing for cone error in the pointing model. This will mean that a sync on one side of the meridian will be close when a pier flip is done. Without this a mount that’s synced in one pointing state could have an error of twice the cone error when a flip is done.

Chris


#8

Hi Fernando,

A. In EQMOD in the center of the main page under Alignment/Sync click on the litttle page icon to open your pointing model. Delete all your alignment lists and untick all the choices that add new alignment points. Back on the main EQMOD page set the user interface to dialog based.

D. In SGP open the Equipment Profile Manager and under “Telescope” tick “use Auto Meridian Flip” . Click the box next to it that says “SET” . This opens the Meridian Flip Options. If your version says “Degrees past meridian to flip” put 2. If it says “minutes past meridian to flip” put 8. Tick auto center meridian flip.

E. This option is a safety feature in EQMOD.to prevent the scope crashing into the mount.if the meridan flip fails for any reason. Its found on the main page of EQMOD. Under Mount Limits Tick “Enable Limits”. Click on the little wrench symbol next to that to open up the box to set your limits. You will have to test it but just make sure you don’t set the limits so they kick in and park the mount before the pier flip works. You can easily set this up indoors.

Hope this all makes sense…


#9

Sorry for the question, but I used always physical and I never had an issue, an imager on the same continent had this issue and then someone mentioned the fix of selecting 1.28 this is confirmed to be working …

But I can’t figure out that -6 to 6 Ha is working, then how can one have the issue … our objects are always in that range … so just for my understanding can someone explain the edge case?

/Yves


#11

Thanks for your help!! I currently have version EQMOD 1.27. I have to switch to a new version?
Thank you,
Fabiomax


#12

Yes, the fix was applied to 1.28m. You can get this version from the file section on the EQMOD Yahoo group. Then after you install this version select side of pier to pointing. Also make the other changes as in post 5.


Meridian Flip issue: "Time to pier flip: NA"
#13

Thanks Tim,
first of all I apologize because I’m not good with softwares :frowning: . I could not find this version on the yahoo group. But I found this (versione k):
http://sourceforge.net/projects/eq-mod/files/EQASCOM/
Do you think that’s okay?
Thanks again,
Fabiomax


#14

1.28k is OK if you are in the Northern Hemisphere, not in the South.

Select the “Pointing” SideOfPier mode.

Chris


#15

Chris,

So which version is recommended for the south hemisphere, I use 1.28m as per previous posts and haven’t noticed any problem

Thanks
Uri


#16

Thank you Chris,I installed k version and I set pointing. No limits selected on eqmod
Cheers,
Fabiomax


#17

Thank you Tim for your answer.
And sorry for the delay in thanking you!

I had other different problems, but finally checked all successfully.

But I had to do a change: I had to set the eqmod settings in Jnow, instead of j2000, mainly because Thesky6.

Thesky6 has no way of setting the epoch (or I didn’t find it). With eqmod 1.28m set in J2000, when I slew to any target with TheSky6, the target is always placed with an offset. Never centered. And when I sync with SGP the scope position, I see that the solved coordinates correspond to those in Jnow!.

I changed last night eqmod settings to Jnow, and then the slew is perfectly centered. The star is in the middle of the image, with no offset.

And made a little sequence with 4 targets without problems. But I couldn’t check the meridian flip because of the clouds.

I don’t really now if it’s mandatory to set eqmod in J2000 or its Ok also in Jnow, as SGP understand it.

Thanks
Fernando


#18

Hi Fernando - The key is to get all your programs/platesolvers using the same epoch. It was recommended that EQMOD users start with J2000 because the majority of other programs and plate solvers are using J2000 as the default. So, this kept everything in the same epoch. Certainly EQMOD can also run successfully in JNOW. Just make sure all other programs and plate solvers are also using JNOW. Sorry for any confusion.


#19

Hi,

Hope someone can help with failed Meridian Flip.

Eqmod 1.28
SGP: 2.4.3.21
Log file: https://www.dropbox.com/s/2nnphkqv0tg70d0/sg_logfile_20151213223611_1.txt?dl=0

I have inserted “[Uri]” in the log file in relation to the following issues;

[14/12/15 3:02:21 AM] [DEBUG] [Telescope Thread] [Uri] ASCOM Telescope: Invalid Operation Exception in Sync : SyncToCoordinates() RaDec slew is not allowed while scope is not Tracking. (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —>

What is the meaning of the above error ?

[14/12/15 3:02:21 AM] [DEBUG] [Pier Flip Thread] [Uri] Meridian Flip: Solve and Sync was Successful

Then later in the log file

[14/12/15 3:02:27 AM] [DEBUG] [Pier Flip Thread] [Uri] Meridian Flip: Telescope failed to perform meridian flip

What was the reason for the flip failure ?

Many Thanks
Uri


#20

Usually means your mount was parked, but I can’t say for sure. Would need the ASCOM logs to see what happened. The only visibility we have is that your mount is no longer tracking, so as far as SGPro is concerned, it is done.

No request to park the mount was sent from SGPro…


#21

Thanks Ken,

Yes, the telescope parked, but why ?, is that an issue with Ascom/Eqmod (I wouldn’t want to bother you with this issue if it’s nothing to do with SGP)

I couldn’t find any log file under my documents\Ascom folder other than some Ascom.Profile files which show date/time as of yesterday morning (I have updated to version 6.2).

Are the log files stored somewhere else ?, under what name ?

Thanks again
Uri


www.mainsequencesoftware.com