Moravian external filter wheel issue

Hi guys

This is Ricardo from Spain. I recently purchased a moravian G2-8300 with 10-position external filter wheel. It is my first ccd camera and i was really excited. I placed the filters (Baader), install the drivers in my pc (windows 10 pro, x64).The drivers gave problems when connecting in sgp but checking sgp forum i found that the correct operation were 32bit. So i installed them.
I started sgp application (version 3.0.0.7), configure a new profile and all that stuff. Then i connect everything (camera, filter wheel, focuser,telescope). Everything worked fine. I planned a session that included frames from filters L, R, G and B. I started with L frames and 3 hours later it
was time to change filter and continue the session. Here it appears the window ‘Failed to set filter’. As I was in the field, i changed object and continued with L frames.
Back home, i tried to reproduce the error and it appears. I showed you what the log wrote:

[03/18/19 20:06:21.935][DEBUG] [Sequence Thread] Setting filter: Red…
[03/18/19 20:06:21.935][DEBUG] [Sequence Thread] Moving filter wheel, isMoving, check 1…
[03/18/19 20:06:21.935][DEBUG] [Sequence Thread] Moving filter wheel, isMoving, check 1 is complete…
[03/18/19 20:06:21.947][DEBUG] [Sequence Thread] ASCOM Filter Wheel: Error in SetFilterWheelPosition. : Referencia a objeto no establecida como instancia de un objeto.
_ en ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) en c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:línea 236_
_ en ASCOM.DriverAccess.FilterWheel.get_Names() en c:\ASCOM Build\Export\ASCOM.DriverAccess\FilterWheel.cs:línea 88_
_ en q6.ib(Int32 position)_
[03/18/19 20:06:21.952][DEBUG] [Sequence Thread] Adding sequence level notification: Failed to set filter, aborting sequence!
[03/18/19 20:06:21.955][DEBUG] [Sequence Thread] Sending Notification: Error - Failed to set filter, aborting sequence!
[03/18/19 20:07:23.563][DEBUG] [Sequence Thread] Error setting filter position! Cannot continue sequence!

When the error appeared for the first time, ASCOM platform 6.2 was installed in the pc. I updated to version 6.4 and the result was the same. Actually i’m blocked because i don’t know where the problem could come and how to fix it.
I will really appreciate your help. Thanks

Did you manually move the filter wheel in SGP before starting the sequence? In other words, could the filter wheel change positions outside of a running sequence?

I would suggest you uninstall all drivers related to Moravian and reinstall them, and make sure to use the 32bit drivers. (Moravian is very confusing about this - they don’t make it clear that 32bit drivers are what 99% of people need to use even if they have a 64bit system).

I would also check the wheel to be sure it works with the software provided by Moravian. My Moravian had some serious mechanical issues with the rubber drive ring on the outside of the filter cassette.

In fact, just watch the filters move when the camera is first fired up. If it makes a funky noise and/or does not stop on the luminance filter, you may have the drive rubber issue.

Hi guys

First of all, thanks a lot for your comments.
I did reinstall only the x86-drivers and the situation persisted. As I was performing all the tests with the moravian attached to the telescope, I unmounted it and left it on a table to check whether the filters move or not. I plugged the power and it sounded like moving but the wheel didn’t move. so i decided to unscrew the the filter wheel housing front and connect it again. Now the wheel spinned!! I connected to Moravian software (SIPS) and the wheel moved, took frames and everything seemed ok. In SGP, did not appear the error i showed you on this post.
So i decided to screw the filter wheel housing front and test it again. Here was the key point. When covering the filter wheel, something (maybe the end of the M3X6 screws) blocked and could not allow the filterwheel to move. Maybe I didn’t mount the filters properly. That’s why I attatch 2 photos. The Moravian manual is not explained very good. it contains very few photos or a ‘howto’.
Apart from that, what i discovered is that the wheel is not leveled. So when it spins, one side goes upwards and obviously blocks the housing front.
In summary. the issue is not a software problem. it seems a mechanical problem. Then, if anyone may had this issue when mounting the filters, please tell me whether i’m mounting in the correct way or not.
Thanks


1 Like

I’m also interested on what’s the problem you are having as I plan to buy a Moravian external filter wheel as well.
Hope you have it solve soon.
I’ll keep following this thread.

Hello I use also the G2 wie 10 36mm Filters…
the wheel must be leveld! there is an little Nose on the wheel this must be in place in the housing…be carefull…
the srews are to long…mine are shorter and have rubber under the “dish” look for an little packacke in the Moravian Box…
also the Filters must be Set in Ascom Filtwerwheel…
the backlash and are set in SGPro.
withe Moravian the Filterchanges applie during EXPOSURE the wheel turns after the start…like:

Sequence…start… filter set to R for instance…Camera returns filter changed…but stays in place…when exposure starts THEN the filter is changed during …its an Moravian thing…

hope an can help u

Moravian says…WARNING!!!
“Always use the screws supplied with the filter wheel. (M3×6 screw with countersink head). Longer screws may extend inside the camera head and may interfere with the camera shutter.”…

Screws should be shorter. I would also suggest you move one of the filters so the empty spots are on opposite sides so you get better balance.

Hi guys

Good news!! - The filter wheel spins!!!
In my last post, there was a photo that shows the screws I used were M3x6, as the manual suggested. There were 8 filters placed (LRGB HalphaSO,clear) in the filter wheel and they aproximately weights the same so the balance is quite compensated. With 5 or less, it is a good idea to redistribute.
In the ccd box there were a set of different screws. M3x8, M3x6 and M3x4. The problem was that the screws blocked the filterwhell so i used the shorter ones. I changed all the screws into M3x4 and…it works. (I attach a few images) The i ran SIPS software and the filter changes without any problem.

I didn’t have time to check it in SGP but i feel confident that it will work. I hope to program a test session during this week and see. In case, something strange appears, i will let you know.
Thanks very much for the comments that help me a lot to look for the solution. Anyway i will write to Moravian support to review the user manual in reference to those screws.

Thinking over my own setup i do actually think the screws you used were correct, they just should be used with some plastic spacers so the screws should not have touched the glass directly.
Did you maybe not get the plastic spacers?
You can see the spacers being used here.

I can advice you to apply a little blue threadlock onto the screws, i had a problem with 1 screw getting loose during transport that got the shutter stuck.

Yup, in fact, I got some slightly larger plastic washers since I was not comfortable with the amount that the stock washers engaged the filters.

FYI, watch your power connector closely. They use way too small and cheap a plug. Several nights ago mine would not stay connected and it turned out that the poor contact had literally melted the female power jack (despite making my own high quality male-ended 16 gauge power cord. I said screw that and soldered the power cord direct to the board - works fine now.

www.mainsequencesoftware.com