Optimising ANSVR Config

Hello all. I sart my imaging sessions with a blind solve to initialise the mount. It usually takes about 6 minutes to solve. So I was wondering what are the best settings to use in ANSVR Config, in the hope that the solve time will come down. My knowledge of what the config settings do and how/ if they interact is very limited, so if anyone can explain the settings and help me to optimise that would be very much appreciated. My current settings are copied below for the C11@F8 with SBIG STT8300 mono

Solver time limit, seconds: 420
Scale error estimate, percent: (left blank) (leave blank to accept error estimate from SGP (100%))
Downsample factor: 2 (leave blank for no downsampling)
Advanced solve-field options:
Epoch for solution coordinates: J2000
Noise level: 10 set the noise level in the image
sort the star brightnesses by background-subtracted flux; the default is to sort using a compromise between background-subtracted and non-background-subtracted flux (unchecked)
Objects: 100 cut the source list to have this many items (after sorting, if applicable).
Depth: 1-50 number of field objects to look at, or range of numbers; 1 is the brightest star, so “10” or “1-10” mean look at the top ten brightest stars only.
Additional solve-field arguments: (none)

Remove temp files after solving (checked)

I am a long time user of SGP and prior to that I used a program called Astro Tortilla to do plate solves, it has a similar config and uses the same astrometry index files. I could speed that up considerably by just including the indexes for my setup (C11@F8) which were the 4205 series of indexes. Because I also occasionally use a canon camera with 200 mm lens, I have also included the index files for that in the index data folder. Will that affect performance of the C11 as it now has more index files to search?

Thanks very much for help,
Paul

This doesn’t answer your question directly, mostly because I too am unfamiliar with what most of the ANSVR settings do. But it certainly should not take 6min to solve. ANSVR usually takes 20-60s for me. Including all the indexes may slow things down a bit, but I don’t think it’s all that much.

I would encourage you to instead try ASTAP as your primary, first solver. If you just provide an approximate image scale (0.48"/px) and approximate camera angle in the camera tab of the control panel, ASTAP should solve very quickly.

At your image scale (0.48), plate solving can be a bit tricky. Do enough stars show in the field?

Hi Joel,

I seem to remember an image scale of 27 x 21 arcminutes, so yes a small area of sky with few stars. That’s why I was interested in the ANSVR config settings and what effect they may have.

I use platesolve 2 as the platesolver once the initial blind solve initialises the mount and that is lightning fast, but it will not blind solve.

I’d like to give ASTAP a try, where do I find it (I’ll try a search engine) and does it integrate with SGP?

thanks for your reply, much appreciated.

Paul

ASTAP is now included in SGP 3.x as an option (Control Panel/Plate Solve tab). You will need to download and install the “G17 star database installer” found here: http://www.hnsky.org/astap.htm

A few other notes:

  1. 27x21 is not your image scale. That’s your field of view.
  2. You don’t need to use a blind solver to get things started. If you put your image scale (0.48) in the Camera settings (Control Panel/Camera tab), and approximate the camera angle you can solve very quickly with either PlateSolve2 or ASTAP. You don’t have to use a blind solver at first. Blind solve and non blind solves do the exact same thing. I guess I don’t understand why you are trying to blind solve. It takes much longer. It can be useful if you don’t know the other hints (scale, angle, position) but since you do know these hints it is much better to use a non-blind solver like PS2 or ASTAP.

Thanks for the information Joel and yes it’s the field of view… - lack of sleep after a run of 5 imaging nights is my excuse!

I’ve copied below my camera settings in my default profile. I filled in the angle and scale from the successful solve dialog. As an example of my initialisation process, I connect the scope in SGP and point it just west of the meridian, take a 5 second exposure and blind solve to initialise. The reason I blind solve is that I have never been able to get platesolve 2 to work for this initial solve. Platesolve 2 works really well when I centre on a target, it really is fast - often 1 or 2 seconds for a solve. So, given what you’ve said, do I need to tweak the platesolve 2 settings to get it to be effective for the initial setup solve?

I have just loaded a recent image I captured in SGP, right clicked and platesolved with PS2, it took 3 seconds ish. If I keep the PS2 dialog open, the angle PS2 reports is 87 deg. When I close the PS2 dialog, it pops up the usual completion dialog which reports angle as 272 deg. (this is why I placed 272 in the dialog below). I haven’t paid much attention to the PS2 dialog while its in the solve process, so wondering now if this might be a problem. I guess not though as PS2 works on all solves bar the first one I do.

Thanks very much for your help.

image.png

OK, I think this might be your whole problem. Don’t point the scope anywhere near the meridian. I think what might be happening is that the mount still thinks it is pointed east, but in actuality the scope is pointed just past the meridian (i.e. West) that could cause issues with solves no doubt. This would also explain why you get 87deg or 272deg. For example, SGP passes through the location from the mount to the plate solver (PS2 in this case). If the mount thinks it’s still in the east just before the meridian, but really the scope is in the west just after the meridian, then the solve will no doubt fail.

Start by pointing the scope 45 deg above the horizon in the east.

I still would recommend trying ASTAP. I think it is more reliable that PS2.

I’ll give it a try tonight Joel. I’ll explore ASTAP as well in the coming days. Thanks

Paul

Unfortunately no difference at all. It does not matter where I point the scope, PS2 will not solve as the 1st PS of the night. I’ve taken some of the index files out (4205 and 4206) active at present for ANSVR.
I’ll try ASTAP next clear night.

thanks
Paul

Paul

Astrotortilla, ANSVR, and PlateSolve2 all rely on astrometry.net (AN). AN can be installed locally or remotely on the Internet. A local install will be MUCH faster than a remote install.

Options which can reduce solve time include

–downsample 2
–scale-low
–scale-high
–scale-units
–no-plots

This is what they would look like in ANSVR Settings (downsample is a separate setting)

–no-plots --scale-low 40 --scale-high 90 --scale-units arcminwidth