Pixels lost unable to calibrate images

The other night i managed to capture a cuple of hours os data.
I have a asi1600mm pro been using it and captured a few targets but still a beginner astrophotographer.
Now SGP put up a splash screen when connecting the camera stating that the ZWO driver is no longer supported please switch to ASCOM driver for ASI cameras.
It also says that if your camera works you can ceep doing that .
I did not notice any difference untill I tried to calibratethe images prior to stacking.
Using Pixinsight for calibration and stacking, and the darks and flats where processed and when the lights where to be calibrated Pixinsight throw an error stating “Error : incompatible image geometry”
The error states that the flats and darks is 46563520 and that the lights is 46553514.
The darks where aquired since before but the flats and lights where captured the same night.

Is there anyone that have experienced someting similar? And figured out what the problem is.

There is no logic to why Pixinsight reports the error since the flats and lights where captured at the same night and the same driver.

Any help is apriciated

it could be that PixInsight is scaling the flats or the darks for you. In my experience that message is generally generated from the difference of the Dark and Light frame. If the darks were acquired with the native driver it’s very likely that they are scaled differently…the data could even be represented in a different manner.

It is probably best to retake the dark library with the ASCOM driver. It is odd that the darks and flats have the same number of pixels though. I wonder if the Flats were scaled with the darks? For some reason I recall that as being an option but it’s been a while.


Thanks Jared
It’s really strange since I did not change the driver but continnued with the old one despite the warning to change to the ASCOM driver.
So from my perspective the aspect ratio should have been preserved.
However will try to recapture a cuple of darks to these the theory with scaling.
Sounds plausible.


Did some testing today.
There is nothing wrong with the ASCOM or ZWO Driver. Tested both and both deliver the exact camera chip resolution.
The issue i think is the Blink process in Pixinsight. I compared the original image to the same image saved via the Blink process and the original have the same dimensions as the camera chip the image outputed from the Blink process is missing 1pixel in with and 6pxels in height.

So mystery solved, need to re-run Blink Process script to se if I can reproduce the issue. If pixels are mising I’ll report the issue to the Pixinsight team.