Restore "Pause Autoguider on Download" Option


#1

Hi guys,

Now that PHD2 can do a full pause (stop both guiding and imaging) the Pause Autoguider on Download makes more sense to reduce USB contention.

For example, the QHY5II-L camera I use for guiding is very chatty. Although I have set everything I can (according to QHY’s FAQ and various forums) to reduce its USB traffic, it still disconnects sometimes if SGP is downloading the imaging camera. I have to reboot the laptop to get it to reconnect. My laptop has 4 USB 2.0 ports but they all are controlled by the same hub, so moving the camera to a different port does not help.

I understand that this option was not terribly useful in SGP 2.3 because PHD continued to image and download even when paused, but this is no longer the case. It would be useful to me and, I would expect, to others.

  • Shane

Stop Guiding During Downloads
#2

Shane,

PHD2 is not the problem. It is really that, with ASCOM, the download of image to PC happens inside the native driver that ASCOM controls. This means that, by the time ASCOM reports the image is ready, it (could be) already downloaded and waiting in memory. Some manufacturers appear to delay this until you try to access the memory, others pre-fetch it as soon as the image is complete…it is hard for us to tell which is which. So… the best we can do here (to my knowledge) is guess when your camera is done exposing through use of precision timers (though there would be no guarantee because it is not in sync with your camera’s timer).

Ken


#3

OK. I understand. I was just hopeful that I could eliminate one more
issue …

Years ago I realized that astrophotography has a parallel process:

  1. Identify the thing that is causing you the most problems.
  2. Fix it, change it, eliminate it, or find some other way to do it.
  3. Goto 1.

SGP has eliminated so many of my problems that I’m down in the weeds
now! Thanks.

  • Shane

#4

Shane, I have this problem too. I keep my imaging camera on a separate USB from the rest of my setup.


#5

Yep, but all of my USB ports end up at the same root hub, so moving it
doesn’t really accomplish anything …

  • Shane

#6

That’s interesting. It seems to make a big difference for me. Have you tried it?


#7

I can only recommend this too. I had one really bad night, where I had some
strange artifacts on my images that I couldn’t explain. After a lot of
analysis and try and error, I came to the same conclusion: that some data
was silently dropped when traffic was too high. After digging into the USB
specs, I realized that this is how the USB protocol works (dropping data
instead of just cutting of connections or creating high latencies). Since
then I use a dedicated USB cable for the imaging scope to avoid this (and
never had that issue again).

 MarkS

#8

Yes, I tried all combinations and none seemed to help, so I opened up MS
Windows->Control Panel->Device Manager and found that all 4 USB ports go
to the same root hub.

That means when Dell designed the laptop, they put all USB 2.0 ports on
the same channel of the same controller chip, which means that they all
share the bandwidth of that channel. Stupid design.

I have four options:

  1. Deal with it. It doesn’t crash that often.
  2. Replace the laptop.
  3. Replace one of the cameras with one that has a USB3 or ethernet
    interface.
  4. See if I can make one of the USB over ethernet devices work reliably.

Options 2, 3, and 4 cost real money and will have to wait.

  • Shane

www.mainsequencesoftware.com