Rigel focuser disconnects


#1

Started having this problem. The Rigel focuser just disconnects. Was wondering if anyone is/has experienced similar? Any thoughts/suggestions? One thing it says is “SGPro thinks the focuser is connected, but it’s not,”

Logfile. Scroll to 22:48 and the error is shown: https://www.amazon.ca/clouddrive/share/S7oT8LThwHCczLstqioN7pvov4n7ZDJmPkq5DlExgBz

Thanks for any help.


#2

I have been using 2 of these for several years and have never seen this happen. You should double check your cables and power supply.


#3

Yes I’ve been using the same setup for over a year without any problems. Just started happening two clear nights ago. I checked the voltage to the Rigel focuser and its fine and checked cables, unplugged and reconnected etc. Seems to only happen when SGP wants to change focus as part of a sequence. If I manually adjust it doesn’t happen. Which is why I included the log. Maybe there’s a clue in there for someone. I read a couple other posts from previous years that had focuser disconnects like mine, one with the same log event, but no real answers to be found to fix my new problem. Not sure whats the difference between manually changing focus (course/fine) and SGP doing it as part of a sequence that would lead to a disconnect.


#4

Went back to v3.0.2.94 and ran some test sequences and the Rigel focuser did not disconnect. I had upgraded to latest release the same time the problem began (could be a fluke but I don’t know). Next test will be to upgrade to v3.0.3.140. Then to latest release again. See what happens.


#5

Its been cloudy here but tonight I had a chance to try again. Now running 3.0.3.151

And again the Rigel nstep focusser gets disconnected when using auto focus routine. If I focus manually (course and fine) there is no problem. I repeated this successfully many times to realize when it was happening.

Could this be a bug? The last ver I ran this didn’t happen was 3.0.2.94. Every subsequent release the Rigel focuser getting disconnected has been occurring.

Is it possible to have a dev weigh in here on this? I can’t seem to run any new versions while this is a problem.

Thank you.


#6

FWIW - I am on 3.0.3.140 and I do not get disconnects with Rigel nstep.focuser,

Not sure I want to upgrade now … :=)

Having said that, if others are not having disconnects on 3.0.3.151 or newer versions, then I would think the prime suspect would be communications (ie. usb cables, usb hub etc.). Is your focuser connected via a usb hub? If so, is it a powered one? Have you tried using a different usb cable? Use usb 2 instead of usb 3 port? Run usb direct to PC instead of via usb hub?

DaveNL


#7

Thanks for this input Dave. The hub is powered. I’ve changed cables and even checked voltages. I determined last night, the disconnect problem only happens when SGP autofocus is used. If I manually move the the Rigel focuser in/out all is fine. This is what is perplexing.


#8

Hi Shawn,

Just another data point. Not sure what’s up but I use the Rigel nStep system with SGPro for a couple of years now and so far I have never had it suddenly disconnect at any time while using SGPro. I have 3 of the Rigel nStep systems on 3 different scopes and running SGPro on three different systems, 2 laptops and 1 NUC. I am currently using SGPro version 151, haven’t had time to update to the 153 version yet.

I’m wondering about 2 things.

  1. During autofocus are you also running PHD2 and if so wonder if there might be an issue with too much traffic on the bus with trying to download PHD2 guide images and the Autofocus images. Just a thought Since I use a OAG, PHD2 is always paused during Autofocus. I also always using 4x4 binning during autofocus so that keeps the file size and traffic limited. .
  2. Not sure of the camera you’re using but could the camera be the issue. Although you said this has never happen until after you started using version 94.

Something to try if you haven’t do so already:

  1. If your not binning the camera during autofocus trying binning to see if that helps.
  2. If using PHD2, try pausing PHD2 during autofocus.
  3. Do you have another camera that you might be able to try? even if it’s your guide camera to see of the problem goes away

Hope this helps,
Mark


#9

Hi Mark - thanks. This is excellent stuff to look at. I will give these suggestions a try. The camera I am using is the Moravian G3 16200EC.

Best,
Shawn


#10

I would suggest that you try connecting your Rigel nStep USB cable directly to your pc and not go through any hub. USB hubs are notorious for causing issues like yours. For example, Sotware Bisque strongly recommends not using any USB hub. I had persistent problems with cameras, focusers and tried about 5 different brands of hubs. I finally moved my pc closer to the mount so I could eliminate the USB hub. Problems went completely away.


#11

Hey Shawn,

Did you get your Rigel focuser working? I was just interested and if you did what did you find was the issue?

Mark


#12

Hi Mark - I tried your suggestions but it didn’t fix things. I ended up buying a new USB cable and running the rigel focuser direct to the computer, not through the USB hub as jmacon suggested. Have had a lot of clouds lately but was able to test things this way, and it seems to be working ok now. No disconnects. Even using latest SGP. I am hoping to test it more if we ever have a clear night again here! Thanks for the suggestions regardless. I appreciate all the help. These things can be confusing and tricky to sort out.


www.mainsequencesoftware.com