Save new sequence - but nothing has changed


#1

Every time I start SGP and close it without doing anything it asks me to save the ‘new sequence’. What is happening here?

Lawrence


#3

That’s weird. I thought that was expected behavior to prevent loss of data, but when I just checked it myself I don’t get the message to save the new sequence. Are you sure you are not doing anything at all? Just open SGP and then close it and you get the “save” message?


#4

I just opened SGP and then hit the close button…it closed without protest.

I opened it again and changed the first event in the empty sequence from ‘Light’ to ‘Dark’ and then hit the X at top right to close the program. It then told me the sequence had changed…did I want to save it. This I guess is what you are talking about. If you do anything on the sequence pane…it obviously detects that and just checks with you before closing…a good thing I believe. Just ignore it if you do not need to save any changes.

Brendan.


#5

Hello. Absolutely no changes made; just opened and closed - reproducible!

This problem started when the program crashed a day or two back. I reported the problem that there seemed to be no error trapping on camera failure to connect. Since then this - and other - effects are happening.

Lawrence :confused:


#6

If it was me…I think I would just uninstall & reinstall. It won’t take long and might just get rid of the gremlins :slight_smile:


#7

Actually, yes. I can retain the sgf files.

Lawrence


#8

I tried using ‘repair’ but didn’t have any effect. Run and then close tells me to save the ‘new’ sequence…

Lawrence


#9

Well! I did an uninstall and then a re-install. Same error message. Wants me to save a sequence that has not changed in the two seconds since loading. Can anyone help here? Something must be seriously wrong.

Lawrence


#10

Just go ahead and try to uninstall/reinstall. You won’t lose any settings
or saved sequence files.


#11

I experience the same behaviour. Open SGPro and immediately close it again without changing anything. I too get asked to save the new sequence. Uninstall and reinstall did not help.
Running on Windows 10…

Regards, Peter


#12

Thanks Peter. I’m (sort of) glad that its not my imagination. Clearly
some info is retained after an uninstall, and somewhere the error is
re-introducing itself on the ‘new’ install.

My second laptop has a comparable SGP setup and does not do this. The
problem only arose after a camera-connect failure crashed the program -
as if there had been no error trapping. Other problems have arisen on
this installation.

regards

Lawrence


#13

OK. That was easy to do but it made no difference. I start SGP, let the windows open, then close the program. It asks whether I want to save the new sequence.

I will live with this one for the moment.

I still have the critical problem that during image downloads the s/w claims to have lost the camera and cannot stop waiting. If (when) finally click abort, the whole progrsam crashes - every time. This may be an ascom problem (I cannot interpret the log file), but it does seem as if there is no error trapping.

The camera connection is fine; I tested with ‘other’ software, downloaded images OK, and then reverted to SGP. There are other problems but I can’t deal with everything in one session.

I shall try to post one of the logs from last night showing the numerous errors listed.
Lawrence


#14

Well, unfortunately the mystery continues. Three nights ago all went well and I made progress in upgrading my knowledge; I collected three image sets via plate solve pointing.
Then two nights back SGP again crashed during the focus routine. Its a major crash. It says ‘downloading image’ but this takes forever. I know that if I click ‘abort’ the whole program will crash. Finally, after 60 secs I click ‘abort’. The whole program crashes and refuses to work for the rest of the night.

What I forgot to do here was to switch laptops; I have two in the observatory (one collecting all-sky-camera data) and this works for SGP crashes… Problem is I still don’t know why SGP crashes violently when it loses camera connection. The same camera still collects normally to any other program.

regards

Lawrence


#15

This morning I removed SGP from my ‘observatory’ laptop. I closed down. I powered up and ran SGP. I closed SGP and it asked me if I wanted to save the ‘changed’ sequence.

regards

Lawrence


#16

This problem still happens. To test again, I just opened SGP and then clicked to close. It asked me to save the (unchanged) sequence. I did so and then closed. I opened it again and closed it - but it asked me to save the (unchanged) sequence. Something is definitately wrong - surely?

Lawrence


#17

Have you tried uninstalling and reinstalling everything?

Too many people dont have this problem for it to be SGP. It’s a configuration problem.

If you’d like me to use team viewer, we could check out what’s happening. Feel free to PM me.


#18

Hello - and many thanks for your response. I have not found out how to PM anyone - there doesn’t seem to be that option anywhere. I would like to send one PM for the test.

I have uploaded the log file to Dropbox - I hope this works.

Could you also tell me whether its possible to see the PlateSolve2 ‘error distance’ in realtime (as soon as it has been measured) so that I can tune the sequence/control panel where it asks for the ‘acceptable distance’ from target. (I hope this is clear!). Without that distance, I have to use a huge allowable distance or the sequence will never continue.

(A grateful) Lawrence


#19

Lawrence…I’ll answer the first part for you…

Click on the avatar of the person you want to message and in the top right corner of the pop-up window you will see the MESSAGE icon. Click on that to send a private message…hitting ‘message’ to actually send it.


#20

Done it - thanks!:grinning:

Lawrence


#21

Ok, we’ll figure it out this afternoon. Is it supposed to be clear tonight?


www.mainsequencesoftware.com