Sequence aborting after autofocus


#1

Hi,

I am experiencing an issue that I think may be related to communication between SGP and PHD2. I am running versions 2.4.2.11 and 2.5.0,respectively.

I am actually sitting at the Okie Tex star party and am experiencing aborted sequences after every autofocus run (each 1 degree C drop).

What it looks like is that SGP requests a dither, then immediately goes into the autofocus run (please note that i have enabled the “pause guiding during autofocus” feature. Once the auto focus run completes, it reports that it is restarting autoguiding, and PHD2 settles… however, after the settling is complete, SGP immediately reports that the sequence has ended. The exclamation alert by the individual event in the sequence reports that the guide star was lost, however PHD2 is happily guiding along. Further, if I dismiss the dialog that indicates the sequence has ended and “resume the sequence” it immediately restarts.

The temperature has dropped 9 degrees C so far tonight, so i have lots of these premature sequence endings in the attached logs, along with one field power failure (which is why there are two logs). Any suggestions would be greatly appreciated.

There are several examples, but one follows a successful focus run at 11:27:00 in the first log. The 3rd and 4th logs are the corresponding PHD2 logs.

Best regards,
Craig Smith


#2

Hi Craig,

The guide logs are helpful, but could you also post your PHD2 debug logs?

Thanks,
Andy


#3

Hi Andy,

Thanks for taking a look. I generated three logs last night…The first covers the time frame I mentioned, but I restarted my sequence at least 7 times after automated focusing runs, so there should be other instances as well.

Thanks again,
Craig


#4

Also, I assume it is obvious to you guys from the logs, but for the record, I am using an SBIG STT camera with integrated guiding, so my guide camera is interfaced via the SGP module.

Craig


#5

Craig,

Both @Andy and I have been over your logs and neither of us has any good idea why this is happening. A couple things:

  • You can prevent this from happening by disabling star mass detection change. SGPro will not receive a sequence ending message for star mass change (which is what is happening)
  • I know this might be a little hard to capture, but what might be valuable to us is the “first” guider image after AF saved to disk and then a “normal” guider image so we can compare the two.

It appears as though the guider image after AF is somehow less integrated than other images. I’m not sure how this can be true. To the best of my knowledge the guide chip on STT models is in front on the main shutter (in the filter wheel I believe) so I don’t think having it closed for part of the guider exposure would make any difference in terms of image intensity.


#6

Just to add a bit to what Ken said, the star mass went up abruptly for a while after each AF, but then oddly went back down, except for the third AF run.

Sometimes the mass will change abruptly if something makes PHD2 lock on to a different star, and the Star Mass Change detection option is there to protect against that happening. When that happens it is accompanied by a shift in the star position (because it’s a different star), but in your case we see the star mass change abruptly (downwards) without any change in the star position. That is the mystery.

And to reiterate what Ken said, you can probably just make this go away by disabling the Star Mass Change option on the guide tab in the brain. If you have a good dark library or bad-pixel map then the star mass change option is not really buying you much anyway and it is pretty safe to disable it.

Andy

Plot from PHD2 Log Viewer, Yellow line is star mass:


#7

Thanks for looking at this @andy and @Ken.

The guider chip is, indeed, in front of the filters on the filter wheel with integrated guider. It also incorporates a shutter on the guide chip which is only functionally useful for building the guide sensor dark library. Due to a requirement for backward compatibility with older model cameras (as explained by SBIG), the guide chip shutter opens and closes with each guide exposure… with the exception of when the main shutter is open (which is, thankfully, most of the time that you are guiding)… And at that point, it stops opening and closing.

So I wonder, since the guide chip shutter is not being purposefully manipulated, whether the shutter may be in the way part of the time or perhaps not fully opening or closing? I will see if I can look into that and try to see if there is any obvious visual evidence of what could be abruptly changing the star mass during these events.

On the other hand, since you have seen the logs, maybe this wordy description could help. I’m pretty sure the fatal “Star Mass Change” message was being generated after the dither and before the focus run (or at latest, at the beginning of the focus run), but not being acknowledged by SGP immediately. I suggest this because more than once when I was at the scope, I heard the warning “beep” right after the dither or possibly right at the beginning of the autofocus run. (Note, as an aside, the fact PHD2 is reporting a star mass change may suggest it was not honoring/receiving the “pause during autofocus setting.”) SGP then proceeded with the autofocus run and successfully completed it. Then the guider was restarted, and settled. As soon as the settling timer counted down and the next image was to commence is when the sequence would abort. It “seemed” (from a user perspective) like the “star Mass Change” message was out there in a queue somewhere (or perhaps sent to a different program module), but was never seen until much later… right when the next image acquisition was cleared to start. As an aside, I confirmed several times that PHD2 was, in fact, successfully guiding when the sequence abort was issued.

The description in this rather wordy paragraph is why I wondered if there were some communications between PHD2 and SGP were getting waylaid for some period

Otherwise, your suggestion worked great and thanks for that. No aborted sequences… Lots of 20 and 30 minute subs and some much-needed sleep. Sorry for the long message… I hope maybe it is helpful.

Sunburned, windburned and largely sleepless in the OK panhandle,
Craig


www.mainsequencesoftware.com