Sequence recovery issues (226?)

I’m running the latest beta but that may not be significant. I had one of the first cases of an automatic restart of a sequence after unsafe conditions. I let SGP completely handle PHD2 and I noticed that PHD2 equipment was still disconnected and SGP was waiting for a guider response when it tried to start up again. SGPwas waiting for me to dismiss a start of sequence note when I returned home at 22:39.

[update] The night progressed and I started PHD2 manually and the sequence again after dismissing the camera temperature warning (which also seems to block the resumption process). One sub later, another cloud popped over and SGP shut down due to safety issues. In the morning, all the equipment was still connected (on the first shutdown it had all been disconnected) and the camera temperature warning dialog was up again, yet the camera was (by now) at -20C. I am not sure if these anomalies are associated with the latest beta. I think I had one instance before, when the resumption feature was first put in, and I recall it worked fine.

I was expecting a resume to work in the similar way as the initial run sequence - equipment connects, including PHD2, waits for camera cools down and away it goes. The sequence start note and camera temperature warning dialogs appear to be getting in the way too.

One last thing, sorry, but going between betas, for some reason I’m losing the sequence event counter updates. I have never had this before but when I load up a work in progress sequence, the event counter has not been updated from the prior session; I have more subs on the drive than the event counter is giving credit for. For instance, although autosave is enabled, I did a full night’s imaging with beta 213 but when I updated to 226, there was no account of it. I’m not sure if that is a 213 or 226 issue.

(full night logfile beta 226- updated from last night)

earlier 226 logfile (possible sequence save issue)

If I get a clear night - I will try and fabricate a shutdown due to unsafe conditions, so that I can accurately date-stamp the events and help you investigate.

@ken
Further observations that confirm some logic suggestions:

I heard my roof close at 1.50 and decided to monitor what SGP was doing.
(Cool down on camera connect and restart sequence with safe conditions were enabled)

SGP went through the shutdown sequence - parking mount, shutting roof, disconnecting equipment , (which includes safety monitor) warming up camera and instructing PHD2 to disconnect.

Once it had warmed the camera, it immediately started to reconnect all the remaining equipment and cool the camera. [first suggestion, if ‘restart with safe conditions is enabled’, don’t unnecessarily disconnect equipment and warm camera]

It was patchy cloud and before the camera could fully cool down, safe conditions returned. The Camera Temperature warning dialog popped up - the usual yes/ no/delay question - but I am certain that this blocks the recovery process and if I had not been around in the middle of the night to say ‘yes’, it just stays there (in the OP, when I first noted these issues 2 days ago, this camera temperature dialog was still on display in the morning and all the equipment was still connected).
I clicked ‘yes’ and the sequence carried on. [second suggestion, if ‘restart with safe conditions is enabled’, don’t allow this warning to impede things, or wait until camera reaches temperature before starting the restart process - also if first suggestion is carried out, second becomes redundant.]

PHD is disconnected from equipment - but the good news is I think SGP reconnected later on when it started up the sequence, once safe conditions returned and it opened roof and slewed to target.

I had ‘OK to Open’ as my safety monitor with Overcast as worse cloud state. There was enough cloud to cause the recovery plate solve to fail and the system went into shutdown again. I have now changed that to ‘OK to Image’, with Clear being the worse cloud state, which should stop a premature restart recurring.

Back to bed - cloud is forecast to clear later and with ‘OK to Image set’ as the safety monitor going forward and cloud level set to ‘clear’ and ‘Cool on Camera connect’ enabled, we will see what happens.
later…
Good conditions did not return and the system shutdown as normal by morning, which I assume is because the end of sequence time was exceeded.

hope this helps. I have a logfile but I don’t think it is that useful in this instance.

Are all your Restart issues occurring because all the kit is being disconnected on ShutDown? I am using the Restart feature to great effect with the latest beta (226).

I have the following set on shutdown: Close & Park Dome, Park Telescope, Warm up CCD. PHD2 stops, but doesn’t disconnect. It all sits there waiting (with everything still connected) for the camera warm up to complete. It then restarts the sequence and sits and waits for weather conditions to become Safe again (which might have already happened!). When it is Safe, I have the CCD set to cool on sequence start, so it then starts to cool the CCD. Meanwhile the Dome opens, the scope slews and it centres on target. PHD2 resumes. The system waits for the CCD cooling to complete and then runs autofocus and off it all goes with the sequence. Until it goes Unsafe again… which at the moment doesn’t take long!!

I hope that all might be useful?

Gav.

@buzz

Thx, I’ll take a look at those 2 things.

Can you share the sgf file you are seeing this with?

Gav - I have ‘disconnect all equipment at sequence end’ enabled in the sequencer window. Do you do that?

I can see how you avoid the temperature warning getting in the way- since the option to ‘cool on sequence start’ does not throw that up.

No, I don’t have the disconnect everything option selected. I connect and disconnect everything myself.

thanks - that would account for the difference and homes in on the logic decision tree

@buzz

Im not sure about this one… we have no indication of whether or not a warmup is necessary. You may restart, you may not. I guess we could put a delay in here for a couple hours? If no restart by then, warm up? Have to think about this.

We have accounted for this. What you have here is a bug. I suspect you cool down your camera on connect and this dialog was only avoided if you cool down on sequence start. This has been fixed.

@Ken
Thanks for that
I changed my settings to do ‘cool down on sequence start’ and disabled the automatic disconnect and imaged last night. I had further restart issues, which may or may not be particular to this beta and it may be applicable to general startup too if the restart code is using the same logic.

The issue is that SGP was stuck on centering and disregarded the unsafe conditions.

This occurred on an automatic restart at 4:15. I could see from my cloud level log that it went clear at about 4:15 for about 10 minutes and then went cloudy (unsafe) again.

The notifications said at 4:20 it was shutting down again due to unsafe conditions but when I got up to review why it was cloudy with the roof still open, there was a failed attempt at centering on screen and the unsafe indicator was on, yet the mount had not parked / roof closed. I recall the camera was warmed up and the equipment was connected. I don’t believe it is an ASCOM thing, since I manually aborted the sequence from SGP, which ran the end of sequence commands and the mount immediately parked / roof closed as expected. I manually disconnected the equipment.

This is more worrying - losing some imaging time is one thing but half an hour after I manually aborted, it started raining… I’ll disable restart for now and would appreciate if you could take a look to see if acting on Unsafe conditions is missed somehow…

log file.

@buzz

This is odd and not related to the original issue reported. There is literally nothing in the logs that indicates SGPro even started to recenter on target. Do you recall any specifics on the recenter UI? Like the icons on the left of each step?

The image display in SGP had a misty shot from the recentering and the bottom status said something like attempting to recenter. I checked the PHD2 screen and it clearly was having fun trying to find a star too.
AAG cloud monitor showed a clear patch of about 10-15 minutes which matched the time of the restart. Looking out the window at 4.30, it was cloudy, no visible stars and the roof was still open. I did wonder if this was anything to do restarting or just one of those things that only occur when an unusual set of conditions occur in a certain sequence. I did think it unusual that an unsafe condition did not override any other state and set things in motion.
It’s not my best time of the day, next time, I will take some screen grabs, or start a screen capture video and explore the status windows. I will hunt out the safety monitor logfile. Sorry I cannot be more helpful.

I have just had the same sort of issue, tried the “restart” for the first time tonight. everything started as normal and expected, I then created an unsafe condition(drop of water on rain sensor), warning popped up, roof closed, mount parked, camera stayed cooling. After a few minuets the condition became “Safe” and the 300 second countdown began, as soon as it got to 0 the warning popped up again and the whole session was abandoned…ccd warmed up, But there was no unsafe condition showing, the indicator was green and my cloud watcher was showing safe.

Log
https://ws.onehub.com/files/3fdq2gvg

@martin_h This issue was addressed in the latest beta.

Ahh Ha…will download and give it a go.
Many thanks.

@Ken

Ken - I guess there are two things here - the warm up and the general equipment disconnect. Putting the warm-up to one side, I am puzzled by the logic to disconnect all the equipment, including the safety monitor, if one is only going to immediately connect again and poll it to see if safe conditions have returned. On the warm up - since one doesn’t know how long the unsafe conditions will prevail and it doesn’t block the startup (now fixed), each situation is different and it will be what it will be…

thanks for fixing the temp dialog warning roadblock so quickly

Double check that disconnect all equipment is not enabled:

For restart we should probably warn if that’s enabled or maybe even disable it. Those two things should be mutually exclusive

Jared

I understand - but sequence end to me would be either the completion of the sequence or timing out when it gets light in the morning? Up to that point, there would be no harm in just leaving the equipment connected and checking for safe conditions to return? I guess it’s splitting hairs now.

1 Like

Yes, I can see that too… We may make the “restart” and “end of sequence” less coupled. Currently restart is somewhat after the fact. So the sequence ends due to Unsafe and this triggers the sequence to start again (exactly like if you had clicked the “Run Sequence” option). Currently there is not a lot of difference between the sequence ending due to unsafe, completion, no available targets, or error. There probably needs to be a little more seperation.

So “End of Sequence” is a little overloaded here.

Jared

Sorry but it did it again, paused for unsafe and as soon as safe returned it claimed it was unsafe and shut down everything. Safety monitor is clearly showing green(safe)
unsafe

I think there must be other mechanisms that indicate unsafe other than the safety monitor. I just had a start up sequence abandon and there isn’t a cloud in the sky. It might be the guider didn’t get going?

www.mainsequencesoftware.com