SGP 2.4.0.2681 (Beta 9) fails to Stop PHD2 2.4.1e on meridian flip


#1

Ran a meridian flip last night, but Beta 9 failed to stop PHD2 even though it reported the autoguider stopped. As it slewed the lost star alarm in PHD2 kept binging until I manually stopped the autoguider. Then when I manually started the autoguider after the flip, SGP reported that I didn’t have an autoguider connected and asked me if I wanted to connect and recalibrate - wasn’t able to detect that PHD2 was already guiding.

Logfile here: https://www.dropbox.com/s/q23gixjeddiupgs/sg_logfile_FailStopAutoGuider_20150130204440.txt?dl=0

Note: After this happens there is a plate solve fail, ignore that - I didn’t roll the roof of my observatory off far enough and plate solves on the inside of the roof really don’t work well!


Autofocus stuck on 1s exposure
#2

It would be much easier to track the problem down if you were also able to attach the corresponding phd2 logs so we can correlate the 2.


#3

I have the guide log turned on, but not the debug log. Which do you need? And if you need the guide log, then where is it saved? Do you need me to turn on debug logging as well?


#4

Found the log file location, so is the guiding log of use or do you need the debug log (sorry, next time…).


#5

From the SGPro side, everything looks fine. We can take a look at the guide log if you want to post it. From, SGPro, this is all we know:

[30/01/2015 9:13:25 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Stopping the Auto Guider
[30/01/2015 9:13:25 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Sending Telescope command to execute meridian flip

The command after “Stopping the auto guider” would not have been sent if a failure to stop was detected. Correlating on the PHD2 side is required at this point.


#6

Actually looking at the logs a bit more. It looks like you manually ran this meridian flip? Right now we have a policy that SGPro is not allowed to modify the guider state unless a sequence is in progress.

Then when you actually did start the sequence, it doesn’t look like there is any problem:

[30/01/2015 9:21:02 PM] [DEBUG] [Sequence Thread] PHD2: Auto Resume
[30/01/2015 9:21:02 PM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Guiding
[30/01/2015 9:21:02 PM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Guiding

#7

There is a setting in PHD2 to “Stop guiding when mount slews”. Is this setting enabled? Even this was enabled, I am not sure if it will automatically resume guiding after the mount stops slewing.

Peter


#8

OK, didn’t realize that guiding wouldn’t be stopped if I did the meridian flip manually. Had a bunch of technical issues with focusing - all my own fault - didn’t realize I had forgotten to manually set the filter so SGP kept taking 1sec exposures - not sure why it kept defaulting to 1sec though as I thought it would default to the 8sec set in the “Exposure time:” setting for OSC in Auto focus options? It’s complicated because I have a Manual Filter wheel setup for my DSLR because it has clip-in filters and I can then set up with individual AF exposures for each clip-in. Does SGP expect to use the OSC=8sec setting if a filter wheel is present? Should I have a null filter in the Filter Setup (named “None”) set to 8sec so SGP doesn’t default to 1sec AF exposure?

Once I set the filter it did start taking 20sec exposures but by the time I got all this figured out it was past the meridian and so ran the meridian flip manually. Figured since PHD was guiding when I did the manual flip that it would stop as per usual - I know better now.
…Keith


#9

Ok… this is apparently something we should clarify in the manual I suppose. SGPro doesn’t really know if you have an OSC camera connected. The “OSC” exposure length setting in Auto Focus is meant to represent the focus time when no filter wheel is connected (so basically we make an assumption that you have an OSC, but we really don’t know). So your idea about throwing in a “fake filter” to your connected filter wheel is legitimate. Then, you can set this non-existent filter (empty filter) and use all the properties of it, including AF exposure time. The lesson here is that if you have a filter wheel connected, can only use AF times as defined in the filter list. If you have no filter wheel connected, you will use the OSC exposure length.

I will modify the 2.4 docs to reflect this.


#10

Thanks for the explanation. I figured that SGP might be ignoring the OSC setting if a FW was present. I’ve set up a filter as “None”, as I probably should have that anyway for when I’m not using a clip-in.
Keith


#11

With this PHD2 setting, I had an associated issue at startup. I had “stop guiding when mount slews” enabled in PHD2 and when the sequence automatically started up, slewed, centered, I had a warning message that the guider was not guiding but only after the centering action- I need to repeat the error and establish the logs but it looked like PHD2 did not start up again after the centering action’s slew. I don’t want to wind up Ken and Jared unnecessarily but if anyone else has noticed anomalies with this PHD2 setting, can you keep both logs and we can work out where to post the query.


www.mainsequencesoftware.com