SGP no longer able to resume PHD2 after slew to target


#1

This has happened in several sessions now, and I’ve been manually re-starting PHD2 to work around it. (But really, between weather and imaging cam hardware problems, there’s hasn’t been much imaging the last six weeks anyway.) After a slew, PHD2 will have one or more good guide stars in the field. SGP will try to resume guiding, and then the image displayed by PHD2 will go back and forth between a normal image showing the guide stars and an image that looks like some kind of noise pattern - mostly solid white, but with a few vertical lines. SGP eventually gives up and goes into recovery mode. SGP 2.3.15, PHD2.4.1. The SGP log is here:

https://dl.dropboxusercontent.com/u/58468743/sg_logfile_20150213175549.txt

though I don’t see anything unusual. The problem begins around 7:02:44. PHD2 works fine when I start it manually. It’s only getting SGP to resume it that is causing trouble. I can’t say for sure whether I saw this when I tested 2.4 - I didn’t have much luck auto-focusing my SCT the night I tried it, so had to move back to 2.3. Then I started having camera problems anyway, and have had little imaging since.

Thanks for any help. I know you guys are snowed under. Well, figuratively - you’re in Texas after all, not the northeast! :slight_smile:

Kevin


#2

I recommend you move to 2.4 beta 13. You (in 2.3) are using an older, unreliable communication mechanism that has been deprecated. With respect to AF, if you specify you have a central obstruction, your AF should remain very close to 2.3’s measurements. SGPro 2.4 uses a much more reliable communication method with PHD2.


#3

Thanks Ken. I tested it with 2.4.13 and PHD 2.4.1f last night and it appeared to work. Not that I got any actual imaging in. Soooo many random problems! Guide cam wouldn’t initialize, then the settings were wrong, then the power supply to the FW failed, etc. I got it all straightened out, then clouds rolled in.

Kevin


#4

I had a similar problem when setting up my 2nd setup. (2.3.15 & 2.4.1)
As soon as the autoguider was trying to settle, the image in phd started to flicker, not being able to pick up the (obvious) guidestar and it ended up in aborting within a couple of seconds.
I’ll try the 2.4 beta this week.


#5

Make sure you update to the latest PHD 2.4.1 version. I think they’re on 2.4.1g or something now.


www.mainsequencesoftware.com