SGP not syncing with EQMOD


#1

I’m in the trial period of SGP and am attempting to get the software to sync with my mount, the plate solves work well and claim to be solved, but the resulting solve data it not passed to EQMOD.

The EQMOD software still displays the wrong position as does the Telescope tab of SGP Control Panel. Even when the plate solve says “The Telescope has been synchronized” and the correct position are shown in the Plate Solve dialog, the EQMOD window still displays the old position.

Any ideas?

Thanks


#2

Hi,
I had the same problem with my Orion Atlas mount.
I cant find my post about that right now (maybe it was lost on the Forum crash).
Someone, who also had this issue, suggested that I should downgrade the EQMOD driver. I have done so, however I have had no time to test if it corrected the issue.

Regards,
Erik


#3

I’ll try that, hopefully I have time to do that and get clear skies before my trial runs out!


#4

2nd update: Call off the dogs, everything is working fine now. apparently there was some confusion between where my mount was starting up from. I parked the mount, manually set the mount to be pointing at Polaris and then unparked and slewed accurately.
Now syncs work great, this software is looking more and more impressive.

A quick update, this evening I tried versions 1.23S, 1.24G, and 1.27I of the EQASCOM driver, and tried both using the Dialog and Append on Sync options. None of these worked, solves all still solve quickly and accurately but not passing the data to EQMOD.

I’m running SGP on a Mac and connecting everything through VMWare, could that be an issue? All other functions appear to work fine, slewing, tracking, imaging etc


#5

Could be. I never had success with VM. Perhaps boot into Windows using Bootcamp and give it a shot.


#6

I re-activate this post.

I have the same issue with SGP, Eqmod and my Neq6ProII mount.
Sometimes (i.e. an error, a problem with meridian flip, etc) the scope losses its position and I have to totally re-sync it.
In most cases, the plate solve is OK, and indeed SGP says that “The Telescope has been synchronized”, but it’s false.
Eqmod shows the wrong position.

I’ve realized that the only solution is closing SGP, turning off the scope and beginning again.

I thought that the problem was that the actual eqmod position is very far from the real one… but I’m nor sure.
Perhaps the problem is that there is other software pointing or using the Eqmod driver, as PHD2 or my Observatory Roof driver.

For syncing again, I exit PHD and the Roof controller ([Talon6 Observatory dome/roof][1]), I switch on again SGP and the scope, make a plate solve and now the sync is OK. Why??

In the log files, when Syncing doesn’t work, I get that:

[06/11/2015 22:43:32] [DEBUG] [Telescope Thread] Plate solving scope frame successful, scope is synced, writing FITs header info…
[06/11/2015 22:43:32] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 3,9322553192 Dec: 75,7571486168
[06/11/2015 22:43:32] [DEBUG] [Telescope Thread] ASCOM Telescope: Error in Sync : SyncToCoordinates() RaDec slew is not allowed while scope is not Tracking. (System.Reflection.TargetInvocationException: Se produjo una excepción en el destino de la invocación. —> System.Runtime.InteropServices.COMException: SyncToCoordinates() RaDec slew is not allowed while scope is not Tracking.

I have looked for that error “RaDec slew is not allowed while scope is not Tracking” but I don’t really understand it. I got the error with both active tracking and not at the Eqmod driver…

I can provide if necessary some logs files, where you can look for that string: “RaDec slew is not allowed while scope is not Tracking

sg_logfile_20151106223307.txt (82.9 KB)

sg_logfile_20151106231546.txt (641.1 KB)

sg_logfile_20151108223914.txt (102.9 KB)

Thanks
Fernando
[1]: http://observatoriosspag.es/index.php/es/spag-monfrague/equipo/84-o-a-r-spag/361-talon6-2.html


#7

This is an error from EQMOD. It looks as if the driver thinks that the mount is not tracking and so is throwing the error. You need to ask on the EQMOD group.

ASCOM specifies that Slews and Syncs involving Ra and Dec coordinates are only allowed when tracking - and slews and syncs to AltAz coordinates are only allowed when not tracking.

Chris


#8

Hi Chris,
Thank you for your response.
After a week, I can not sync anymore!!
I don’t know what’s happening.
I tried indeed with Maxim and Pinpoint, and it doesn’t sync.
Same thing in SGP.
I tried with eqmod 1.28k and 1.28m.
It’s very annoying!!


www.mainsequencesoftware.com