SGP starting next frame before dithering is finished


#1

Win 7 SGP 2.4.1.5. PhD2 stops guiding while running dither. Watching the target I can see no new x’s appear. SGP then starts the next image frame. 10 seconds go by before I see another x on the target as PhD finally starts guiding again. It then takes another 15 seconds for PhD to get back within the 2 arc second circle, and by then the image is ruined. Obvious double stars visible. I do have it set to a very high dither, but SGP should still wait until the guiding is settled at less than 1.5 arc seconds to start the next frame. Here’s the log. https://www.dropbox.com/sh/dr6dxzbexbx7o9b/AADD57XOyvV-K0Ferj7Vw2mda?dl=0
PhD2 also seems to skip frames. I watch the x’s on the target, and about every fifth one takes twice as long to appear as the 2 second shutter speed that I am using. Should I perhaps be reporting this to Open PhD2 instead?
Dean


#2

The settle parameter of 1.5 is pixels, not arcseconds. You likely need to make this value a good deal lower. Looking at your logs:

[5/4/2015 2:26:52 AM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Guiding
[5/4/2015 2:26:52 AM] [DEBUG] [Sequence Thread] Waiting for Auto Guider distance to fall below 1.5
[5/4/2015 2:26:52 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:52 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:52 AM] [DEBUG] [Sequence Thread] Distance is below 1.5, starting timer…
[5/4/2015 2:26:53 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:53 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:53 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:53 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:54 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:54 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:54 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:54 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:55 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:55 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:55 AM] [DEBUG] [Sequence Thread] PHD2 distance request…
[5/4/2015 2:26:55 AM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.3…
[5/4/2015 2:26:55 AM] [DEBUG] [Sequence Thread] Distance stayed below 1.5 for 3 seconds, done settiling…

So it looks like the guider isn’t moving all that much. Or if it is it doesn’t seem to be reporting it. It’s also possible that it moved so far it lost the star and it’s taking a while to get back on track? Although I didn’t see anything that would indicate that being the case.

Thanks,
Jared


#3

Thanks Jared,

And that was the problem alright. I have PhD2 set to display arc seconds, and forgot that the setting for the dither was set in SGP in pixels. With my setting of 1.5 pixels, that worked out to more than 6 arc seconds. Now that I changed the setting to .2 pixels,SGP waits for PhD2 to get back within 2 arc seconds before starting the next frame.

Dean


www.mainsequencesoftware.com