SGPro 3.0.0.X Issue Thread


#61

I understand that it’s 45 days from release. It’s just that 3.0.0.5 was only released a few days ago yet the expiry was 10 days when I installed it, not 45 days from release as I expected. I was wondering if maybe something went wrong with my install such that the expiry timer didn’t get reset. Or is the 3.0.0.5 beta supposed to expire next Friday?
…Keith


#62

3.0.0.5 was actually a minor fix to 3.0.0.4 and since it happened shortly after 3.0.0.4 we opted not to reset the beta timer. The release date on the website is technically incorrect for 3.0.0.5 but the initial release of it never made it up there but it was shared in the forum via dropbox.

The release of SGP3 will be out before the beta runs out. It will also reset the trial counter so everyone can still have a chance to check it out that was on the beta.

Thanks,
Jared


#63

Ah, I see. Makes sense now Jared. I’ll await the SGP3 release.

…Keith


#64

Did 3.0.0.5 break something with PHD2 and Paramounts? I’ve had no trouble for six months, but after upgrading to 3.0.0.5 PHD2 commands are no longer getting any motion from the mount. Andy is thinking it’s an SB problem, but maybe something changed in SGP? However, reverting to 3.0.0.4 hasn’t fixed this. Logfile for 3.0.0.5 is here:

Kevin


#65

Never mind - it was the windows update/ASCOM mess. A newer update solved the problem, and 3.0.0.4 is running smoothly tonight,


#66

In target settings, Location (J2000) ----------- (i) info box. If the (i) icon is clicked on a unmodified new sequence target 1 creates an object reference exception error.


#67

Hi Ken and Jared,

SGP 3.0.0.7 works quite well but I have observed a couple of issues:

  1. The target list box settings cogs get mostly covered up by the scroll bar on the right when I have at least 4 targets (e.g. a mosaic). The window width is not adjustable. I can still get the settings box up by clicking on the little piece of the cog that is visible.

  2. The visibility curve is not correct for the object. FITS headers written by SGP have the correct time so SGP has the right time.

The first screen snippet shows both problems. The second, from C2A, shows the proper visibility curve for comparison purposes.

Regards,
Kent

C2A Capture


#68

It is interesting about the visibility curve - I have not seen this problem myself, it has been very accurate. Have you double checked location and time zones?


#69

Hi Buzz,

I could not find a place within SGP to set the location and time zone. SGP should, however, be able to get the date/time info from the OS and geodetic location from the ASCOM mount driver. Perhaps it needs geodetic location and time zone as settings but I can’t find them; where are they? BTW, I’ve been using SGP for years (but that doesn’t mean I know much). SGP parked the scope and closed the dome at the proper time per the end time of the target even so.

Regards,
Kent


#70

Aha! That may explain things. Time is set by the PC, location is set in the user profile manager. You put in your details there and then save. I noticed that when I went over to 3.0.0.7, I somehow lost my user profile on an existing sequence. If you click on the drop-down arrow beneath the Target Data and File name settings in the sequence, you can then apply the user profile to a sequence. I think that will fix your issue.


#71

Hi Buzz,

Thanks. I had forgotten that the User Profile Manager had location. However, it was all there and set as default for new sequences. I re-applied the profile anyway but get the same result. I’m sure I’ve messed something up here but don’t know what.

Kent


#72

Hi Buzz,

Ok, I found it. It WAS the location. Although the values were right, somehow the latitude got changed to South instead of North. I don’t know when that happened. It produces the correct results now.

Thanks for your help,

Kent


#73

I did wonder. The two altitude graphs were almost inverted. You were down under!


#74

A trivial thing, and likely something I’m doing incorrectly … or maybe Windows update:

IMAGE 01: Target Settings Time-Constraints window shows NGC2392 starts at 55.2deg elevation and 7:57pm tonight. Stops at 42.4deg elevation and 1:52am tomorrow morning. This is correct, however … after using the graph to set these values, there is neither the solid green circle, nor the bold red X to mark start and stop. This is true whether or not the elevation values are “locked”.

IMAGE 02: Solid green circle and bold X only show up once you select below 20deg elevation tomorrow. Note also the odd “-90deg” values in the Time-Constraints window.

My user profile is (pretty sure) accurate for my location. I also tried the above examples with an auto populate profile (Kilgore TX). Both sets of data were consistent and produced the same results.
This behavior is the same with my OBS computer and Home computer.

SOFTWARE:
SGPro v3.0.0.7

OBSERVATORY computer:
Dell Inspiron 3847, Intel i3-4150 @ 3.50ghz, 8gb ram
Win 10, 64bit, v 1709, build 16299.125
Update current as of December 24

HOME computer:
Dell XPS8910, Intel i7-6700 @ 3.40ghz, 16gb ram
Win 10, 64bit, v1709, build 16299.192
Update current as of January 10


#75

Apologies for the quality of the images.

Mark


#76

Problem appears to have solved itself. Both computers were shut down for a couple of hours. Upon reboot, the markers for start and stop worked as they should.

Mark


#78

When launched, SGPro produces a system error when checking for updates (Object not set …). Any suggestions or ways to disable auto update checking? SGPro will run once the error is acknowledged.

UPDATE
Solved this one - it was a firewall issue.


www.mainsequencesoftware.com