SGPro 3.0.0.X Issue Thread


#1

Hi folks,

Please post easily reported issues here directly. If your issue takes a bunch of screen space, please consider making your own thread and then linking to it here.

I can no longer keep track of individual posts coming in… any help keeping this beta organized will be greatly appreciated.


Sequence Generator Pro 3.0.0.3 Beta is Released for Testing
SGPro 3.0 Issue Thread
Sequence Generator Pro 3.0.0.4 Beta is Released for Testing
Sequence Generator Pro 3.0.0.2 Beta is Released for Testing
Sequence Generator Pro 3.0.0.1 Beta is Released for Testing
#2

Got a different message from Avast this time:

Last time, on 3.0.0.0, it just wouldn’t complete the download, this time the download completed but the file was quarantined at installation.

Bob


#3

Hey All,

Got an Unhandled Exception for you here and how to produce it in 3.0.0.1

System.NullReferenceException: Object Reference not set to an instance of an Object

  1. Open SGP 3.0.0.1

  2. (Target 1 will be in the sequencers Target List) - Click it’s little cog wheel to the names right

  3. Click the info button to the right of Location (J2000)

  4. There’s your unhandled exception

Note: This is only happening with default Target names appearing as Target 1, Target 2, Target 3 etc
If you pick a target from the F & M wizard & load it into the sequencer, that works ok

This exception has to be related to the default target names ei Target 1, Target 2 etc. Manually
changing the name from Target 1 to M33 in the sequencer still produces the exception.

Regards
Paul


#4

Is it possible to make a general point here ?

When the Planner comes up it is ‘Glued’ to the Target Settings box

There are other boxes born from the sequencer which when opened are also
glued to their respective boxes.

Is there any change of Ver 3, at some point, having an option so these glued windows can be free floating instead and appearing in the center of the screen or near the bottom etc ?, I find this really annoying sometimes as the planner is quite a long box and when it opens about a third of it is off the right hand side of my screen.

Just a suggestion
Paul


#5

In the planner, is it possible for SGP to remember which checkboxes I have checked & unchecked for next time when I open the planner

???

Cheers
Paul


#6

@Ken

I was able to download 3.0.0.1 but the installer presents this screen:

and then after about 10 seconds, just crashes. Tried running it multiple times. I did not try to uninstall v3.0.0.0 before installing v3.0.0.1.

Charlie


#7

It depends on your intent I suppose. Do you want these options saved because you want to view all target graphs the same way or do you want to view each target a different way?

I am not sure about this one… not able to reproduce


#8

@ Ken,

Personally ?..All the same way


#9

Ken/Jared

I’m not sure this is applicable to the current 3.0.0.n Beta release virus checker issue but it sure bit us on a new alpha release last week:

https://social.technet.microsoft.com/wiki/contents/articles/32288.windows-enforcement-of-sha1-certificates.aspx


#10

Hi Gents,
No problem but just a couple of questions about installation. No doubt this has been covered before but I can’t find it.

  1. I’m a current user of v2.6.0.23. Does v3.0.0.1 require an uninstall of my current version, or is it a separate and stand-alone version?
  2. Can you clarify what you mean by your posted statement “…unless: You do not intend to purchase SGPro 3.0”. I simply don’t uderstand your intent.
    Thanks for your help and such a great software.
    Mark

#11

@Ken

I uninstalled v3.0.0.0 and tried to re-install v3.0.0.1 but had the same failure. An attempt to reinstall v3.0.0.0 also failed. So, I then attempted to re-install v2.6.0.20, the version I have been using since it came out. Installer failed the same way.

Rebooted system and saw message that my antivirus software was cleaning my system. When reboot completed, I opened Bitdefender 2018 and saw this:

So a recent update to Bitdefender 2018 is now seeing SGP as a possible virus and blocking its installation. I have not delved deeply into BD but will see what I can do to whitelist SGP or disable BD during the install.

Charlie


#12

@Ken

I tried to “white list” SGP in Bitdefender 2018 but for some reason that did not work. Turns out BD has an option called “Advanced Threat Defense” that can be turned off. Doing that allowed SGP v3.0.0.1 to be installed.

After starting SGP 3.0.0.1, I opened the Target Settings dialog box and then just clicked the " i " icon to open the graphic - got an exception. After trying a couple of things, I realized I had not entered an RA or DEC value for the target. Entering a value solved the problem.

Probably need to check for valid RA and DEC and put up an error box. Hmm, technically, 00:00:00 is valid for both RA and DEC but SGP threw an exception with those values.

Right clicking graphic does not record end time if you click more than 3.5 hours past midnight.

Some thoughts about extending the Planning Assistant concept – now that FMW is bundled, I would like to see the Target Settings dialog box support a Simbad database lookup on a target name just like FMW does. For new imagers, in particular, they often just want to take a picture of M51, for example. So being able to just enter M51 and click a lookup button to get its coordinates would be hugely helpful. If you actually want to do mosaics or to set your rotator angle or custom position your subs, etc. you would still use FMW.

Charlie


#13

SGPro 3 will install over your 2.X version unless you change the install directory. If you install two different versions of SGPro they will share the same layout settings.

Not sure how to clarify. If you do not intend to purchase SGPro 3.0, it is not in your best interest to install and test it.

Not sure what this means. Well past midnight…


#14

This might be an issue with the time of day you were running the checks (and SGPro’s interpretation of whether or not a particular time is considered today or tomorrow). Might try to see if that 3.5 hr window expands when doing the same test later.


#15

@Ken

Anytime I right clicked in the graphic later than 3:30AM to select end time and altitude, the altitude was always shown as -90. Closer to midnight, the altitude was shown correctly. This was happening around 11AM. I just repeated the experiment at 11PM and right clicks and left clicks worked just fine.

Also, I just downloaded 3.0.0.2 and Bitdefender 2018 blocked the installer. I will disable BD tomorrow and install 3.0.0.2.

Charlie


#16

Thanks Ken.

Mark


#17

Hi,

Two things to report:

  1. I have just downloaded v3.0.0.2 with no antivirus problems. During the install my antivirus, AVG, challenged the ‘ASCOMCHECKER.exe’ and I had to create an exception for the install to complete. When I tried to start SGP, AVG antivirus wouldn’t let me, saying that the app might be dangerous and has started investigating the software and would get back to me. I turned off AVG and SGP started with no problem.

  2. I had a problem with v3.0.0.0 not slaving my Pulsar Dome, well, with v3.0.0.2 again nothing happend when I clicked the slave option in the control panel. I then tried nudging the dome a few degrees from within the SGP control panel. It started moving as instructed by the nudge and then carried on to slave accurately to the mount. So, it will slave but only once the software has made a connection to the dome with my intervention. The log file is here:

Thank you,

Gav.


#18

@Ken

I have now repeated the test of the start time / end time selection in the graphic and it clearly works properly when done at 11PM and fails when done at 11AM.

I just tested at 10:30 AM and a left click picks the time and altitude correctly but does not display the green dot. Then right clicking the graphic at a point later than about 3:45 AM causes the end time to be correctly selected but the ending altitude is shown as -90. The red X is not displayed.

In the graphic, I right clicked at 3:59 AM.

Charlie


#19

I use Avast (Free edition) for AV protection on my W10 pc.

I installed 3.0.0.2 beta today after disabling Avast. It installed all fine. After installation I re-enabled Avast and I have had no problem using SGP.


#20

Just installed V3.0.0.2 beta today. I don’t seem to get anything on the planning display. Is there something I need to enable in settings?


www.mainsequencesoftware.com