'Slaved to Telescope' auto-on when you connect to Observatory?


#1

Can we get it so that ‘slaved to telescope’ is automatically selected when an observatory is selected? Seems like this would be a ‘duh’, but similar to having to the previous problem of having to go in and manually reset some of the options in regards to how it responds to your mount parking/unparking it is frustrating when you miss a night of imaging due to missing a check box. Or, make it so I can save the setting to my profile?

I’ve missed out on two nights of imaging because of this setting. I go in, I’m 99% sure I’m clicking it, and when I come out and realize it wasn’t selected…


#2

Or, a warning similar to the ‘hey, there isn’t a guider selected but one is needed, are you sure you want to continue?’ That’d be nice too.


#3

I set a message to that effect to pop up when I start a sequence to remind me to check the option. Look under [Options]
[General Options] for the spot to set the custom message.

Having said that, I agree it should stay checked by default for a saved profile. Isn’t that what profiles are for?

I assume you mean the “slave to observatory” checkbox. I might suggest as an alternative for the next version that the state of the checkbox be saved as part of a profile, but when checked it would pop up a notice when the sequence is started to the effect “are you sure you wanted this checked?” That might satisfy both concerns.


#4

This is not a profile option (I believe it’s erroneously in the profile manager, if so it needs to be removed). It should behave similar to how PHD does. IE if you have a obs and mount selected and not slaved when you hit “Run Sequnce” you should get an error. Slaving the obs is an action, not a setting…maybe the checkbox also needs to move from a checkbox to an actual button?

Also maybe when you click run sequence it just gets automatically slaved? I’ll have to think about those.

Thanks,
Jared


#5

OK, now it makes more sense. Yes, the type and position of the control needs some re-evaluation, it seems.


#6

Honestly, the automatically slaved if you’ve connected a dome/observatory would be my preference. I do like the warning similar to the ‘unpark mount’ one would be OK too. One thing I noticed, ‘slaved to telescope’ is saved in the profile. But, it unchecks when you connect your observatory for some reason, even if a mount is connected.

CCDMan, I’m gonna do your ‘fix’ for now too. Thanks for that suggestion.

I know it’s ‘user error’ :slight_smile: But it’s super frustrating. :smiley:

Thank you for the reply,
Chris


#7

Not sure what the disposition is of this request. Sorry if I’m flogging a dead horse.

I would prefer the slave tick box not to require manual execution. First one must remember to execute this even though the Scope and Observatory have been connected. Then, this selection gets canceled if the Observatory (in equipment) is disconnected. It’s not always obvious in the middle of the night that a re-tick of the box must be done upon re-connect of the equipment.
And yes, the slave tick box does show up in the equipment profile, but as mentioned has no affect on the equipment control panel.
Any of the previous posts’ suggestions would be fine with me.

Thanks,
Mark


#8

Agreed :). It’s the first thing to drop out of my cross-check. Even if it was just an option under ‘options’ to ‘auto tick slaved to telescope’ since not everyone wants this.


#9

Anything further on this? When I have it in the profile that the Obs is slaved to the mount and that profile is activated - why do I lose the ‘slave’ option already checked? If it is in the ‘constructed’ profile - surely it should stay there when the profile is activated.
If it is not part of a profile (as per Jared above) - then it has not yet been changed as far as I can tell.


#10

I agree.

I have a “roll on roof” observatory, and every night I have to remember activate at the profile the observatory type.By default it always goes to “Dome” type.
If I forget to change it to the correct one, the Slave to Telescope don’t work.
SGP finishes the sequence and it doesn’t close the roof!!.
I thing it’s a problem.
Why the observatory type is not saved??
Thanks
Fernando


#11

I know we have been avoiding this because we wanted the action to be explicit… but we are willing to concede due to the popularity of the request. Moving to the 2.5 list.


#12

This has been completed and will be in the next 2.5 beta (looking like 2.5.0.11).

Under the slave settings you’ll now find an option to “Slave on Sequence Start”, this is in the Control Panel and Profile.

Jared


www.mainsequencesoftware.com