Solves at but not ansvr local

I’m brand new to ANSVR ( running locally), and although I was able to successfully install and solve plates, some all-sky solutions failed. Moreover, a plate which successfully solves at, fails locally; even after nearly 30 minutes of solve attempts. The same image solves within a few minutes at

Here is my set-up:

Using ANSVR 0.20 on port 9123
default config (except I set solver time limit to 1200 seconds)
16’ x 11’: indices 4206 (16 to 22 arcmin)
11’ @ 20%: indices 4200 (2 to 2.8 arcmin)
I am using Visual PinPoint in All-Sky solving mode (by-passing use of local reference catalogs)

After the failed attempt, PinPoint returns the message:

“All-sky solution failed: Submission 27 took over 10 minutes, something went wrong!”
(which is weird because I had set the time limit to 1200 seconds; 20 minutes).

I’ll add that using Visual PinPoint and the USNO A2.0 reference catalog will solve the plate in seconds.

Thanks in advance for any help.

Are you sure you installed all the required catalogs? I have never had local fail to solve for me.

Hi. Thanks for looking and your question. I have indices 4200 though to and including 4206 downloaded and available to ANSVR. I double-checked the data directory, \cygwin_ansvr\usr\share\astrometry\data and see 264 files (plus the ic and ngc files); the same number shown at

I’m still trying to figure out the variables involved by carefully going through the solve results (if any) using the local (ANSVR) v. remote Locally, I am getting a 30% solve rate. I’m still working on the rate that remote gives.

I’m glad to learn from you that you’ve never had local fail to solve. There is hope, for me :wink:

Sounds like you have done everything correctly, but obviously something is out of whack. (I love that word, whack). When set up correctly, it absolutely will give you unfailing solves. For several years it was my only solver and never failed. With a fast pc, it solves in 6 to 8 seconds, quite acceptable, but not as fast as ASTAP (or Platesolve2). You should really get it working, if only for your backup solver. After you get it working (or before if you get tired of messing with it), install ASTAP. It is fast and rock solid, free and easy to install.

I have had 3 FOVs over the past several years, roughly 40’, 80’, and 150’, with resolutions ranging from .45 asec/pixel to 2.0. All solved using local ANSVR without failures. Yours is MUCH smaller than my smallest. Therein might be the problem.
I don’t think you have nearly enough catalogs loaded. I would load all of them from 5’ through 30’.
What is your resolution?

OK, thanks for your input and suggestions.

Hello Michael.

This is a long shot but it is possible that some of your index files are corrupt. I had a similar problem recently on a new install where the local server would not solve, yet the same images solved via ansrv local on my other systems. Tore my hair out trying to work out what setting I had wrong. Finally decided to check the output text of ansrv local via the local server com window (running win10 here). I noticed that it was indicating some of the index files contained unexpected data. I then re-downloaded those files and bingo, I could then solve all the images that previously would not solve.

Also, please provide the images that won’t solve. We can then test those images to see if they solve on our systems. Good luck.

Thanks for your input. Do you have any more specifics about the Watch Ansvr log window (I think that’s what you mean) indicating that “index files contained unexpected data”. I can search the log files if I know what I’m looking for. Then again, I have been watching that window and I usually see this wrt to the index fields:

Field 1 did not solve (index index-4205-11.fits, field objects 11-20).
Field 1 did not solve (index index-4205-10.fits, field objects 11-20).

Attached is an uncalibrated test image of M67 that did not solve locally, but did solve when uploaded to, shown here:

Funny we can’t upload FITS files here :slight_smile:


I just re-read your input and wanted to be clear that I had originally downloaded all the necessary files for my FOV. That is all files from the 4200 through to and including the 4206 series comprising over 31 GB of data. So its not for lack of files. And I forgot ot answer that my resolution is 1.27 arcsec/px :slight_smile: