Using local astrometry.net as only solver


#1

After a lot of frustration with it, I have decided to give up totally on Elbrus. Its “hit rate” is just too low for me and I am tired of waiting for the all-but-inevitable “invoking failover.”
The local server version of astrometry.net seems to deliver solves sufficiently reliable that Elbrus will not be personally missed.

Last night was the first session since I set astrometry.net as my only solving software.
All went well except I got flaky results from the “Center Here” function. It did not “center” on the point I had selected. It completed the plate solves and slewed the mount but centered on a point about a third of an image width “off” in the E-W direction. It did this consistently.

Any hint as to what could produce this strange behaviour?

Terry


#2

I also use astrometry.net as my only plate solver for the same reasons that you do. I had a similar problem but with meridian flips not centering. However, the results were the same as it continued to plate solve off to the side. It was suggested that I make sure that I was using JNOW or J2000 across my plate solving as well as my telescope control. I believe astrometry.net uses J2000. I had just loaded the latest version of ASCOM and noticed it defaulted to Unknown. I then changed it to J2000. I really haven’t had enough time to properly test it but I’m hoping thats it.I hope that is your problem as well.


#3

What Tim says.


#4

Thanks Tim and Chris but I do not know where to find this setting?

Terry


#5

Terry, what mount are you using? Mine is in the ASCOM driver under Settings for my G2 controller.


#6

Thanks, Tim:
I am using an AP1600. The details of my settings are as shown:

I see no provision to change the coord. system?


#7

Terry, I can’t see it either. I have a different mount and when I looked at my setup screen it let me choose JNOW, J2000 or leave it on Unknown. I really haven’t tested it since I made this change but it seemed logical that would be the problem, since my default was Unknown. I hope someone else can help you - sorry.

Tim


#8

Same… Sorry Terry :(. I wish I could help more.


#9

Again, thanks Tim and Chris.

Ray Gralak informs on the AP Yahoo group that the AP driver uses “Local Apparent (similar to JNow), which means it does no epoch translation.” There is no provision to change it and no plan to make such a change possible.

I remain puzzled. My plate solves “work.” I am able to solve to within a few pixels to ensure new subs register with those taken in previous sessions.

It seems only my “Center here” functionality that is not working.

If it’s an AP driver matter, all users of AP mounts should have the same problem?

Terry


#10

Thats strange Terry. My symptoms were the opposite. My plate solving was the one that was off while centering was usually dead on. As I mentioned, I haven’t had a chance to check my fix yet and won’t for at least another week. However, it certainly can’t hurt to have your mount and plate solving the same - JNOW or J2000. Since your mount must be JNOW, I wonder if you can change astrometry.net to JNOW? Maybe other AP mount users have modified Elbrus or Pinpoint to JNOW, if they can’t modify astrometry.net?


#11

I feel I am falling into a dark well here. I swear that I DID have “center here” working a few weeks ago. Now it centers “not here.”

What have I done in the meantime? Ditch Elbrus. Nothing else.

Elbrus seems to have pretty much totally failed the last several outings. It used to work maybe half the time? I have had a long and unsatisfactory history with Elbrus. Why it seems to have totally collapsed on me is another puzzle. While I really don’t want to do it, I suppose I could reinstall it from scratch (again!) and see how things shake out with the “center here” function. I feel I am losing, rather than gaining ground though. :frowning:
“Center here” is a function of SGP that I am really loathe to lose!


#12

Hello,
same problem as Terry here but with an eq6, non properly centering. I contacted Jared, he had reproduced the problem but he had no solution 'some month ago). May be if we are several with the same problem the solving priority of this issue can increase.
Thanks.
Pascal


#13

Terry, I have been thinking that if you can plate solve you shouldn’t have an issue with J2000 vs JNOW. Maybe the centering is something else. Now that Pascal has indicated he has the same problem with his eq6 and Jarod can reproduce it - there may be nothing you can do except wait for a fix from Jarod. No use getting frustrated by playing with different plate solvers again.

Tim


#14

Hello,
Using EQMod, I find centering does not always work, but there is a trick you can use to make it center better. Go the the dialog where you can select how you want the EQMod to use the points for goto, by default it probably says 3 points or something like that. I find that to center a target up, I have to switch that to “nearest point”. Then running the centering algorithm works.

I can’t remember why, I recall it being discussed on the EQMod yahoo group. Maybe it will help you in this instance.

Thanks,
Mike


#15

Hi Guys,

I have a EQ8 and i too ditch Elberus for the blind sync, but i also face the same issues, where the intended target is always about 1/3 of the screen off the target.

I can definitely say that this issues appears to be SGP related as i also have Maxim DL and doing the same plate solves with Pinpoint LE always puts the target bang in the centre where it’s supposed to be.

Whilst it’s not the end of the world, it is a little irritating to get up the following morning and find that you images have been ruined as the centre here function, didn’t quite work properly.

Would love to see this get some attention, or better still have Pinpoint LE capability added as i can’t afford nearly $199 for full blown pinpoint.

Out of interest, what results do people get if they use the full blown pinpoint with SGP ? do the centre here function properly ?

Rich.


#16

I believe you’re confusing Auto Center with Center Here. Auto Center is what is used when targets are switched. Center Here is invoked by right clicking on the image and choosing “Center Here”. If you’re using this “in sequence” then you’re using Auto Center.

Anyways, almost all issues with Auto Center can be tracked down to an epoch difference between the solver and the scope. Astrometry.NET uses J2000 and I’m guessing your scope is set to use JNow.

Center here does indeed have an issue that we’re looking into that happens at certain camera angles. Auto Center has no known issues with any of the solvers. I think if you had Pinpoint you would see the same issue as Pinpoint also uses J2000.

Thanks,
Jared


#17

Hi Jared,

Sorry for confusing matters by not using the correct terminology. I was referring to “Auto Center” whilst running a script, where it doesn’t seem to centre the target properly.

Also, as an example of another problem i have, lets say i clear eqmod of all sync points and then slew to a star in Cartes Du Ceil and then perform a blind sync…it solves the image and adds a sync point into eqmod, which they shows in cartes du ceil that i’m a good way off target, so i then slew to the star again, and it’s still about a third of the screen away from centre.

I now do the same process with MaximDL and Pinpoint LE, but when i slew to the star after a pinpoint solve, it puts the star bang in the centre of the cross-hairs.

I’m not saying that this is a fault of SGP, just trying to understand the difference between Astrometry.Net and Pinpoint LE, and why they give different results.

Not sure if i can change eqmod to use j2000, but i’ll have a look.

Richard.


#18

I was out imaging last night, again only using astrometry.net. I have set eqmod - in the setup screen - to J2000. I also have - as Mike suggested - set eqmod to use the nearest point. Both “Center Now” (I assume this uses the same logic as “auto center”) and “Center Here” centered the target within 50 pixels. Richard, I can’t explain why Pinpoint LE with Maxim DL and astrometry.net with SGP will give you different results. I do know that the latest version of eqmod mine defaulted the epoch to “Unknown” which I changed to J2000.


#19

Thanks Tim,

I found the “unknown Epoch” setting in Eqmod and changed it to J2000, and i’ll go back and change the pointing model to nearest star and see how i get on.

At least if i have everything running J2000, then i at least know that everything is working using the same model and should produce consistent result.

Rich.


#20

Now I have to go and check the epoch in my instance of eqmod. All I know is that the pointing mode works for me every time, but I bet you I also have the wrong epoch.

Will try tonight maybe and see!

Glad the nearest point worked Tim!

Mike


www.mainsequencesoftware.com