Using PinPoint with the USNO libraries


#1

I recently took the time to download the USNO A2.0 libraries for use with PinPoint. I configured Visual PinPoint to use that library rather than the GSC/1.1. Visual PinPoint is very fast with the USNO libraries. However, I then discovered that SGP does not support the use of the USNO libraries. My primary interest in the USNO libraries is that I am about to move my imaging platform to a 12" Meade LX850-ACF scope and at 2400mm focal length, the FOV is going to be somewhat small. I am thinking the larger number of stars in the USNO may be very beneficial when plate solving at the longer focal length.

cm


#2

USNO is currently not supported but may be added in a later version. GSC should be adequate for FOVs down to 20 arcminutes.

Thanks
Jared


#3

I am wondering if you’ve made the move to the LX850. I have yet to find an ASCOM driver that does a decent job with this scope. SGP slews the scope and immediately starts imaging even before the scope has started the slew using the Universal driver. The lx200GPS doesn’t even connect.

Ugh, so far there is very little value in SGP for an LX850 mount.


#4

Mick:

Sorry for not being more specific – I referenced moving to a 12" Meade LX850-ACF OTA. I have an Astro-Physics mount. However, I believe others have posted that they have been using the LX850 mount with the ASCOM drivers.

My speculation is that the issue is Meade’s StarLock software. After the LX850 mount slews to a target, it initiates its own internal “plate solve” and auto centering routine. The ASCOM driver is probably reporting successful slew when in reality, the LX850 mount is moving around doing its own centering. I believe SGP allows for a delay after slew. Setting this to a couple of minutes might allow the LX850 to finish its own plate solve / centering routine before SGP initiates an image capture.

cm

Charlie Miller


#5

Ah, I’ll give that a try. In my own software (Linux based) the scope doesn’t return a “Slew Done” until the whole plate solve routine is complete and the final slew is made. I assume the ASCOM driver would not report to the host that the scope was done slewing until the scope did itself. I also understand there is a problem with the Universal Meade ASCOM driver if the host tries to start and stop tracking. Maybe that’s the problem as well. I’ll run some tests with the delay and see what happens.

Thanks.


#6

That’s how things are supposed to happen for a synchronous slew…however that’s not always the case. We even attempt to protect against that in SGP by querying to see if “Slewing” is set.

Jared


#7

Yes but that’s in control of the driver, not SGP unfortunately. I think the issue here is that the LX-850 has three modes of operations:

  1. No high precision pointing (HPP) - just goes to the DEC & RA based on best calculation
  2. User based HPP - when asked to go to a location it first goes to a bright star from its database of alignment stars that is nearby the coordinates, asks the user to center the star in the eye piece and press enter. It then does a local sync on this to improve it’s precision. This is the LX-200 mode.
  3. StarLock HPP - Just like #2 but the LX-850 uses it’s own imaging cameras to find and center the alignment star precisely and then finally goes to the object. This is extremely accurate!

On any slew once the final position is reached, the StarLock automatically finds a guide star, acquires a lock, and begins guiding the scope. This occurs every move.

From the API when you do a GOTO in #1 it reports “Slew complete” when it reaches the target. It does this in #2 as well since the computer doesn’t know about the user centering option so it reports “Done” after the slew to the alignment star. But in mode #3, unique to the LX850, it slews, then sends a “auto aligning” message, and performs the second slew, and reports “slew complete”. Then the Starlock starts it’s auto-guide acquisition. It has a separate status you can read that goes from acquiring, guiding, or idle and it must be on “guiding” before the camera should be used. It takes about 15-90 seconds for an auto-centered slew and auto-guide lock.

I’m thinking the writer of the current ASCOM driver doesn’t have an LX850. I think it starts a slew then waits for the scope to write back to interface, ignoring what it writes and simply tossing the characters because in the previous scopes anything back means the slew worked if the status is OK. What it should do on the LX850 is wait for the “slew done” message, then check the status of the StarLock and wait for it to change to “guiding” and finally report the slew is done.

In addition to being unaware of the unique LX850 slew method, the driver currently also always reports the first slew after connecting as “complete” even before the scope starts moving. It also exhibits the same behavior on the first slew of a sequence randomly. I think this is because it accepts anything as the “slew done” and it’s not flushing the scope’s buffer after connection so there is some message waiting. If any time it gets out of sync with the send-receive it accepts the pending messages from the scope as the “slew done” message and dumps the buffer so the next slew works.

Here’s theSGP work around I have come up with in the mean time:

  1. When creating your equipment profile set a 60 seconds as the “mount settling time” using the Universal ASCOM Telescope Driver for Meade.
  2. When creating a sequence add an event at the top that performs a slew. I call this the same name every time (slewone) and have it acquire a 30s dark frame. What you slew to isn’t important but I set it to the same coordinates as the first real event in the list. It’s a pain, but it works. Using the same name makes sure I don’t clutter my disk with bad files.
  3. Set all events to “Slew To” instead of “Center” on event start. The LX850 is extremely accurate if you do a good drift align and you’ve made sure your OTA is completely orthogonal on your mount (there is a procedure in the onboard software to assist with this – it’s worth it).

When you start a sequence the first event may fail to wait for the scope to slew. If this happens, abort, reset the seq, and try again. It will now work perfectly fine for hours on end.

The 60 second delay is enough for the HPP auto-center on the alignment star, slew to the final coords, and the StarLock to acquire a guide start and start auto-guiding. What could really assist in SGP is another delay after slewing to give the StarLock time to start guiding. This would allow someone with a well aligned permanently mounted scope (me > :} ) to turn off the auto-HPP but still give the auto-guider a chance to lock on nights with good seeing even with a bad ASCOM driver. I wish I was a better Windows programmer as I would tweak the hell out of the driver myself and being unable to do so sucks but I’d rather work on a good Linux sequencer then Windows ASCOM drivers anyway. :smiley:

I’m finally getting to do some good SGP testing. Woo hoo!


www.mainsequencesoftware.com