Waiting on camera Temperature to start


I saw that last night in the middle of my sequence that I got a message in the lower left corner that said:
Waiting on camera temperature to start sequence. This caused me to not image for 3+ hours last night due to this stall. I had been imaging for many hours prior to this happening, I saw this once before with another camera. It isn’t uncommon for me to try and reduce the temp after the sequence has started, i’ve done this for years, the power for TEC for that camera would stay at 100% and it would cool the camera to the best of its ability, but never stop the sequence to wait for it. I did this last night as this was first light for a new ZWO 533. This behavior is by design I guess.

Is there a toggle to disable the ability to stop a sequence after it has started if the temp drops below the desired temp that I have not found?


In control panel \ camera \ Camera Cooler there’s the general settings, so if you untick the three bottom boxes, it would then be a manual process to set your temperatures, but at the least I’d tick the ‘cool down when camera connects’ so that have a starting point.

So - was the reported temperature wrong too high? I had this some time ago and then realized that SGP was starting up again after an unsafe period, in which it warmed the sensor up.

Funny, that’s what it looked like to me when I noticed it had been waiting for 3+ hours. (I had just woken up, it was around 4am), but my first thought was it looked like the temp had been reset to -35, which was the profile cool down value. I thought I went to sleep with it set to -28 which is really all the 533 would cool down to at that time. I also have seen this behavior in a prev release of 3.1 in December where the when I checked on the sequence midway through the night, it was waiting and this was well after it had acquired many subs, and not after a restart that I did. I don’t know if that was actually the case last night. Because it was a new camera and I “touched” usb devices, Windows in it’s infinite wisdom always re-enables Power Management on USB hubs/devices which is not good cause many hours into the sequence, I noticed that SGP was stuck Downloading a sub. I forgot about the power management stuff. and just tried to restart SGP, and then i couldn’t connect to the focuser, and that’s when i remembered the USB stuff, I forgot to uncheck PM for all the USB devices, and they were all checked, so i disabled them (didn’t reboot) maybe i should have, and then started SGP again and connected everything ok and continued the sequence. So last night I did actually start up SGP after many hours, got things going and went to bed. It may very well had been set to -35 and I ignored it when starting the sequence, but I’m pretty sure I waited till I saw it capturing subs before I left it to go to sleep. I did see a Bad happenings message, it looks like it recovered from losing a guide star a little after 1am, would that restart the sequence?

GNS was running and I didn’t get an alert that it was waiting for temp, maybe that’s a setting I don’t have checked, I didn’t look into that yet.

My question in this thread was in 3.0 and 2.7, temp change would never stop a sequence midway and wait for a temp, at least I never saw it and I have been using SGP for a couple of years. Is there a way to disable this new 3.1 feature?

Here is the log, in case anyone wants to see that.


Sorry Tom - missed your question. I think you disable the restart after unsafe in the options.

Moving to feature requests…

Summary: Add option to disable TEC temperature safeguard.

The reason this safeguard exists is that most will want to use calibration frames captured at the same temperature as the lights. This coordination requires that SGPro wait until some common temperature (+ or - 3 deg) is achieved. I am not saying your workflow is wrong… just a brief explanation of current behavior. We are hesitant to add new settings to SGPro, but if there is demand we will do it.

Thank you Ken. I was really just looking to understand if SGP always acted like this of this was new (stopping a seq midstream if the temp shifted too much from the set temp). I was getting to know a new camera and lowered the temp after the sequence had started when I saw that I was set to my starting temp but only at something like 50% TEC power. I wanted to see how cool it could actually get the camera, I didn’t think the sequence would actually pause and wait for the camera to achieve the temp I set it to after it was started. Maybe SGP always worked this way and I never ran into this. I was thinking that if I set cooler temp real low, it would stay at 100% and only get as cool as it could, I didn’t anticipate it pausing the sequence, that’s all.

I agree with you on wanting matched temps, but calibration frames are cheap compared to clear skies, especially lately which is why I merely wanted to understand if this was proper behavior since I had never run into this happening in the past. I do not think there is demand for this feature, I won’t do it again, lol.


This check has been around a long while. I can’t remember when it was added, but I think in 2.6. As to why it complained mid sequence, I will need to dig through your logs for that.