Xagyl Filter Wheel Stops Working


#1

I have a Xagyl 5 x 1.25" motorised filter wheel that has been working with SGP. I recently upgraded to the latest version of SGP and now the filter wheel will randomly stop responding to SGP when I tell it to switch filters.

I have a ttached the log from when the error occurs. You can see the error right around the 9:10PM mark.

I should also add that I updated the firmware of the wheel to latest version and all of the drivers, etc are full updated.


#2

I use Xagyl too. In my case I loose USB connection and it causes communication loss and failure. Did you try to run it off a different program, like Nebulosity? That would eliminate USB connection part.
Once I put a filter a wrong way, that wrecked havoc for sure. Other than that this FW was good to me.
Ian


#3

Thanks for the help. I ran it off nebulosity and noticed that when it was getting to position it was overshooting it and then getting an error. I tried with the standalone application Xagyl provides, and it was doing the same thing.

I reverted back to the previous firmware and did a reset & recalibration and it seems to be working now.


#4

Glad it worked out! I guess, I’m not upgrading to that firmware version anytime soon:laughing:


#5

It’s almost always the USB cable. Try a different one. I actually used rubber bands to hold my USB cables onto my Xagyl.


www.mainsequencesoftware.com