Can I do this?


#1

I am pretty much finished with trying to get PHD2 to work with SGP. It is now nearly three weeks of trying, and failure.

So I want to at least try to use my new equipment, which is the ZWO ASI 1600mm Cooled camera, Atik EFW2 filter wheel, and my new Moonlight auto focus.

Is there a way to have PHD2 work outside of SGP, while my camera, filter wheel, auto focus, mount control, and plate solving work within SGP?

At the rate I am going with trying to solve the intricacies of SGP, it will be a few years of hard work to solve all the problems I somehow encounter. I know it is me, as like I have said before, complex software just leaves me scratching my head.

I hope someone can come up with a solution so I can actually start using my new equipment. Caley Ann


#2

PHD2 is always working outside of SGPro… it’s its own application. The only interaction between SGPro and PHD2 is to dither, settle, pause and resume. If you are having difficulty with SGPro sending those commands to PHD2, then just select “No Auto Guider” from the Auto Guider tab in the control panel. SGPro will take images as if there is not auto guider in use.

In general, we don’t see a lot of issues reported about this specific interaction so I am not 100% sure what is ailing your setup. You might have explained it in another thread… I read and respond to so many I have likely forgotten. Is it possible you are having a local firewall issue with the port PHD2 uses for communication?


#3

Actually, SGP IS sending the requests to PHD2 to calibrate, but no matter how I set things up in SGP, calibration always fails. But when I run BYEOS, with PHD2, I get no problems. That tells me there is something not right going on with SGP. Apparently it is being too picky about how things are calibrated, and just says fail.

I really don’tr know how to explain it. I am not savvy enough with the equipment and software to make a proper statement about what is happening. I just know that when SGP is working with PHD2, it always fails, and when BYEOS is working with PHD2, I never have a problem.

I’ve tried what seems like dozens of permutations in SGP setting up the equipment portion of auto guiding, but it doesn’t seem to matter.

Yes, I have asked for help everywhere, it seems, and people have been wonderful trying to help me work through the problem. Apparently I am too dumb to figure these things out.

I just don’t know if I am making a mistake, or that my system is preventing things from working. I still think I have something entered wrong in SGP, or possibly am missing entering something in a window I don’t know about. There seems to be a lot of pop up windows to deal with.


#4

i think in another thread here someone suggested that you manually point your rig at the celestial equator, start PhD, and ask it to calibrate by hand. then make sure PhD is set to save the calibration and automatically re-load it whenever it starts (auto restore calibration). if you have a permanent or semi-permanent observatory, you’re done. turn on Dec compensation in PhD and connect PhD to the mount and it will automatically fix up the calibration vectors whenever your scope points at a new target.

if you set up and break down every night, then do the calibration manually at the beginning of the night. you just don’t want PhD to ever do a calibration in response to a “start guiding” command from SGP.

if for some reason PhD is insisting upon calibrating each time you start guiding (meaning if SGP makes the command or you click the crosshair button in PhD), then something’s messed up with the PhD configuration. you need to get to a point where SGP will start guiding no matter where it’s pointed without re-calibrating.

bottom line is - i’m pretty sure SGP never asks PhD for a calibration, unless you have ticked “Re-calibrate auto guider when target changes” in SGP’s autoguider settings. if you’ve done the calibration by hand in PhD and asked it to auto restore calibration + do dec compensation, you definitely want that SGP setting turned off.

rob


#5

I have all that done as suggested, and things still do not work. That is what is frustrating me. I’ve done everything that everybody has suggested, and the darn thing is still acting like a stubborn mule.

I will give it one more try tomorrow night with my new equipment setup. If it still refuses to cooperate, I will have to try another something, possibly new control software.


#6

so by “does not work” you mean that every time you try to start guiding PhD tries to calibrate?

what happens if you never start SGP and just do everything in PhD manually?

finally are you using PhD2 (OpenPHD) from http://openphdguiding.org/ ?

rob


#7

Perhaps you could post more info on your settings in both PHD and SGP? Screenshots of your SGP control panel autoguide window, the settings window inside that, the PHD settings (each tab of the brain window) and equipment profile settings?

What versions of PHD or PHD2 are you using?


#8

I am using version 2.6.1 for my astronomy computer. This computer never goes online, so I don’t have AV software on it. But the firewall part of windows does allow my PHD and SGP, and all the other astronomy programs to talk to one another.

As for taking screen shots, I haven’t a clue as to how that is done on my windows 8.1 computer. I’ve tried out in the shed, and I just cannot seem to get it done

As for calibration, I did what I was asked, checking a box in PHD which remembers the calibration done. When using BYEOS, PHD2 boots up, I connect the equipment, and it starts guiding because of that calibration. But when I boot up PHD2, then start up SGP, and try to run the sequence I created, SGP tries to calibrate regardless of the settings I put in PHD2, and that calibration attempt ALWAYS fails. I do not have recalibrate when target changes checked anywhere in SGP. SO I am guessing it is something else in SGP that is causing the fail. I doubt the PHD2 version is the culprit, unless the new release was specifically written to address issues with SGP.


#9

Image showing autoguider control.


#10

Use the snipping tool in accessories.


#11

Nope, I was told to make sure it wasn’t checked. And it still seems that SGP sends a command to PHD2 to recalibrate. Something is weird.


#12

Is your sequence the following:

Start PHD2, connect equipment, calibrate PHD2, check guiding, stop PHD2
Start SGP, connect equipment, slew to target, start events.

With the calibrate unchecked, SGP should start PHD2, let it settle and start events. If this is not happening, you do need to send screen shots of your setup to get help.


#13

I think it may be possible that I am leaving PHD2 running when I bring up SGP, and the Sequence I wish to use for the night. I am guessing that causes a conflict. I will make sure I stop PHD2 guiding before bringing up SGP, and starting up the Sequence.

Will let you know what happens. Right now I am too tired to get out and fiddle with the equipment and software. My workday was a bear. Caley Ann


#14

I always start guiding with PHD2 before I start SGP sequence without issues. I like to make sure that PHD2 found a guide star to guide on and continue to autoguide before I start SGP sequence.

Peter


#15

It sounds to me like you have a calibration settings issue. BYEOS is doing a remembered calibration, but for whatever reason SGP is trying to do a calibration, it’s failing.

So what happens if you start PHD and force a calibration (ie not load a previous calibration)? Does it fail, or success? Again, what are your settings in PHD. Doesn’t need to be screenshot, just let us know somehow.


#16

PHD2 Guiding will always calibrate on startup unless you tell it not to by enabling the option to restore calibration data from a previous execution:

You probably don’t want the option in SGP to calibrate on new target. If the target is at a high DEC location, calibration doesn’t work well.

You didn’t say what version of SGP or PHD2 you are using. I suggest obtaining the latest “dev” release of PHD2 since there are a lot of useful new features that really improve PHD2 Guiding.

Finally, having a standard startup procedure is very useful to insure good communications between PHD2 and SGP. Don’t start SGP until the following is completed:

  1. Point the scope at the zenith and have a decent guide camera focus.
  2. Start PHD2 Guiding and have it calibrate.
  3. With PHD2 guiding on a star, invoke the Guiding Assistant; let it run 60+ seconds; take the
    recommendations.
  4. Monitor the guiding graph and make sure it looks good; that is, guiding corrections typically staying within the +/- 1 arc second range.
  5. Stop guiding on the star.

Now start SGP. It will automatically connect to PHD2 and manage PHD2 without you having to do anything. Note: there are a lot of parameters in PHD2 Guiding. You will have to become familiar with what they do and you may need to tweak the defaults to get good guiding with your equipment.

Charlie


#17

I wholeheartedly agree with Charlie’s advice, but I would clarify that the zenith is not necessarily the best place to point the scope for calibration. We recommend calibrating close to declination zero (celestial equator), and within an hour or two of the meridian. It helps to nudge the guide star north before starting calibration to take up any dec backlash.

Andy


#18

Hi Guys, I will try all this advice when I get out to the observatory. Caley Ann


#19

I think I finally have a night without wind and/or clouds, so I will try all the great stuff you GUYS provided. I wrote everything down in order of when it is to be done.

I probably am adding to my misery, but I finally decided I need to get my filter wheel and new mono camera online. So I will be doing all the stuff you gave with the new equipment, once I can achieve focus with the new camera.

Hopefully tonight will be the night things work, though I have learned not to count on it. Even if I get one thing working, I will consider it a victory. Caley Ann


#20

I set up the “Auto Restore Calibration”, and ran on a star as close to Meridian and Celestial Equator as I couid manage. I then slewed to the opposite side of the Meridian to a target I wished to take one frame on. PHD2 calibrated fine, and started tracking.

My guide scope focus was worked on last week, and seems to be ok.

I also ran the “Guiding Assistant” for quite some time. I don’t know if it takes into account the mechanical errors of my mount, but I wanted to allow it to do so, if it does. I ran things for about 10 minutes. Two items to the right of this Assistant mentioned changing figures to 10, which I clicked “OK” on. It also told me I was 15 seconds off on my polar alignment, and recommended I fine tune things. I have tried several times to get things better, but my Celestron CGEM DX isn’t the smoothest thing to adjust. But I will give it a go again.

I hadn’t reaccomplished the balance of my mount with the addition of the new equipment, so tracking probably suffered because it really was severely out of balance.I accomplished the rebalancing after I shut down everything, and it seems to be nice and smooth now.

As for how PHD2 guiding did after my calibration, and test with SGP, I think it is working, but the way SGP works is still confusing me. I am guessing that the long wait I had was because the camera was in the process of cooling, and hadn’t finished. I got one frame, which showed star elongation, but I am attributing that to the severe imbalance of my mount with the added equipment. I think you call it backlash.

Tomorrow or whenever I get the chance, I need to do a visual star alignment to get my mount back to where it was before my balancing act. Then I will redo my polar alignment, redo the calibration step at meridian/equator, and finally run guiding assistant again to see if things have improved.

I also found out that the software (that came on a disc) that runs my new Atik EFW2 camera is apparently not able to properly control the wheel, so I have downloaded a package from Atik that is supposed to have the new drivers. I will install them tomorrow.

I also downloaded the newest version of PHD2 guiding, but that presents a problem when it comes to my auto guider camera. It will entail me having to reinstall PHD2, and the SSAG software because, according to the instructions, any time you change the PHD2 version, you need to do that.

I will have to again look at my Equipment Profiles to ensure they are correct/complete, and then make a Sequence with the object I wish to photograph, along with adding the appropriate Equipment Profile.

I think that once all the above is done, I will be ready to try again. Will let you know how things work. I just need lots of practice with all the various software and equipment, and I think something will eventually start clicking. Caley Ann


www.mainsequencesoftware.com