Mount is parked or not tracking message

Hello,

I know this is an old thread, but just wondering if any answers have been found to this issue?

It happened to me for the first time last night during a sequence, actually more than once, then seemed to go away. The mount was still tracking and guiding. It’s an Avalon uno.

The only thing that I was doing that might have been different was dithering, don’t know if that’s anything to do with it.

Thanks

Chris

I am still having this issue too. It’s clearly across several different mount brands so it can’t be something related to a specific mount driver. From what I’ve gathered it’s from SGP checking ASCOM mount status and for some reason it’s saying parked when it’s not and tracking fine. Is there some kind of workaround here at least? The only solution I’ve found is to disconnect the mount when I start a sequence, which essentially takes away much of the automation of this program, or to just use a different capture software, as this has never happened in others. Please look further into a solution.

The error you posted is coming from your ASCOM driver. It would likely need to be something addressed by the driver author.

Thank you,
Jared

Hi Jared,

Thanks for your response. I have emailed Avalon to see what their thoughts are, however as you probably realise, this error has been posted on this forum by people using Skywatcher, Ioptron and Avalon mounts, and various other users who do not specify their mount brand.

I posted my log in a separate thread, I am presuming you saw that? An auto-ignore option would solve this problem as it seems that in all cases posted, the users mounts were tracking fine at the time the error message was posted and the sequence paused.

Thanks

Chris

+1 for auto-ignore

Experiencing the same issue with a Skywatcher Az-Gti.

Many thanks
Minos

I also experienced that issue last night and unfortunately it costed me over an hour of capture time as I went to bed. I have ioptrion zeq25. I really would like to set it and forget it for an hour or so but it seems I cant right now. Somebody mentioned another threat that speak to that issue. Do you have a solution?

We do not have a solution… we are not fully aware of what the issue is here or if there even is one. We cannot entertain a request to ignore… That is a slippery slope. As part of the SGPro safety system, it checks to ensure that the mount is still tracking. From SGPro’s perspective, we consider the mount to not be tracking if it is disconnected or if it says it is not tracking. There is a possibility that we mistakenly think a disconnect has occurred, but it’s certainly not apparent in any way. As Jared said, the fastest way to resolution here is to have SGPro and corresponding ASCOM logs for your mount and go line by line.

I will send these. Thank you. I really appreciate you taking time to answer

I am also still getting this message after updating all my drivers and firmware. It’s been a year now. There has to be something that can be done about this. At least give us the option to ignore this specific ASCOM request causing the issue? As of right now with this situation I have basically no automation for this automation software because the only way I can use it is to disconnect the mount before I start imaging. Kind of defeats the purpose if you ask me. I am ready to switch to a different software package since devs seem to not care about fixing this. __

This response, from a few days ago, doesn’t sound like a developer who doesn’t care.

It looks more like a developer who is asking for more information but isn’t getting it.

Sending the information asked for could get a resolution, it’s more effort than posting peevish messages but could be more productive.

Hi,

I have the same problem. It is frustrating I admit. I use the SynScanMobile Ascom telescope driver. Never had a problem with it with other applications. Not sure what to do. Basically the automation / sequencer does not work as it stops on its own with no alarms. Can’t go to bed :frowning:
I want to help. If someone can tell me how to get the information files. I will surely send right away…

Thank you

Michel

It seems it is a pervasive problem. Did any of you switched to another software? I am babysitting my mount as we speak but unfortunately need to sleep sometimes. I just send my logs in another post just yesterday.

I can’t see how Ken and Jared can do anything to help while the people with the problem refuse to provide any data.

What is needed is at least SGP logs showing what SGP thinks is happening at the time the problem happens. Ideally ASCOM log for the same time showing tht communication between SGP and the mount.

The way to get these logs has been documented on this forum on many occasions.

My guess is that SGP is reading the tracking status or the isParked status and getting the response that the mount is not tracking or that it is parked. They quite correctly generate the message.

If that is the case then what should happen will depend on the state of the mount. If it really is not tracking thenthis needs to be fixed. If it is tracking but reporting that it isn’t than that would need to be fixed in the driver. Similarly for the isParked state.

But this is all speculation and nothing can be done without reliable information - and that means log files containing relevant data.

Some text feedback would have helped but even without this the problem is pretty obvious, the mount is parked. SGP is detecting this and perfectly correctly reporting that it can’t continue trying to control a mount that is parked.
This log entry shows this:

[06-26-19 18:21:28.300][DEBUG] [Main Thread] ASCOM Telescope: Error in StopMove : Illegal operation while parked (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Runtime.InteropServices.COMException: Illegal operation while parked
— End of inner exception stack trace —
at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at System.Type.InvokeMember(String name, BindingFlags invokeAttr, Binder binder, Object target, Object[] args, CultureInfo culture)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 443)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 483
at ASCOM.DriverAccess.Telescope.MoveAxis(TelescopeAxes Axis, Double Rate) in c:\ASCOM Build\Export\ASCOM.DriverAccess\Telescope.cs:line 712
at qr.kx()

Hi
But it’s not parked. It’s continues to track

Your mount is generating errors indicating that it is parked so as far as SGP is concerned it is parked. SGP can’t continue, even if it wanted to because your mount is rejecting commands to move because it thinks it is parked.

You need to find out how to unpark your mount, maybe by sendig an unpark command to it.

I wish I knew how

www.mainsequencesoftware.com