Plate solving will never work


#1

I am still in trouble, I cant believe I will ever be able to get plate solving to work. And if i cant I have no use for SGP. Terrible. Here is a portion of my log. Could anyone give me a hint as to what I need to do, to get this to work??

Thanks… and Merry xmas…

-25-17 09:14:15.120][DEBUG] [Unknown] Astrometry.NET - Waiting for solve to complete
[12-25-17 09:14:15.622][DEBUG] [Unknown] Astrometry.NET request: /api/jobs/28
[12-25-17 09:14:15.622][DEBUG] [Unknown] Astrometry.NET returned: {“status”:“failure”}
[12-25-17 09:14:15.622][DEBUG] [Unknown] Astrometry.NET solve done in 15 seconds.
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] Astrometry.NET - Solve Completed
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] Astrometry.NET - Failed to solve image.
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] *********** SUCCESSFUL SOLVE *************
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] SOLVER: True
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] SUCCESS: False
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] CONF: 0
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] BLIND: True
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] RA: 0
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] DEC: 0
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] SCALE: 0
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] FLIPPED: False
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] ANGLE (EON): -500
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] MSG: Failed to solve image
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] ******************************************
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] Auto center validation frame solve failed. Failed to solve image
[12-25-17 09:14:15.863][DEBUG] [Telescope Thread] Adding sequence level notification: Auto center validation frame solve failed. Failed to solve image
[12-25-17 09:14:27.166][DEBUG] [Sequence Thread] Something has gone wrong when centering the target, but recovery mode is NOT active!
[12-25-17 09:14:27.166][DEBUG] [Sequence Thread] Adding sequence level notification: Something has gone wrong when centering the target, but recovery mode is NOT active!
[12-25-17 09:14:27.168][DEBUG] [Sequence Thread] Error on auto center, aborting sequence!
[12-25-17 09:14:46.070][DEBUG] [Sequence Thread] DoEventGroupChange: Error in auto center (True)
[12-25-17 09:14:46.099][DEBUG] [Sequence Thread] DoEventGroupChange: Complete
[12-25-17 09:14:46.102][DEBUG] [Sequence Thread] Cannot start seqeunce. EventGroupChange failed.
[12-25-17 09:14:46.105][DEBUG] [Sequence Thread] ********* Run post sequence *********
[12-25-17 09:14:46.105][DEBUG] [Sequence Thread] SGPro capture cal frame mode is OFF…
[12-25-17 09:14:46.105][DEBUG] [Sequence Thread] Clearing timed monitoring events…
[12-25-17 09:14:46.105][DEBUG] [Sequence Thread] Checking RunEndOfSequenceEquipmentOptions, force = True
[12-25-17 09:14:46.105][DEBUG] [Sequence Thread] In RunEndOfSequenceEquipmentOptions
[12-25-17 09:14:46.106][DEBUG] [Sequence Thread] Parking telescope…
[12-25-17 09:14:46.109][DEBUG] [Sequence Thread] ASCOM Telescope: Park message received.
[12-25-17 09:14:46.109][DEBUG] [Sequence Thread] ASCOM Telescope: Sending park…


#2

Can you upload an image you are trying to solve? I’ll see if I can solve it.

Why aren’t you using PlateSolve2?


#3

I was using platesolve2. Hmmm. But I was trying others.

I dont have an image to upload. I just used my Skytools 3 to enter corordiates for M57. And while it accepted that, it still failed to plate solve…


#4

Here is another piece from my log. Still faisl. But maybe there is more info in this log??

[12-25-17 11:12:02.567][DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE complete…
[12-25-17 11:12:02.644][DEBUG] [Telescope Thread] Auto center verification frame complete. Plate solving image C:\Users\ve1drg\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[12-25-17 11:12:02.650][DEBUG] [Telescope Thread] ************* SOLVE HINTS ****************
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] SOLVER: PlateSolve2
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] BLIND: False
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] METHOD: Max Regions
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] RA: 18.9035427514483
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] DEC: 33.0544462345737
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] SCALE: 6
[12-25-17 11:12:02.651][DEBUG] [Telescope Thread] ******************************************
[12-25-17 11:12:03.352][DEBUG] [Telescope Thread] FitsFileHeaderData: Angle - 0
[12-25-17 11:12:03.352][DEBUG] [Telescope Thread] FitsFileHeaderData: Scale - 0
[12-25-17 11:12:03.353][DEBUG] [Telescope Thread] FitsFileHeaderData: RA - 18.9035427350296
[12-25-17 11:12:03.353][DEBUG] [Telescope Thread] FitsFileHeaderData: DEC - 33.054446224088
[12-25-17 11:12:03.365][DEBUG] [Telescope Thread] PlateSove2 Param: RA (RAD) - 4.94893591956423
[12-25-17 11:12:03.365][DEBUG] [Telescope Thread] PlateSove2 Param: DEC (RAD) - 0.576908919216754
[12-25-17 11:12:03.365][DEBUG] [Telescope Thread] PlateSove2 Param: Width - 632
[12-25-17 11:12:03.365][DEBUG] [Telescope Thread] PlateSove2 Param: Height - 838
[12-25-17 11:12:03.365][DEBUG] [Telescope Thread] PlateSolve2 Command Line:
[12-25-17 11:12:03.365][DEBUG] [Telescope Thread] C:\Users\ve1drg\AppData\Local\SequenceGenerator\PlateSolve2.exe 4.94893591956423,0.57690891921675,0.01838413478767,0.02437643188619,3000,C:\Users\ve1drg\AppData\Local\SequenceGenerator\Temp\psXSolve_0.fit
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] *********** SUCCESSFUL SOLVE *************
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] SOLVER: False
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] SUCCESS: False
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] CONF: 0
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] BLIND: False
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] RA: 0
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] DEC: 0
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] SCALE: 0
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] FLIPPED: False
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] ANGLE (EON): -500
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] MSG: Solve failed! Maximum search limit exceeded.
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] ******************************************
[12-25-17 11:14:13.721][DEBUG] [Telescope Thread] Auto center validation frame failed to solve. Solve failed! Maximum search limit exceeded.
[12-25-17 11:14:13.722][DEBUG] [Telescope Thread] Adding sequence level notification: Auto center validation frame failed to solve. Solve failed! Maximum search limit exceeded.
[12-25-17 11:14:13.724][DEBUG] [Telescope Thread] Auto center validation frame solve failed, invoking blind failover…
[12-25-17 11:14:13.725][DEBUG] [Telescope Thread] Astrometry.NET: Sequence endpoint data: Astrometry.NET (Remote)
[12-25-17 11:14:13.725][DEBUG] [Telescope Thread] Astrometry.NET: Sequence endpoint data: Astrometry.NET (Remote)
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] ************* SOLVE HINTS ****************
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] SOLVER: Astrometry.NET
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] BLIND: True
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] METHOD: Max Regions
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] RA: 18.9035427514483
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] DEC: 33.0544462345737
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] SCALE: 6
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] ******************************************
[12-25-17 11:14:13.730][DEBUG] [Telescope Thread] Astrometry.NET: Sequence endpoint data: ANSVR (Local Astrometry.NET)
[12-25-17 11:14:13.763][DEBUG] [Telescope Thread] Astrometry.NET convertedAstrometry.fits path: C:\Users\ve1drg\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[12-25-17 11:14:13.763][DEBUG] [Telescope Thread] Astrometry.NET - Saving file
[12-25-17 11:14:13.763][DEBUG] [Telescope Thread] SaveFileBmp16: Locking bitmap for disk write…
[12-25-17 11:14:13.763][DEBUG] [Telescope Thread] SaveFileBmp16: Opening file stream…
[12-25-17 11:14:13.763][DEBUG] [Telescope Thread] SaveFileBmp16: Writing FITS headers…
[12-25-17 11:14:13.763][DEBUG] [Telescope Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[12-25-17 11:14:13.770][DEBUG] [Telescope Thread] SaveFileBmp16: FITS block fill…
[12-25-17 11:14:13.770][DEBUG] [Telescope Thread] SaveFileBmp16: Unlocking bitmap…


#5

Please post a fits that is failing for you along with the corresponding log. Otherwise we’re just guessing.

Thanks,
Jared


#6

Platesolve 2 needs a scale and yours is set to 0.


#7

I have no fits files. Sorry. Wish I did.I am just typing in the coordinates for M57. AND running it that way.

–Ted Gervais Windsor Ont


#8

Any idea on what the scale numbers should be? I dont know.


#9

The scale will come from the particular equipment you use. You can enter your information on this web page to get a fairly close approximation of what your scale is: https://astronomy.tools/calculators/ccd (use the CCD Resolution Calculator).


#10

You can also do a blind solve to populate that info but you’ll need internet access. The benefit of doing that is you don’t have to guess.

As Joel mentioned, PlateSolve2 is not a blind solve so it needs to know your scale, angle, and approximate position. PS2 is faster than astometry.net but needs more info to solve. Astrometry.net is slower but it will solve without any information.

Thanks,
Jared


#11

Your image scale depends on the camera and scope that you use. See this image
scale calculator. http://celestialwonders.com/tools/imageScaleCalc.html

I really think you would benefit from spending some time reading through
the SGP help file, or Alex McConahay’s The First Week tutorial
http://mainsequencesoftware.com/content/SGP-The%20First%20Week.pdf.


#12

I just read through that tutorial. Really nice with the kind of info I needed.
I will adjust the data I have based on the tutorial. And my fingers will be crossed.

–Ted Gervais Windsor Ont


#13

Well I have done the reading and made changes, and yet no luck on plate solving.
What I see on the screen is that it cant find the files it needs to plate solve at :
…\AppData\local\sequenceGenerator\temp\plate_solve_image.

I am wondering --is this a Windows 10 problem? In other words why cant it find that directory?


#14

You might have several web server that uses same ports on same pc, it often happens to me on my work machines.

I still think you can have the wrong scale, but the blind solve should fix that. can you tell us please your setup (optical train) to determine the correct scale?


#15

When you try to plate solve to some imported coordinates, SGP will take a photo with your camera and put it on screen. I’m pretty sure the image stays there until you delete it. You can manually save this file as a FITS.

If you let me have this file, the intended location, your sensor’s pixel size and the focal length, I can try and plate solve it for you with Platesolve 2 and PinPoint.


#16

Ok guys. Here is what I am doing. Working only with simulated values right now. The camera I use is a stf8300 sbig. Its specs that I used for SGP is :
Size 3326x2504
5.4 x 5.4 pix size
8.3 million

I ran those numbers through a converter for camera and scope (EdgeHD C-11) and
came up with these numbers. Which I am using is SGP:
size 22.1 x 16.6 at 0.4.

I hope this is right??

FOV also turns out to be 1.

I don’t know what else to do.

I start SGP by bring up a saved profile. All the data is in place. I than bring up the focus wizard and enter an object. I fetch that image and save it. I than use that image in the SGP session. I run the session and plate solving fails.??

What more can I do. The wizard was able to bring up the image just fine. But SGP plate solving can’t do the next step??

I am lost…


#17

Can you post a FITs taken with this setup?

Also try using the Remote version of ANSVR rather than Local. You shouldn’t need to do any of this testing at night. If you have an image taken with SGP just load it, right click the image in SGP and choose “Plate Solve”. No need wasting perfectly good nights trying to get the plate solve system working.

Also here is a known good FITs that you can use to test your solving system as mentioned above. HOWEVER you should also do this with images off of your system as your scale and other settings will be different.:

Thanks,
Jared


#18

Thanks Jared in offering your help and providing this fiel…

Well I downloaded the file and ran it in the mosaic framing utility and once the image appeared I right clicked on it to run plate solve. And it failed.

So I set up a proper sequence using my paramters for my EdgeHD C-11 and ran the program and I watched that little screen come up and eventually fail.

Something is amiss. I was thinking that the whole setup was not too difficult to get things going. But there is something amiss with the plate solving. And this is the most important aspect for me.

Perhaps I should delete all things related to SequenceGeneratorPro and start over.
I don’t know what else to do. I must have made a grave error somewhere but don’t know how or where. I ran the catalogue stuff from ansvr tonight. Putin more cataloges. But things didn’t work any better with that change.

I will think a lot about this tonight. And if you think I am off track here in how I ran plate solve utility. Let me know. Maybe Maybe the framing error is not where you meant???


#19

Well I tried something different today.

|I used cntrl-i and loaded that file you sent me. Once that was up and in place \I did a right click and chose plate solving, and it worked. What a shock.

Then I started over and brought that image up in moisaic like |I did before and the right ckick on the image failed for plate solving.
And running it through the normal process also failed when it tried to plate solve.

So what I see - the plat4e solving software must be ok?? It works when I use just an opened image. But fails when the image is settled inside SGP.

Now … what next. I have all my pix data all ok ( i am sure)… so what do I fix now??


#20

What image from the Framing and Mosaic Wizard are you attempting to solve?
Can you just open up an image you’ve taken with SGP and attempt to solve it
like you did with the image I sent?

Thanks,

Jared Wellman
– Co-Founder and Developer
www.mainsequencesoftware.com


www.mainsequencesoftware.com