SGP and Pulsar Dome


#1

Just wanted to check compatibility between SGP and the new Pulsar Dome Driver. When I connect to the dome driver directly in SGP the dome doesn’t seem to track and after a while becomes unresponsive if I try to move it manually. If I connect through POTH it seems to work better. I wondered if anyone had any experience with this?
Jason


#2

Do you have the “Slaved” box checked for the dome? SGP and ASCOM Logs for the dome would help.

Thanks,
Jared


#3

Thanks for your response Jared, yes the slaved box is ticked, I will send some logs after I do a little test run tonight whilst its cloudy!


#4

Is this a complete new driver - or are they still using the Shelyak controller (& driver)?


#5

It’s a new driver and system. I had a closer look at the slave settings and the azimuth error was set way too large which will explain why the dome wasn’t moving. On the next clear night I will test with the autoguider etc to see if I get any problems re the dome becoming unresponsive


#6

sg_logfile_20160713001522.txt (436.9 KB)
part dome log.txt (1.3 KB)

Had a clear sky last night so I tried again. Still having difficulties with the dome being unresponsive during the session and at several times I had to disconnect and reconnect the dome in SGP. I have attached the last part of the ASCOM dome log as the file was too big to upload and the SGP log from one of the instances last night. I appreciate all the help.


#7

Hello @jasonwink, I’m very interested in this thread as I am about to have a Pulsar Dome installed tomorrow and I use SGP. I know that there is quite a task ahead of me to get everything set up and talking to eachother correctly, but your troubles worry me. I hope that you sort the problem and I look forward to hearing what the solutions are.


#8

SGP is great and the Pulsar dome is great too, its just trying to iron out all the niggles to get things working smoothly. The issue for me is that the dome starts off working ok and I can see the azimuth changing in SGP so I know that it is slaved to the scope, then usually at the end of an image capture or two SGP seems to be waiting for something and wont progress with the sequence until I turn off the power of the dome and restart it. Last night this happened at least 5 times which gets more frustrating as you get more tired! I have tried a sequence without plate solving, phd2 and autofocusing last week and the dome seemed to work perfectly in this instance over the course of a few hours in the daytime. I am hoping it is just a setting that or something that I have missed.


#9

Phew! That is very good to hear as I was starting to get a bit nervous. I have no dout that I will be quizzing you regularly once I connect up the computer if things don’t quite go to plan. Which, let’s face it, with astrophotography is just about everything at some point!!

Good luck with things and please do post solutions as you discover them.


#10

Hi Jason,

I hope that you might be able to help… My dome is up now and I am trying to get things running. I have installed the latest ASCOM (6.2) and the Pulsar ASCOM driver and can connect to the drive unit with the Pulsar software, but when I try to connect to the dome in SGP it fails. In SGP I select “ASCOM Dome Driver for Pulsar Observatory” in the Observatory section, but when I try to connect it just throws an error saying “Error connecting to ASCOM Dome Driver for Pulsar Observatories Dome.!”. Do you have any ideas as to what I am doing wrong, please?

Thanks,

Gav.


#11

Hi Gav,

I don’t have the new Pulsar Ascom driver (I am using the Shelyak driver with my Pulsar Dome) - but just had a quick look at the setting for your driver…only thing I see is that you must set the COM port. Have you checked Device Manager (Windows) to look at which COM port your dome is using (or set to) and then check that you have it correct in the SGP setting for the Dome.

Just a 1st thought…if that is OK, then you may have to wait for someone with this driver to get back to you.


#12

Hi Kinch,

Thank you for your reply. Hopefully you have the solution. I did try entering several different Com port numbers in the settings, but none worked. However, I didn’t check in device manager which port the dome drive is actually using. I will give that a go tomorrow morning. Fingers crossed!

Thanks,

Gav.


#13

Gav, I hope the com port setting sorted it for you. Also you will need to calibrate the dome through the Pulsar software as well.


#14

Thanks for the help Kinch - you were spot on. I checked which com port the dome was on, entered that in the setup and hey presto it works!

Jason - thank you, yup, all calibrated and slaving nicely!


#15

Great - glad to hear you are ‘up and running’. Best of luck with the new dome…


#16

Sounds very exciting Gav . . . hope you get the weather for some images with your new obs!


#17

Had the same problems last night, the dome is slaved but soon during the imaging sequence the dome fails to respond and needs to be switched off and usually re calibrated as it will often go 180 degrees out of sync. I am not sure if you can see anything in the logs i posted previously? I am attaching another log from last night, many thanks.sg_logfile_20160719020352.txt (311.5 KB)


#18

I’ve had a look at the log and there are a number of things that might be relevant.

The dome seems to connect successfully, then there’s a failed attempt to connect to a dome driver using COM7. This might be SGP attempting to connect for a second time to a dome driver that will only accept one connection, the first connection stops the second one. I’m not at all sure about this though.

There’s a timeout on CanSetShutter. This looks like a bug in the Pulsar dome, it should return false if the shutter can’t be moved.
There’s also an input string was not in the correct format error from the dome, it appears to be on CanSetShutter and on Slewing.

It may be worth seeing if there is a dome driver log and definitely contacting Pulsar. The errors seem to be reported by the dome driver and they may have an insight into what is happening.

SGP appears to be the messenger here, nothing more.

Chris


#19

Thanks Chris I have sent an email to Pulsar re the problems so hopefully they can look in to the issue with the help of the software developer


#20

Just to update you all, after a firmware update everything works now as it should and I can get some sleep at night!


www.mainsequencesoftware.com